Atlassian

Documentation for Confluence 5.5



Confluence 5.5 Documentation

Contents

Confluence USEr's GUIAE . ... ... e e e 7
Getting Started with Confluence .. ... ... . 8
About ConfluenCe . .. o 8
Dashboard . ... ... .. 9
Page in View Mode .. ... 10
Confluence GloSSary . . ... ... 12
Keyboard ShortCULS . ... ... 16
Using Confluence on a Mobile DeviCe . .. ... ... e e 20
Creating CoNtENt . . ... 24
Using the EditOr ... ... e 27
Quick Reference Guide for the Confluence Editor . .......... ... . . . ... 31
Working with Text Effects . ... ... 42
Working With LiNKS . . ..o 44
Working With ANChOrS ... 49
DiSplaying IMages . . ..o 51
Deleting an Image . . ... i 55
Working With Tables .. ... 55
Using Symbols, Emoticons and Special Characters ............ ... ... ... . ... 57
USiNg AUtOCOMIPIETE . . .o 59
Working with Page Layouts and Columns and Sections . ................. ... ... 63
Working With MacCros .. ... o 66
Activity Stream MaCrO . . . ..o 68
ANCNON MACIO . ot e 68
AAChMENTS MACIO . . . 68
Blog POSIS MACIO . ..o e 70
Change-History MacCro . ... ... e e 75
Chart MacCrO ..o 76
Cheese MaCrO . ..ot 123
Children Display Macro . . .. ... .t e e e 124
Code BIoCk MacCro .. ... 126
COolUMN MACIO . o oot e e e e 130
Content by Label Macro . ... ... 131
Content by USer MacCro . ... ...t e e e e 136
Content Report Table Macro . ... e e 137
Contributors MacrO .. ... ..t 139
Contributors SumMmary Macro . . ... ..t 143
Create from Template Macro .. ... .. e e 148
Create Space BUtton MacCro . ... ... e e 151
ExcerptInclude Macro . ... ... 153
EXCerpt MacCro . . ... . 154
EXPand MaCrO . ... ..o 156
Favourite Pages MacrO . . ... ...t 157
Gadget MacCrO . ... 158
Gallery MaCrO . ..o e 161
Global REpOrtsS Macro ... ..ot e 164
HTML INnclude Macro . . ... e e e 165
HTML MaCrO . .. e 166
IMPresence MacCro . ... ... ... e 167
Include Page Macro ... ... e 168
INFO MACIO . .. 170
JIRA Chart Macro . ..ot e e e 172
JIRAISSUES MACIO . . . e e e 175
JUNIE REPOIT MACIO . . ot e e e e e 184
Labels LISt MACIO . ... e 187
Livesearch MacCro . ... ... 188
LOremipsum MaCKO . .. .ottt e e 189

Created in 2014 by Atlassian. Licensed under a Creative Commons Attribution 2.5 Australia License.


http://creativecommons.org/licenses/by/2.5/au/

Confluence 5.5 Documentation

Multimedia MacCro . ... ... e 190
Navigation Map MacCro . ... ... 191
NetwWOrk MaCIO . . ..o 193
NOfOrMAat MACIO . . ..o 195
NOtE MaACIO . .. 196
Office EXCEl MACIO . .. ..o 197
Office POWErPOINE MACIO . .. ... e 198
Office WOrd MacCro . .. ... 200
Page INdexX MacCr0 . . ... ... e 201
Page Properties Macro . ... ... . 202
Page Properties Report Macro ... ... e 204
Page Tree MacCro . ... ... i 207
Page Tree Search Macro .. ... ... e 210
Panel MacCro ... ... e 211
PDF MaCIO .. e 213
Popular Labels MacCro . . ... . 213
Profile Picture Macro .. ... ... 214
Recently Updated Dashboard Macro . ......... ...t 215
Recently Updated Macro . ... ...t e 217
Recently Used Labels Macro ... ........ . e 223
Related Labels MaCro ... ... 224
RSS Feed MacCro . ... . 225
Search ReSUltS MaCIO .. ... ..o 227
SECHON MACIO . . .ot 230
Space Attachments MacrO . . ... ...t e 231
Space Details MaCro . ... ... 232
Space JUMP MaCIO . . ... 233
Spaces LISt MacCro ... ... 235
StAtUS MACIO . . ..ot 236
Table of ConNtents MacCIO . . ... ..o 237
Table of Content ZoNe MaCIO . . . . ...ttt e 242
TID MACIO . 246
USer LISEMACIO . . . ..o e 247
User Profile MacCro . ... ... 248
User Status LISt MaCro . ... ... 249
VieW File MaCIO .. ..o 250
Warning Macro . .. ... o e 253
Widget Connector MacCrO . . .. ...ttt e 254
Task REPOrt MAcCIrO . ... ..o e 264
Working with Drafts . .. ... 266
Configuring the Time Interval at which Draftsare Saved ........................... 267
Concurrent Editing and Merging Changes . ......... ... . 268
Resuming the Editing of a Draft .. ........ . . . . . 268
Recording Change CommeNnts . ... ... .. e 269
Creating Beautiful and Dynamic Pages .. ......... . 270
Working with Templates . ... ... 273
Adding a Template . ... ... .. 274
Creating a Page usinga Template .. ... .. ... ... e 280
Editing atemplate .. ... ... 282
Deleting a Template . ... ... ... 283
Working With BIUEPIINTS . . . . .o 284
DecCisions BIUEPIiNt . . ... e 287
File List BlUueprint . ... 288
Meeting Notes Blueprint . .. ... .. 290
Product Requirements Blueprint . .. .. ... 291
Shared LINKS BIUEPIINt . . . . .. e 293
JIRA Report BIUEPINt . . oo 294
Retrospectives BIUEPIINt . . . ... e 297
Creating a blueprint style report . . ... ... e 299
Working with the Office Connector . . ... ... .. e 305
Office Connector PrereqUISItES . . . . .o oo 305
Displaying Office Files in Confluence . ........... . . . i 307

Created in 2014 by Atlassian. Licensed under a Creative Commons Attribution 2.5 Australia License.


http://creativecommons.org/licenses/by/2.5/au/

Confluence 5.5 Documentation

Importing a Word Document into Confluence . ........... . . . 309
Editing an Office Document from Confluence ....... ... ... . . . . . . .. 312
Editing an Office Spreadsheet from Confluence ........... .. ... . . . ... ... 315
Editing an Office Presentation from Confluence ........... .. ... . . . . . . ... 318
Installing the Firefox Add-On for the Office Connector . ....... ... ... ... ... . ... . ....... 321
Importing Content Into Confluence . ... ... . 329
Importing Content from Another Wiki ... ... . 330
Importing Pages from Disk . . ... .. 331
Sharing CoN Nt . . .. 332
NEtWOTK OVEIVIBW . . . o e e e e e e 332
Likes and Popular Content . ... ... e 334
User Status Updates . ... ... 336
USINg MeNIONS . . . oo 338
Emailing a Page .. ... 340
Commenting on pages and blog poStS . . . ... 341
Printing Confluence Pages . ... ... e 343
Exporting Confluence Pages and Spaces to Other Formats . ............. ... ... ... ...... 343
Exporting Confluence Pages and Spacesto HTML . ......... ... . . .. 343
Exporting Confluence Pages and Spacesto PDF .. ... ... ... . . . i 345
Customising EXports to0 PDF . . .. ... e 346
Creating PDF in Another Language ... ... e e 357
Exporting to a Word document . . ... ... 358
Exporting Confluence Pages and Spacesto XML . .......... .. 358
Managing Changes and Notifications and Tasks . ....... ... ... .. .. 359
Watching Pages, Spaces and BlOogS . .. ... 360
Managing WatChers . ... ... 362
Subscribing to Email Notifications of Updates to Confluence Content . ..................... 363
Subscribing to RSS Feeds within Confluence . .......... .. . . .. . i 366
Using pre-specified RSS feeds . ... ... 368
Using the RSS Feed Builder . ... ... 368
Subscribing to a Network RSS Feed . . ... ... 370
Managing Notifications in Confluence . ... ... ... . . 371
Working With TasKS . . ... e 374
FINdiNg CoNteNnt . . ... 376
Searching Confluence . .. ... .. ... e 379
Confluence Search Syntax . . ... ... ... e 386
Confluence Search Fields .. ... ... .. 390
Searching the People DireCtory . .. ... ... e e 393
Organising CoONteNt . . . . ... e 394
Working With Pages . . .. ..o 394
MOVING @ Page . ... 395
CopYiNg @ Page .. ..o e e 397
Renaming a Page ... ... 398
Deleting @ Page ... ... 398
Purging Deleted Pages . ... ... 399
Restoring a Deleted Page . . ... 399
Viewing All Pages in @ Space ... ... 400
Changing the Sequential Order of Pages . ......... .. i 401
Managing Orphaned Pages . .. ..... ... 403
Managing Undefined Pages . .. ... ... 404
Using the Documentation Theme . .. ... ... e 404
Viewing Page Information . ... ... 407
Viewing Recently Visited Content . . ... ... 408
Page History and Page Comparison VIEWS . . .. ... e 409
Using a WebDAYV Clientto Work with Pages . ......... .. e 412
Working with Blog POStS . ... ..o 412
Working With SPacCes . . . . ..o 414
Viewing All Confluence Spaces . ... ... 415
Creating @ SPaCE . . .ottt e 418
Setting Up your Personal Space . ...... ... e 419
AdMINISTENNG 8 SPACE . . . . ottt 420
Editing Space Details . . ... ... 421

Created in 2014 by Atlassian. Licensed under a Creative Commons Attribution 2.5 Australia License.


http://creativecommons.org/licenses/by/2.5/au/

Confluence 5.5 Documentation

Deleting @ SPace . . ... 422
Backing Up and ResStoring @ SPacCe . . .. ..ottt e 422
ArChiVINg @ SPaCE . . .. 423
ViIiewing Space ACHIVILY . .. ... 424
Viewing Recently Updated Content . .. .. ... ... . ..t 425
Working with Mail Archives . .. ... 425
Adding a Mail ACCOUNL . . . ..o 426
Deleting Mail ... ..o 427
Fetching Mail ... ... 428
Importing Mail . . ... 428
Managing Mail ACCOUNES . . . .. .o 429
Working with Confluence Labels ... ... . . . 430
Adding Labels ... 431
Using Labels to Categorise SPaces . . ... ...t 433
Removing Labels . ... ... 434
Using Label Macros to Categorise Wiki Content ... ... ... e 435
Viewing Labels and Labelled Content . ........ .. . . ... 436
Viewing Personal Labels .. ... .. 439
Working With Favourites . ... ..o e 439
Working with Attachments . ... ... 441
Using Drag-and-Drop in Confluence .. ....... ... . . e 442
Attaching Filesto a Page . ... ... 443
AACNMENT VEISIONS . . o 445
Deleting an Attachment . .. ... .. 445
Displaying a List of Attachments . .. ... ... 446
Downloading AttaChments . . ... ... 450
Editing Attachment Properties . ... ... ... 450
Embedding Multimedia Content . . ... ... ... 451
Embedding PowerPoint Presentations inaPage .............. ... 454
Moving an AttaCchment . . ... ... e 454
Viewing Attachment Details . .. ... ... . 455
Customising ConfluENCE . . . ... e 456
Personal CustomMISAtIoONS . . . ... .ttt 457
User Profile OVeIVIEW . .. . e 457
Changing Password . .. ... ... e 458
Editing User Settings . ... .. o 459
Editing Your User Profile ... ... 461

Email Address PrivaCy . ... ..o 462
Updating Email Address . ... ... 462
Choosing a Profile Picture . ... ... e 462
Viewing User Profile ... ... 464
Viewing and Revoking OAuth Access TOKeNs .. ........ .. .. 465
Choosing your Home Page .. ... . e 467
Customising your Personal Dashboard ... ........ ... . e 468
Customising the Look and Feel of a Confluence Space .......... .. .. ... ... . . . . ... 469
Applying a Theme to a Space . ... ... 470
Configuring the Documentation Theme . ........ .. . e 471
Configuring a Sidebar . ... ... . e 480
Changing @ SPace's LOgO . . .. ..ottt e 481
Customising Space LayOuULS . . ... ... e 482
Editing a Space’'s Colour Scheme . . ... ... 484
Styling Confluence with CSS . ... ... e 486
Basic Styling Tutorial . . ... ... 488
Styling Fonts in Confluence . ....... .. e 490
Requesting Add-0NS . . . ... 491
Giving People Access to CONtENE . . . . ... e 492
Page RestriClioNS . .. ... 493
Site Administrators and their Permissions . .. ........ ... 497
Contacting Confluence ADMINISIrators . ... ... i e 497
Space Administrators and their Permissions .. ......... .. . 499
Space Permissions OVEIVIEW . . . . ..ottt ittt e e e e e e e e e 499
AsSIgning Space PermisSionS . ... .. ... 500

Created in 2014 by Atlassian. Licensed under a Creative Commons Attribution 2.5 Australia License.


http://creativecommons.org/licenses/by/2.5/au/

Confluence 5.5 Documentation

USErS @and GrOUPS . . oottt et e e e e e e e e e e e e e e e e e 503
Searching for USers . ... ... e 504
Working with JIRA In Confluence . ... .. ... 506
Working with JIRA Agile in Confluence . . ....... ... . . 508
Advanced and Special Uses of Confluence . ...... ... . . .. e 509
Working with Confluence Markup . .. ... 509
Confluence Storage Format . . ... ... ... e 510
Confluence Wiki Markup . .. ... e 528
Working with Confluence Gadgets ... ....... . e 536
Adding a Confluence Gadgetto a JIRA Dashboard ........... .. .. ... ... ... . . ... .... 537
Configuring Confluence Gadgets for Use in Other Applications .. ...................... 542
Confluence Gadgets ... .. ... e 545
Activity Stream Gadget . ... ... 547
Confluence News Gadget . ....... .. i e 548
Confluence Page Gadget . ........ ... e 549
Confluence Quicknav Gadget . ... ... ... e 552

Adding JIRA Gadgets to a Confluence Page ...... ... ... i 552
Developing Technical Documentation on Confluence Wiki .. .......... . ... ... ... .. ..... 553
Creating your Technical Documentation Space ............... it 553

Using Templates in Technical Documentation .............. ... i, 559
Re-using Content in Technical Documentation . ............. ... ... 560
Managing the Life Cycle of your Technical Documentation ............................ 565
Providing PDF Versions of your Technical Documentation .................. ... ....... 569
Exporting and Printing Technical Documentation .............. .. ... ..., 574
Essential Confluence Features for Technical Documentation .......................... 578
Confluence Add-ons for Technical Documentation ............ ... .. ... .. oo .. 587
Further Reading about Developing Technical Documentation on Confluence ............. 594

Using Confluence as a Knowledge Base . ......... . e 595
Developing an Intranet on Confluence Wiki . ... . . 596

Created in 2014 by Atlassian. Licensed under a Creative Commons Attribution 2.5 Australia License.


http://creativecommons.org/licenses/by/2.5/au/

Confluence 5.5 Documentation

Confluence User's Guide

About the Confluence User's Guide

This guide covers features and functions that are available to Confluence users and space administrators.

For information on administering your Confluence site, including customising your site, refer to the Confluenc
e Administrator's Guide.

This guide assumes that you are using the Confluence default theme. If your Confluence site has been
customised the header may look different, and menu items appear in different locations to the examples
given in this guide.

® Getting Started with Confluence

About Confluence

Dashboard

Page in View Mode

Confluence Glossary

Keyboard Shortcuts

Using Confluence on a Mobile Device

® Creating Content

Using the Editor

Creating Beautiful and Dynamic Pages
Working with Templates

Working with Blueprints

Working with the Office Connector
Importing Content Into Confluence

® Sharing Content

Network Overview

Likes and Popular Content

User Status Updates

Using Mentions

Emailing a Page

Commenting on pages and blog posts
Printing Confluence Pages

Exporting Confluence Pages and
Spaces to Other Formats

® Managing Changes and Notifications and

Tasks

Watching Pages, Spaces and Blogs
Managing Watchers

Subscribing to Email Notifications of
Updates to Confluence Content
Subscribing to RSS Feeds within
Confluence

Managing Notifications in Confluence
Working with Tasks

® Finding Content

Searching Confluence
Searching the People Directory

® Organising Content

Working with Pages

Working with Blog Posts
Working with Spaces

Working with Mail Archives
Working with Confluence Labels
Working with Favourites
Working with Attachments

® Customising Confluence

Personal Customisations
Customising the Look and Feel of a
Confluence Space

Downloads

Fror Download the Confluence documentation
/:';,:g in PDF format.

Other Resources

Confluence Administrator's Guide
Confluence Knowledge Base

Atlassian Answers
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® Requesting Add-ons
® Giving People Access to Content
® Page Restrictions
¢ Site Administrators and their
Permissions
® Space Administrators and their
Permissions
® Space Permissions Overview
® Users and Groups
Working with JIRA in Confluence
Working with JIRA Agile in Confluence
Advanced and Special Uses of Confluence
® Working with Confluence Markup
® Working with Confluence Gadgets
® Developing Technical Documentation
on Confluence Wiki
® Using Confluence as a Knowledge
Base
® Developing an Intranet on Confluence
Wiki

Getting Started with Confluence

Getting to know Confluence

The dashboard

Page layout

Spaces in Confluence
Other users

Personalising Confluence

Changing your password
Updating your user profile
Creating your personal space
Choosing the home page you see
when you log in

Customising the dashboard for
yourself

Getting notifications about
changes

Things to do

Creating Content
Adding a space

More helpful things

Keyboard shortcuts
Confluence glossary
About Confluence

Take me back to the Confluence User's Guide.
About Confluence

Confluence is a wiki. You can use it to collaborate on writing and sharing
content with your team. Your team can be as small or as big as you like. It
could encompass the whole world. Your content can be as simple or as rich
as you like. It can be just words, or you can add images, diagrams, activity
streams, web service integration and more.

In a nutshell, a wiki is a piece of software that runs on a server. It publishes
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web pages that you can read via a web browser such as Mozilla Firefox, Related pages:
Google Chrome or Microsoft Internet Explorer. The thing that makes wiki i
pages different from other web pages is the edit button. Provided that you ¢ Getting
have the right permissions, you can edit the page, save your changes, and SFarted
the updates will be visible to other people immediately. with
Confluenc
Confluence provides extra functionality that transforms it into a social e
collaboration platform: ® Confluenc
o e User's
Add a space for your team, then add a page or comment on someone S

else's page.

® Share content by writing a blog post, sharing a link or calling
someone's attention to a page via @mentions. Form a social network
and tell people what you are doing via a status update.

® Add images, picture galleries, videos and more.

Dashboard

The dashboard is the front page of a Confluence site. It provides an overview of the site, gives access to the
spaces that you have permission to view, and displays a few different lists of the most recently updated content.

You can go to the dashboard from anywhere in your site by choosing the site logo at the top left of the page.
This might be the Confluence logo, or may be a customised logo set by your Confluence Administrator.

Overview of the dashboard
The dashboard is divided into these sections:

®* Welcome message: The information that appears in the top left section of the dashboard. Confluence
Administrators can customise this message.

® Get started: A quick-start guide for administrators. This section of the dashboard is visible to Confluence
administrators and system administrators only.

It is not configurable via the web interface, but you can update or remove it by editing the site layout.

® Spaces, Pages, Network: Tabs displaying your favourite content and people, displayed in the lower left
section of the dashboard.
® Spaces displays the spaces you have marked as favourites, followed by all the spaces that you
have permission to view.
® Pages displays the pages you have marked as favourites.
* Network displays the users that you are following (or who are following you).

® Recent activity: Tabs on the right-hand side of the dashboard, displaying recently-updated content:.

® Popular displays content that has been recently created, liked or commented on. See below for
more details.
All Updates displays updates from all spaces that you have permission to view.
Favourite Spaces displays updates from your favourite spaces.
Network displays updates made by the users that you are following (or who are following you).
Space Categories displays updates from spaces in the category you have selected from the list.
On this page:

® Qverview of the
dashboard

® More about popular
content

* Notes

Related pages:

® Confluence Glossary

® Working with Spaces

® Confluence User's
Guide

Screenshot: The dashboard
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Dashboard %) Create Space
Welcome to Confluence Popular = All Updates =~ Favourite Spaces =~ Network — Space Categories
Confluence is where your team collaborates and shares ,
knowledge — create, share and discuss your files, ideas, | [2) Rollin in Confluence 5.0 18 26
minutes. specs, mockups. diagrams, and projects. Henry Tapia
About 5 hours ago
Get started g @ Meeting Notes 2013-02-11
Create a new space "_"a"‘i ’_"I“-"”Eza"‘
and start creating content. fopul s eurs =
. (2 Re: Git branches for 5.0.1 Bugfixing 1
m Invite your colleagues Fabian Kraemer
‘ to join you in Confluence. About 5 hours ago
Upload your picture - Git branches for 5.0.1 Bugfixing ™eE PO7
and edit your profile. o Steven Lancashire
About 5 hours ago
Spaces  Pages | Network (2 Team Black - Confluence 5.1 5 O2
Steve Haffenden
. Feb 08,2013
Favourite Spaces
(> Re: Git branches for 5.0.1 Bugfixing @1 91
@ Confluence Development * Chris Kiehl
8 Documentation Sandbox * About 4 hours ago
{’:) Sarah Maddox * (> Re: Search Improvements 1
Dave Loeng
. About 4 hours ago
Site Spaces Create Space
~ | > Re: Rollin' in Confluence 5.0 1
o3 3ssdiglkjaat e Henry Tapia
Iﬁ P e About 5 hours ago

More about popular content
The 'Popular’ tab on the dashboard displays recent activity of the following types:

®* Pages, blog posts and comments that people have recently liked.

® Pages and blog posts that people have recently commented on, and threaded comments that people
have recently replied to.

® Pages and blog posts that have recently been created.

'Recent’ means any activity in the last seven days.
A bold link means that you have not yet visited the page.

The activities are listed in order of popularity, with the most popular at the top. Likes, comments and content
creations are scored equally. Activity that involves people in your network ranks higher than activity not involving
your network. The most recent activity ranks higher than earlier activity.

Notes

® If you have the right permission, you can add a new space from the dashboard. Choose Create Space at
the top right of the dashboard, or on the 'Spaces’ tab.

® By default, the dashboard is the home page for the Confluence site. However, you can set any other page
in Confluence as your home page via your user profile settings.

® If your site has a custom homepage, the site logo will take you to the homepage not the dashboard. You

can still access the dashboard by invoking a URL like this one ht t ps: // yoursite. com wi ki / dashb

oar d. acti on. See Configuring the Site Home Page for more details.

Users can customise the dashboard for themselves.

Are you looking for a way to build an RSS feed? Choose Help > Feed Builder.

Are you looking for a list of the people in your site? Choose People on the header.

Administrators can customise the global dashboard that all users see.

Page in View Mode

The images below show the menus and other controls on a typical Confluence page using the default theme.
The sidebar is on the left of each page. On the right is the body of the page.
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Related pages:

Using the Editor

Sharing Content

Creating Content
Overview of Spaces

Confluence User's Guide

Go to the
dashboard
[ home page

Navigate
to other
applications

= X Confluence

8 Sample Space

2 Pages
= Blog

Spaces

SPACE SHORTCUTS

Here you can add shoricut |
to the most important contefe
your team or project. Configure
sidebar.

fa Sample Space Home
Sample Page

All about chocolate

+ Create child page

See all
spaces

Manage
notifications and
tasks in workbox

Search the
site or
space

I o ¢ o 4 -

Title and breadcrumbs
show the path to this
page

Sample page
Created by Rach Admin, last modified Dyw User just a moment ago

Two penguins find themselves togeth son an ice floe, drifting helplessly into warmer waters. The
penguins are very fond of €ac| The byline shows authors ’;the ice flow splits in half, right

een the penguins. As the and date updated waves a flipper and calls out
ocolate milk!"

Add pages,
blog posts and
other content

See all
people

Administer
the site

People Create Access your

profile or
log out

Pages / Example space Home

# Edit [2 Share

¥ Tools -

Share this

Access tools
for use in
this page

page with
other users

@) Like Be the first to like this Mo labels #

Add labels
to this page

Use the sidebar to

find your way
around the space

Section or option

Sidebar

Application Navigator

Dashboard / Home Page

Spaces

People

Explanation

The sidebar helps you to see where you are in the
space, and helps you to find pages and other content
in the space. The sidebar contains shortcut links to
important pages in your space. Space administrators
can access options to configure the sidebar and other
parts of the space. At the bottom of the sidebar is a
contextual navigation section, which adapts
depending on the page or blog post that you are
viewing. See Finding Content.

Use the application navigator for quick and easy
access to applications that are linked to your site, for
example JIRA. Confluence Administrators can add
links to the application navigator, for example
external websites.

Choose the site logo to access to the site home page.
By default, the dashboard is the home page of your
Confluence site. Your Confluence Administrator may
have set a different homepage for your site.

Use the Spaces menu to access your recently viewed
spaces and the Space Directory which contains a list
of all the spaces that you have permission to view.

Choose this option to see the people directory,
showing all the users of your Confluence site.
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Create Create pages, blog posts, and other content types in
Confluence.

Search Type text into this box to see a list of matching pages.
Select a page to go directly to it, or press Enter to use
the full Confluence search. See Searching
Confluence.

Help Go to the documentation for help and support, view a

Administration

Workbox

User

Tools
Like
Edit

Watch

Share

Labels

Add a comment

Title and breadcrumbs

list of keyboard shortcuts, or access other help
options from this menu.

The cog icon gives access to the site administration
menu. If you are a Confluence administrator or a
system administrator, you can access user and
add-on management, and other site administration
options here. (Note that the space administration
options are in the sidebar, not in the administration
menu.)

View and respond to natifications collected from
Confluence page watches, shares and mentions. See
Managing Notifications in Confluence.

After you have logged in, your profile picture will
appear at top right of the page. When you choose
your profile picture, the user menu drops down with
options to log out, access your user profile, or view
your editing history, personal labels and page
watches. You can also retrieve drafts of pages you
are editing.

Perform miscellaneous actions relating to the page.
Let people know that you like this page.

Edit the current page. (Shortcut: press e on your
keyboard.)

Add yourself as a watcher of the page, to receive
notifications of changes.

Email a link to the current page to another
Confluence user or email address.

View and edit labels (tags) attached to the current
page. (Shortcut: press | on your keyboard.)

Click in the text box to begin writing a comment.
(Shortcut: press m on your keyboard.)

The title is the page name. The breadcrumbs show
the position of the page in relation to its parent pages
in the space.

Byline Shows the original author and the most recent editor
of the page, and the date of the most recent edit.
Byline icons A small padlock indicates page restrictions. A

paperclip indicates that the page has attachments.
Both icons are clickable, leading to the 'Page
Information’ and 'Attachments’ pages, respectively.

Confluence Glossary

Administration Console
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The Administration Console is the interface for the global administration of Confluence.

Only administrators can access the Administration Console.

Administrators
The Confluence permission scheme allows the following main levels of administrator permissions:

® System Administrator — full administrative access to Confluence.
® Confluence Administrator — access to most of the Confluence administrative functions, but excluding
those which could compromise the security of the Confluence system.

Please refer to the overview of global permissions for details of the functions which each level of administrator
can perform.
CamelCase

CamelCase is a form of markup commonly used in wikis where words compounded together LikeThis without
spaces are used to create links.

In Confluence, Camelcasing can be turned on from the Administration Console.

Change Comment

A change comment is a short description entered during the edit of a page to record the changes being made in
the edit.

Child Pages

Creating child pages is a means of hierarchically organising content in Confluence. A child page can only have
one parent page.

Comments

A comment may be a remark, question, or any other additional information you wish to add to a page pertaining
to the topic the page covers. You can comment on any page or news item in Confluence.

Confluence Administrators

The Confluence permission scheme allows the following main levels of administrator permissions:

® System Administrator — full administrative access to Confluence.
® Confluence Administrator — access to most of the Confluence administrative functions, but excluding
those which could compromise the security of the Confluence system.

Please refer to the overview of global permissions for details of the functions which each level of administrator
can perform.

Custom Decorators

Decorator files are used to define layouts in Confluence. They are vmd files and require knowledge of the
language, Velocity, to edit.

Dashboard

The dashboard is the front page of a Confluence site. It provides an overview of the site, access to all spaces,
and displays a list of the most recently updated content within them.

Form Field Markup

Form field markup is a specialised markup used when creating page templates in Confluence 4.2 and earlier. It
is no longer needed, because the template editor offers form fields as an option in the editor toolbar.

Global Administrators

A global administrator is the same as a system administrator.
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Global Spaces
Known as Site Spaces, these spaces contain content on any theme or topic of your choice.

For more information about site spaces and personal spaces, see Working with Spaces.

Hover Profile

The hover profile is the pop-up you see when the mouse pointer pauses over a Confluence user's name. Use
the hover profile to follow the user, visit their profile, and more.

JIRA

JIRA is Atlassian's award winning Issue tracking and project management application.

Visit Atlassian's website to learn more about JIRA.

Labels

Labels are user-defined tag words assigned to pages to categorise content in Confluence.

Macros

A macro is a command wrapped inside curly braces {...} used to perform programmatic functions and generate
more complex content structures in Confluence.

Blog Posts

A blog post may be a journal entry, status report or any other timely information pertaining to a space.

Notifications

A notification is an email message sent to you updating you of changes to pages and spaces you choose to
'watch'.

Orphaned Pages

An orphaned page is a page without any incoming links.

Pages

Pages are the primary means of storing information in Confluence and are the building blocks of spaces.

Parent Page

A parent page is a page that has one or more child pages. It may itself be a child of another page.

People Directory

The People Directory contains a list of all users in your Confluence site. Each user's name links to their personal
space.

Permalink

A permalink is the url used to link to specific content items like comments.

Personal Spaces

Personal spaces belong to particular users, and rather than being listed on the Dashboard, are available from
the People Directory.

For more information about global spaces and personal spaces, see Working with Spaces.

RSS Feeds
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An RSS feed is a format for delivering summaries of regularly changing web content. RSS is read by RSS
newsreader programs.

You will need an RSS reader to subscribe to feeds within Confluence.

Confluence acts as an RSS reader for feeds from sites outside of Confluence.

RSS Reader

An RSS reader is a specialised RSS program (also called aggregator) that displays the contents of RSS feeds
for you. To subscribe to RSS feeds within Confluence, you will need an RSS reader.

Site Administrators

The Confluence permission scheme allows two levels of administrator permissions:

® System Administrator — full administrative access to Confluence.
® Confluence Administrator — access to most of the Confluence administrative functions, but excluding
those which could compromise the security of the Confluence system.

Please refer to the overview of global permissions for details of the functions which each level of administrator
can perform.

Site Spaces

Site spaces contain content on any theme or topic of your choice. Previously known as global spaces.

For more information about site spaces and personal spaces, see Working with Spaces.

System Administrators
The Confluence permission scheme allows two levels of administrator permissions:

® System Administrator — full administrative access to Confluence.
® Confluence Administrator — access to most of the Confluence administrative functions, but excluding
those which could compromise the security of the Confluence system.

Please refer to the overview of global permissions for details of the functions which each level of administrator
can perform.
Space Administrators

A space administrator is a user with the 'Space Admin' permission for the space. A user with this permission can
perform a host of functions relating to the management of a space and has complete access to the space
regardless of any other control settings or permissions.

Permissions for a space are only assigned and modified by space administrators.

Spaces

A space is an area within Confluence, containing your pages, blog posts and other content. You can think of
each space as a sub-site, or mini-site, each with its own home page.

There are two types of spaces: site spaces and personal spaces - see Working with Spaces.

Templates

A template is a pre-defined page that can be used as a prototype when creating pages. Templates are useful for
giving pages a common style or format.

Themes

Themes are pre-defined 'look and feel' styles which are configured from the administration menu and can be
applied across Confluence or to a single space.

Thumbnails
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As of Confluence 4.0, all images on the page that aren't links are displayed as thumbnails: when you click on an
image the full-size image is displayed in a pop-up.
Tiny links

A tiny link is the shortened url of a page which is useful when sending links to the page, for example, via email.

Trackback

Trackback is a mechanism by which two sites can stay informed each time one site refers to the other by means
of trackback 'pings’.

In Confluence, Trackback is enabled from the Administration Console.

Trackback Autodiscovery

Trackback autodiscovery is a block of code that can be placed in a web-page to describe where trackback pings
should be sent for that page. You can read the technical specification for autodiscovery here.

When Trackback is enabled, Confluence uses Trackback Autodiscovery to ping pages that are linked to, and to
advertise its own pages as being able to receive pings.

Undefined Links

An undefined link is a link to a page that has not yet been created. Clicking on the page link allows you create
the page.

User Profile

Every user account in Confluence is linked to a profile that contains user related information and options to
configuring user preferences.

Watching

When you watch a page, you receive an email notification whenever that page has been modified. When you
watch a space, you receive an email notification whenever content is added or modified in that space.

Wiki

Pioneered by Ward Cunningham, and named after the Hawaiian word for 'quick’, a wiki is a website that makes it
easy for anyone to contribute pages, and link them together.

Wiki Markup

This is the markup used in some macros and the site welcome message. You can also insert wiki markup into
the editor using Insert > Markup.

Related Topics

Take me back to Confluence User's Guide
Keyboard Shortcuts

Confluence provides a number of keyboard shortcuts that you can use to speed up your editing and viewing.
This page describes the keyboard shortcuts for the English language. The shortcut keys (letters of the alphabet)
may be different in other languages.

Confluence can display a list of available keyboard shortcuts. There are a few ways to see this keyboard
shortcuts dialog:

® Choose the help icon at top right of the screen, then choose Keyboard Shortcuts.
®* When viewing a page, press Shift+?
® In the editor, choose the question mark icon on the editor toolbar.

The keyboard shortcuts dialog shows the following information:
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® General — global, page and blog post shortcuts.
® Editor — text editing and formatting shortcuts.
® Editor Autoformatting — wiki markup and autoformatting shortcuts.

On this page:

® Keyboard shortcuts
® All screens
Editor
Tables in the editor
Autocomplete in the editor
View screen
Workbox
® Disabling and re-enabling keyboard
shortcuts
® Notes

Related pages:
® Using Autocomplete
® Confluence User's Guide

Keyboard shortcuts

The first section below describes the keyboard shortcuts that are available on all Confluence screens.
Subsequent sections describe the shortcuts specific to each type of screen.

Notes:

® |f you are using Chrome or Firefox on OS X, you may use 'Cmd' or 'Control' in the shortcuts below. Safari
users may only use 'Control'.

* We have used capital letters (for example, 'A") instead of lower case ('a") to represent keys on the
keyboard. Do not press the Shift key unless this guide explicitly mentions it.

All screens
Shortcut Action
/ Enable the quick search
Ctrl+S ® Submit (where a form is active).
® Editor -- save the Confluence page.
® Qutside the editor -- save the browser page.
G thenD Go to the dashboard
G then S Browse the current space
G then G Position cursor in the search box. See Searching
Confluence.
? Open the Keyboard Shortcut help
[ Toggle the sidebar.
Editor
Shortcut Action
Ctr+0 Apply the paragraph style.
Ctr+(1-6) Apply a heading level (of the number chosen) to the
current line.
Ctr+7 Apply the preformatted style.
Ctr+8 Apply the block quote style.
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Ctrl+Shift+A
Ctrl+B
Ctrl+Shift+B
Ctrl+Shift+D
Ctrl+Shift+E
Ctrl+F

Ctr+l
(letter I, not number 1)

Ctrl+Shift+J

Ctrl+K
Ctrl+Shift+K

Ctrl+M
Ctrl+Shift+M

Ctrl+Shift+N
Ctrl+S
Ctrl+Shift+S
Ctrl+U
Ctrl+Y
Ctrl+z

Tab

Shift+Tab

Shift+Enter

[then]
Ctrl+Shift+F

Tables in the editor

Windows

Ctrl+Shift+c

Ctrl+Shift+i

Open the Macro Browser.

Make the selected text bold.

Format text as a bulleted list.

Insert wiki markup. (Opens the Wiki Markup dialog.)
Preview the page you are editing.

Open the Find and Replace toolbar.

Make the selected text italic.

Insert a JIRA issue. (Opens the Insert JIRA Issue
dialog.)

Insert a link. (Opens the Insert Link dialog.)

See a list of suggested pages or other locations to
link to from your page. More about autocomplete...

Insert an image. (Opens the Insert Image dialog.)

See a list of suggested images, documents and other
files to embed in your page. More about
autocomplete...

Format text as a numbered list.
Save the page you are editing.
Format text with a strike through.
Make the selected text underlined.
Revert an action that was undone.
Undo the most recent action.

Indent current line (only in bulleted lists and
numbered lists).

'‘Outdent’ current line (only in bulleted lists and
numbered lists).

Force a line break without a paragraph break. This is
a line break with no extra space.

Add a task.

Hide the tools at the top and bottom of the page,
giving you a much larger editing area (a full-screen
editor).

Action Mac OS X

Copy the current table row, or the ~ Cmd+Shift+c
selected rows.

Insert a table. (Opens the Insert Cmd+Shift+i
Table dialog.)
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Ctrl+Shift+v

Ctrl+Shift+x
Alt+Up Arrow
Alt+Down Arrow

Autocomplete in the editor

Key
[

@
I

See more about using autocomplete.

View screen

Shortcut
B
C

< 4 n =z - X

w

Workbox

Key
gthenn
j

k

Paste the table rows from your
clipboard, placing them above the
current row.

Cut the current table row, or the
selected rows.

Add a row above the current row.

Add a row below the current row.

Action

Cmd+Shift+v

Cmd+Shift+x

Alt+Up Arrow

Alt+Down Arrow

See a list of suggested pages or other locations to
link to from your page.

See a list of suggested images, multimedia files and
documents to embed in your page.

See a list of suggestions as you begin typing a macro

name.

See a list of suggested users to mention.

Insert a date using the date picker.

Action

Create a blog post.

Create a child page of your current page.

Edit a page or blog post, or return to Edit mode when

previewing.

Open the Link To dialog.

Add or edit labels.

Add a comment to a page or blog post.

Share the current page

View attachments.

Return to page view (only if you are viewing page

attachments).

Add or edit watchers.

Action

Open the Confluence workbox.

Move down to the next entry in the natification list.

Move up to the previous entry in the notification list.

Created in 2014 by Atlassian. Licensed under a Creative Commons Attribution 2.5 Australia License.

19


http://creativecommons.org/licenses/by/2.5/au/

Confluence 5.5 Documentation 20

n Move down to the next natification for a particular
page or blog post.

p Move up to the previous notification for a particular
page or blog post.

Enter Open the selected notification.

u Return to the notification list after opening a particular
notification.

See more about managing natifications.

Disabling and re-enabling keyboard shortcuts

Keyboard shortcuts are enabled by default. You can disable general keyboard shortcuts for your personal editing
sessions. This setting will not affect other Confluence users. You cannot disable the editor keyboard shortcuts.

To disable or re-enable general keyboard shortcuts:

1. Log in to Confluence.
2. Open the keyboard shortcuts dialog, by doing one of the following:

® Choose the help icon at top right of the screen, then choose Keyboard Shortcuts.
®* When viewing a page, press Shift+?
® In the editor, choose the question mark icon on the editor toolbar.

3. Choose the General tab.

4. Select or clear the Enable General Shortcuts check box as required.

Notes

®* Note about supported web browsers: Please ensure that you are using one of the web browsers
supported by Confluence. If you are using an unsupported browser or browser version, some features
may not work correctly. Check the Supported Platforms page to find the list of supported web browsers
and browser versions on this page.

®* The keyboard shortcuts dialog also displays the trigger characters for the Confluence autocomplete
feature. See Using Autocomplete.

® Confluence keyboard shortcuts are consistent with JIRA keyboard shortcuts.

Using Confluence on a Mobile Device

When you view a Confluence page on a mobile device, such as an iPhone, iPad or Android device, Confluence
will display an optimised version of the page. Confluence chooses the mobile or desktop interface based on your
device. See Supported Platforms for details of supported mobile devices.

On your supported mobile device, you can:

View the Confluence dashboard, pages, blog posts, and user profiles.
Add or reply to a comment on a page or blog post.

Like a page, blog post or comment.

Watch a page or blog post.

See your notifications and tasks.

You cannot add or edit pages or blog posts, or edit existing comments, using the mobile interface.

The dashboard — the first thing you see

Screenshot: The dashboard in Confluence mobile
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Popular Recent Blogs Netwark

L JIRA 5.2 Bug Fixing

. . e i

ﬂ Re: On culture and ideas _
. F1d0¢

Workshop - "The Business
Case" - Why is Customer _
Experience Important? v

Choose a tab to see:

® Popular content — what people like in your wiki.
® Recent blogs — the latest blog posts.
* Network — updates by people in your network.

Tap the links to view the full content of a page, blog post or comment.

Searching for content and people

Tap the menu icon E to open the menu panel on the left of the page. Then type text or a person's name in
the Search box. The mobile interface offers the quick navigation search, which returns matches on page title
only. (See Searching Confluence.) To use the full search, switch to desktop mode.

Screenshot: The menu panel in Confluence mobile
Search people and conlent

Dashboard

Motifications

Tasks

Give feedback

Switch to desktop version

Log out

Viewing pages, blog posts and comments

Tap a link on the dashboard or on any other page. Confluence will display the linked page, blog post or
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comment.

You can:

* View the content, tap a link to move to another page, and interact with the page using the standard
functionality supported by mobile browsers.

® |ike or unlike a page, blog post or comment.

® Watch or stop watching a page or blog post.

® Add or reply to a comment. Confluence mobile supports plain-text comments only.

Screenshot: A page showing Like, Watch and Comment options.

Chocolate

By Sarah Maddox % Watch
Jun 18, 2012
The food of technical writers everywhere.

\ ¢ Like \

Viewing people's profiles

Search for a person's name, then view that person's user profile. Tap the options to phone, SMS or email a
colleague directly from your mobile device.

Screenshot: A user profile on Confluence mobile

Sarah Maddox ©

sarah @ atlassian.com
02 1234 5678

Call Message Email

Position Technical Writer
Department Engineering

Location Sydney

Following up on notifications

You can view and respond to your notifications on your phone or other mobile device. Tap the menu icon E
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to open the menu panel on the left of the page. Choose Notifications, and tap a notification to see its details.
You can reply, watch or like via the inline actions. Tap Open to open the page or blog post in a new page. For
full details, see Managing Notifications in Confluence.

Screenshot: Notifications in Confluence mobile

— Notifications
7 likes of Feedback requested - all ... >
Joe Clark liked Last chance for ada... >
A Re: Ul Text Guidelines >
| Atlassian Foundation's bush regene... >
- EOFY 2012: Choose your own Adv... >
~ 2 comments on Confluence fortech ... »

More

Viewing tasks

You can view and manage your tasks on your phone or other mobile device too. Tap the menu icon E to
open the menu panel on the left of the page. Choose Tasks then tap a task to see its details.

Screenshot: Tasks in Confluence mobile

— Tasks
To Do Completed
Atlassian Foundation's bush rege... »

Overview of FY12 Speaking Events >
Leave work early to pick up choco... »
Sarah Maddox — buy the chocolates >
Sarah Maddox — write the docum... >

Recommended database migratio... »
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More things you may need to know

Some macros may not appear

Confluence macros are not yet fully supported in Confluence mobile. If you view a page that contains an
unsupported macro, you will see a message inviting you to click through to the desktop version of the page.

Screenshot: Macro not rendered in Confluence mobile

View macro in desktop version
You can swap from mobile to standard Confluence and back again
You can swap from the mobile view to the standard view of a page at any time. Choose the menu icon E th

en choose Switch to desktop version.

Screenshot: The menu panel in Confluence mobile

Q Search people and content

Dashboard Bitt
Notifications 5 1 n¢
Tasks = sar
Give feedback 5 2cg
Switch to desktop version El Rag

Log out
25 £l Ser
= 2cd

You can also swap from the desktop view to the mobile view, if you are on a mobile device. Choose the option S
witch to Confluence Mobile at the top of the window.

Administrators can disable Confluence mobile on your site

The mobile functionality is provided by a plugin called the '‘Confluence Mobile Plugin'. To remove the
functionality from your site, you can disable the plugin.

Confluence mobile is a web interface, not a native app

Atlassian does not supply a native mobile application that you can download and install onto your mobile device.
Confluence mobile is a web-based user interface that Confluence displays when it detects a mobile client.

See Supported Platforms for supported mobile browsers.
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Creating Content
Do you want to add a page or a blog post? Choose the Create option in the Confluence header.

Pages and blog posts are created within spaces, so you will need the 'Add Pages' or 'Add Blog' permission for
the space. A space administrator can give you these permissions. See Giving People Access to Content.

Adding a page or a blog post

You can add pages and blog posts via the 'Create' dialog.
To create content:

1. Go to a space and choose Create in the Confluence header (or use shortcut key c).

2. Choose the type of content you want to create. You can create a blank page, a blog post, or a page
based on a template or blueprint.

3. Choose Next.

4. The Confluence editor will open. Add your content in the editor pane, or update the default content
supplied by the template.

5. Choose Save.

You can also select a space from the Create dialog to create a page in a different space to the one you are
currently viewing.

Space administrators can customise the items that are visible in the Create dialog. If any items are hidden you
will see a Show more link. See Working with Templates for more information.
On this page:

Adding a page or a blog post

Location of the new page

Using an undefined link to create a page later
Other ways to create a page

Related pages:

Using the Editor

Creating Beautiful and Dynamic Pages
Adding a Template

Working with Blueprints

Finding Content

Organising Content

Confluence User's Guide

Screenshot: Creating content
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Create ™ Help

Select space Demonstration Space Parent: Overview

Blank page % Blog post Your page will be a
Start with a blank page. ) Share news and announcements | child of this parent

Our Company-Wide Template for FAQs Team Template for Risk Matrix

Meeting Notes
Plan your meetings and share notes and actions
with your team.

AN

Your templates and
blueprints appear here

Add or customise templates for the selected space

Location of the new page

When you create a new page, that page will be a child of another page, in the space that you selected in the
'‘Create’ dialog. The parent page depends on where you are when you create the page.

Your location when creating the page Location of new page

You are viewing a page in the same space where you A child of the page you are currently viewing.
will put the new page — that is, the space that you
select in the 'Create' dialog.

You are viewing any other Confluence screen. For A child of the home page in the space you select in
example: the 'Create’ dialog.

® You are on the dashboard.

® You are on the 'Pages' view of a space.

® You are viewing a blog post.

[}

You are viewing a page in a space, and choose to
add your new page in a different space.

The space sidebar in the default theme has useful links to your pages, blog posts, and other parts of the space.
For more about the sidebar and the location of pages, see Finding Content.

Using an undefined link to create a page later

You may want to insert a link pointing to a Confluence page that does not yet exist, but which you intend to
create later. This type of link is called an undefined link.

To add an undefined link for later creation of a page:

1. Edit the page in which the link should appear.

2. Type ' to trigger autocomplete, and type the name of the undefined page. Alternatively, type the text first,
then select the text and type ''.

3. Choose Insert Link to Create Page.

When you save the page, Confluence colours the undefined link red. When someone clicks the link, the new
page opens in edit mode. That person can then enter the page name, add content and save the page, as usual.
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Other ways to create a page

You can display a button on a page, which offers people the option of creating a page based on a given
template. See Create from Template Macro.

You can import content from other Confluence sites, other wikis, Microsoft Word, and HTML pages. See Importin
g Content Into Confluence.

The Confluence APIs allow programmatic and scripted creation of pages. See our developer documentation.
Using the Editor

The Confluence editor is the tool that you will use to create and edit Confluence pages, blog posts and
comments. You can enter content as you would in a Word document, apply formatting, and embed other content
and files into the page.

Looking for a quick start? See the Quick Reference Guide for the Confluence Editor.
To begin an editing session, choose Edit at the top of a page (or press E on the keyboard).

A note about permissions: To edit a page, you need the 'Add Pages' permission for the space. See space
permissions. Someone may also apply page restrictions that may prevent you from editing the page.

An editing session
You start an editing session whenever you:

® Create a new page or blog post, or add a comment.
® Edit an existing page, blog post or comment.

While in an editing session, you can also:

Name, or rename, a page or blog post. Note that renaming has effects that you should consider.
Add a comment describing the changes you made.

Choose whether or not people watching the page get notified of the change you made.

Add labels to the page.

Confluence automatically saves drafts of your page as you work. If another user begins editing the same page
as you, Confluence will display a message, and will try to merge the changes when you save your page.

Choose Cancel (at the bottom of the page) if you want to end the session without saving any changes.
The session ends when you choose Save.

When you create a new page you can choose the location where the page should be saved. You can also move
a page after it has been saved, to make it a child page of a different page, or to move it to another space.

To see changes between different versions of the page, look at the history of the page.
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On this page:

An editing session
The editor
Toolbars
Embedding content in the page
Things to help you work faster
® Autoformatting
® Autocomplete
® Autoconvert for pasted
links
® Drag-and-drop for
external images and files
® Drag-and-drop within the
editor
® Keyboard shortcuts
® Finding and replacing text
® Enabling and disabling
autocomplete and
autoformatting

Related pages:

® Quick Reference Guide for the
Confluence Editor

® Page in View Mode

® Working with Tables

® Working with Page Layouts and
Columns and Sections

® Displaying Images

® Working with Links

® Using Symbols, Emoticons and
Special Characters

® Confluence User's Guide

The editor

Screenshot: The Confluence editor

Blank Space / Pages / Blank Space Home / Sample Page

Sample Page

Paragraph ~ B I U A ~ ¥4~

i
11
11
[l

|
]
il
=

& H~ | +-

»
p

== ?

frhis is a sample page

a 0 % What did you change? Notify watchers Preview CEVCW Cancel

Item Explanation
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Page title

Page content

Editor toolbar

Restrictions

Attachments
Labels

Change comment

Notify watchers

Preview

Save

Cancel

Toolbars

From the toolbar you can:

merge and split cells.

editor).

Type the name of the page. This name is used in
links to the page.

Add the words, images and other content that forms
the content of the page.

Use these tools to format and colour content, create
lists and tables, indent and align text, and insert other
content into the page, such as symbols, links,
images, multimedia files and macros. The toolbar
also provides the find and replace option, help, and
full-screen editing options.

Control who can view or edit the page. See Page
Restrictions.

View, and manage, the attached files on the page.
Add labels to a page, to categorise the page content.

Type a comment that describes the changes you
have made.

Select this option to prompt Confluence to send an e
mail notification of your changes to people who are
watching the page.

See how your changes will appear, without saving the
page.

Save the changes you have made to the page.
(Keyboard shortcut: Ctrl+S).

End the editing session, without saving any changes.

Apply paragraph styles and character formatting (such as bold, italics, superscript).

Choose colour for text.

Create numbered and bulleted lists.

Set the indenting and alignment for text and images.

Create links to other pages, attachments, anchors and external resources.

Add tables, and add, remove, cut and paste rows and columns, highlight cells, rows and columns, and

Insert other content into the page, such as images, multimedia, attachments, symbols and markup.
Use macros to add other types of content, such as a list of JIRA issues or a table of contents.

Add layouts and columns and sections to your page.

Find and replace content within the page that you are editing.

Hide the tools at the top and bottom of the page, giving you a much larger editing area (a full-screen

Note: The full-screen editing option is available in Firefox, Chrome and Safari. It is not supported in
Internet Explorer. The editor remembers your full-screen preference the next time you edit a page.

Screenshot: The editor toolbar
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Paragraph ~ ||B | I (U | A ~ %A ~ |i= | i= iz | =|= +- |9 A
Paragraph Strikethrough & Image
Heading 1 Subscript & Link
Heading 2 Superscript [ Attachment
Heading 3 Monospace Q symbol
Emoti

Heading 4 Clear Formatting © Emoticon

{1 Markup
Heading &

= Horizontal rule
Heading &

i= Task List
Preformatted
@ User Mention

¥ JIRA Issue
@ Info

Quote

= Status
Gallery
= Table of Contents

2 Other Macros

Embedding content in the page
Choose Insert on the editor toolbar to include any of the following types of content on your page:

An image.

A link to another Confluence page or external URL, or a link to an attachment or image.
An emoticon or symbol, or a horizontal line.

A macro. Choose either a specific macro, or Other Macros, from the Insert menu.

Things to help you work faster
Autoformatting

You can type Confluence wiki markup directly into the editor to have Confluence auto-format your text as you
type. To learn more, choose ? on the editor toolbar and choose the Editor Autoformatting tab. See also See
the Quick Reference Guide for the Confluence Editor.

Autocomplete

When editing a page or blog post, you can enter a trigger character to show a list of suggested links, media files
or macros to add to your page. This feature is called ‘autocomplete' and provides you with a fast editing solution
if you prefer to use key strokes rather than pointing and clicking with the mouse.

Quick summary of autocomplete:

Type: To see suggested:

[ pages and blog posts
! multimedia files

{ macros

@ mentions
For details, see Using Autocomplete.

Autoconvert for pasted links

When you paste URLs into Confluence, the editor will analyse what you are pasting and automatically convert it
into something that will display well in Confluence. Examples include:

Created in 2014 by Atlassian. Licensed under a Creative Commons Attribution 2.5 Australia License.


http://creativecommons.org/licenses/by/2.5/au/

Confluence 5.5 Documentation 31

YouTube videos

JIRA issue queries

Google Maps

Confluence pages, blog posts, comments, user statuses, user profiles.
Shared screenshot links from Skitch

And more.

Drag-and-drop for external images and files

You can drag a file from a location outside Confluence, and drop it directly into the editor. For example, try it with
images, video files, audio files, Office documents, and PDF files. The contents of the file will be embedded into
the page or blog post. Please refer to the following pages for more information:

® Using Drag-and-Drop in Confluence — Using Confluence's drag-and-drop feature, including details about
its requirements and configuration.

® Displaying Images — Embedding images onto a Confluence page or blog post.

®* Embedding Multimedia Content — Embedding videos, audio files and other multimedia files onto a
Confluence page or blog post.

® Displaying Office Files in Confluence — Embedding Office and PDF files onto a Confluence page or blog

post.

Drag-and-drop within the editor

Working within the editor panel, you can drag an image or a macro from one location on the page and drop it
into a different location on the page. Hover your cursor over the image or the macro placeholder. The cursor

changes to a drag-and-drop icon % and you can click the image or macro and drag it to a new location.

If you want to abandon the drag-and-drop action, press Escape. The image/macro will return to its original
position.

Note: For the drag-and-drop of images and macros in the editor, Confluence supports the following browsers:
Chrome, Firefox, and Internet Explorer 9. (Drag and drop in the editor does not work in Internet Explorer 8.)

Keyboard shortcuts

To see the keyboard shortcuts available, choose ? on the editor toolbar.

Finding and replacing text
Click the find / replace icon on the toolbar, or use the keyboard shortcut Ctrl+F (Windows) or Cmd+F (Mac OS).

Search matches are highlighted in yellow. You can step through the results one by one, replace the matching
text strings one by one, or replace all matching strings at once. This find and replace feature works only within
the current page.

Enabling and disabling autocomplete and autoformatting

You can enable or disable the editor's autocomplete and autoformatting functions, by editing the settings in your
user profile.

In summary:

1. Choose your profile picture at top right of the screen, then choose Settings.
2. Choose Editor under "Your Settings' in the left-hand panel.

For more details, see Editing User Settings.

Quick Reference Guide for the Confluence Editor

This page is a quick-reference guide to using the Confluence editor. The aim is to give you enough information
about the editor's features for you to experiment yourself, rather than describing every possible shortcut key,
autocomplete feature or toolbar option.

This guide is for people who want to use the autocomplete, autoformatting and keyboard shortcuts provided by
the editor. If you prefer to use the toolbar options, the editor itself should be mostly self-explanatory.
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Introductory tips

1. Jump in and start using the Confluence editor. The editor toolbar contains the most important buttons
you'll need for creating and editing content.

2. Use the keyboard shortcuts. For example, type these characters in the editor panel:

® Type [ (angle bracket) to insert a link.
® Type ! (exclamation mark) to insert an image or other media.
® Type { (curly bracket) to insert a macro.
These characters will trigger the autocomplete functionality, prompting you with a list of suggestions to

?
finish off the entry. For more shortcuts, click the help icon "~  on the editor toolbar.

3. See how to undo the autocomplete and autoformatting actions. To undo something that autocomplete or
autoformatting has done, press Ctrl+Z (Windows) or Cmd+Z (Mac).

On this page:

® |ntroductory tips
® Seeing it in action
Using the most common formats and features
® Formatting text
Using symbols
Linking text
Using lists
Using tables
Using macros
® Displaying images and multimedia
Enabling and disabling autocomplete and
autoformatting

Related pages:

® Using Autocomplete
® Using the Editor
® Confluence User's Guide

Seeing it in action

This short video shows the autoformatting and autocomplete features of the editor.

See the video on YouTube

This video shows how to add macros, links and images by wiki markup alone. Type the macro, including its
parameters and the closing curly bracket. Add a link, such as an anchor link, and end it with a square bracket.
Insert an image or other embedded object, enclosed between exclamation marks. As soon as you close the
macro, link, or embedded image, Confluence will convert it to rich text format and add it to the page.

See the video on YouTube.

Using the most common formats and features

Below is a list of the most commonly used editor features, and the related keyboard shortcuts.

Formatting text
Formatting text What to do Windows keyboard shortcuts

(For Mac OS X, replace 'Ctrl'
with ‘Cmd")
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Heading levels

Bold text

Italic text

Underlined text

Monospace t ext

Left, centre and right alignment

Indentation

Line break

Type the heading level and a full
stop. Autoformat will convert the
line to the appropriate heading
immediately. You can continue
typing your heading text
immediately. Example:

h2.

Type an asterisk *', your text, then
another asterisk. Confluence
autoformat will convert the text to
bold immediately. Example:

*Surf's Up*

Type an underscore ', your text,
then another underscore.
Confluence autoformatting will
convert the text to italics
immediately. Example:

_Surf's Up_

Type a plus sign '+', your text, then
another plus sign '+'. Confluence
autoformatting will convert the text
to underlined immediately.
Example:

+Surf's Up+

Type two curly braces {{, your text,
then another two curly braces }}.
Confluence autoformat will convert
the text to monospace
immediately. Example:

{{Surf's Up}}

Click the left, centre and right
alignment buttons on the editor
toolbar:

@ This can also be used to align
images independently of text.

Click the left and right indentation
buttons on the editor toolbar:

= 3=

Press Shift + Enter to force a line
break without a paragraph break.
This is a line break with no extra
space.

33

Ctrl+1to 6

Ctrl+b

Ctrl + i

Ctrl +u

{

None

Tab (right), Shift + Tab (left)

Shift + Enter
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Quotation

Colour

Using symbols

Adding symbols and emoticons

Tick or check mark

Smiley

Linking text

Linking text

Use the Quote style — select 'Quot
e' from the style dropdown menu
or use the keyboard shortcut.
Example:

=

|F‘aragraph | B I

Paragraph r
Heading 1
Heading 2
Heading 3

Heading 4

Heading 5

Heading 6

Preformatted

Click the colour options on the
editor toolbar. Example:

Ul A |~ A ~ i= | iz

What to type

Type a forward slash in round
brackets. Autocomplete will
convert it as you type. Example:

(/)

Type the globally-recognised
markup for a smiley face (colon
and round bracket), a wink
(semicolon and round bracket),
and so on. Autocomplete will
convert it as you type. Example:

What to type

Ctrl + 8

None

Keyboard shortcut (Windows)
(+/+)

t+)

Keyboard shortcut (Windows)
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Linking to a Confluence page Type a square bracket [ and start |
typing the page name to see the
suggested pages to link to. Press
the arrow keys to select the page
you want. Example:

[ Modern Gir

Link suggestions

|=] Modern Girl song lyrics

—4 Search for ‘Modern Gir'
=2 InsertWeb Link

':E:' Insert Link to Create Page

Alternatively, use wiki markup ent
irely. Type the link, including the
alias and the page name or URL.
As soon as you type the closing
square bracket, Confluence will
convert the link to rich text format
and add it to the page. This means
that you can skip the link browser.

® This works if you have
'‘Autoformatting' enabled in the
editor settings in your user
profile.

® This does not work if you paste
the wiki markup onto the page.
You need to enter the closing
bracket manually.

®* Example: [ Moder n
Grl|Mdern Grl song
lyrics]
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Linking text to a web page

Created in 2014 by Atlassian. Licensed under a Creative Commons Attribution 2.5 Australia License.

Type a square bracket '[' and
select 'Insert Web Link', then
paste the URL into the link dialog.
Example:

[ Modermn Girl

Link suggestions

|=] Modern Girl song lyrics

‘%, Search for 'Modern Girl'

= Insert Web Link

':D:' Insert Link to Create Page

Alternatively, use wiki markup ent
irely. Type the link, including the
alias and the URL. As soon as you
type the closing square bracket,
Confluence will convert the link to
rich text format and add it to the
page. This means that you can
skip the link browser.

® This works if you have
'‘Autoformatting' enabled in the
editor settings in your user
profile.

® This does not work if you paste
the wiki markup onto the page.
You need to enter the closing
bracket manually.

® Example: [ Modern G rl | ht
tp: // www. exanpl e. conf s
ong]
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Linking to a page that does not yet
exist

Type a square bracket '[' and the
name of the non-existent page,
then select 'Insert Link to Create
Page'. Example:

[ Future of the modern girl

Link suggestions

- Search for ‘Future of the modern girl’
52 InsertWeb Link

+ InsertLinkto Create Page

Alternatively, use wiki markup ent
irely. Type the link, including the
alias and the page name or URL.
As soon as you type the closing
square bracket, Confluence will
convert the link to rich text format
and add it to the page. This means
that you can skip the link browser.

® This works if you have
'‘Autoformatting' enabled in the
editor settings in your user
profile.

® This does not work if you paste
the wiki markup onto the page.
You need to enter the closing
bracket manually.

® Example: [ Future of the
Modern Grl]
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Linking to an attachment
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Type a square bracket '[' and start
typing the attachment name to see
the suggested attachments to link
to. Press the arrow keys to select
the item you want. Example:

[ chocs

Link suggestions

- Chocs2 jpg
n Chocs1.jpg

—4 Search for ‘chocs’
=2 InsertWeb Link

'{IF' Inzert Link to Create Page

Alternatively, use wiki markup ent
irely. Type the link, including the
alias (if required), the caret
character » and the attachment
name. As soon as you type the
closing square bracket,
Confluence will convert the link to
rich text format and add it to the
page. This means that you can
skip the link browser.

® This works if you have
'‘Autoformatting' enabled in the
editor settings in your user
profile.

® This does not work if you paste
the wiki markup onto the page.
You need to enter the closing
bracket manually.

® Example: [ *att achnent
nane]
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Linking to an anchor

Using lists

Using lists

Adding a bullet list

Adding a numbered list

To create the anchor: Add an
anchor macro using wiki markup.
Confluence will convert the macro
to rich text format and add it to the
page. For example, to create an
anchor named 'index’, type the
following: { anchor : i ndex}

To create the link: Use wiki
markup too. Type the link,
including the alias (if required), the
hash character # and the anchor
name. As soon as you type the
closing square bracket,
Confluence will convert the link to
rich text format and add it to the
page. This means that you can
skip the link browser.

® This works if you have
‘Autoformatting’ enabled in the
editor settings in your user
profile.

® This does not work if you paste
the wiki markup onto the page.
You need to enter the closing
bracket manually.

® Example: [ | ndex| #i ndex]

What to type

Type an asterisk "*' followed by a
space. Autoformat will convert the
line to a bulleted list. You can
continue typing your text
immediately. Example:

My list:

Lbullet ite

@ To add another line of text to
an entry without creating a new list
item, press Shift + Enter at the end
of the line.

Type a hash or pound '#' followed
by a space. Autoformat will
convert the line to a numbered list.
You can continue typing your text
immediately. Example:

My list:
1. E
@ To add another line of text to
an entry without creating a new list

item, press Shift + Enter at the end
of the line.

Keyboard shortcut (Windows)
Ctrl + Shift + b

Ctrl + Shift + n
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Using tables
Using tables What to type Keyboard shortcut (Windows)
Adding a table Type a series of pipe characters'|' None

then press Enter. Autoformat will
convert the pipes to a table.
Example — to create a table with
three columns:

Using macros

Adding macros What to type Keyboard shortcut (Windows)

Adding a macro to your page. Type {' and start typing the macro  {
name to see a list of macros that
match your text. Press the arrow
keys to select the macro you want.
Example:

{ blog
Macro suggestions

Blog Posts
Blog posts report

D. Open Macro Browser

Alternatively, use wiki markup
entirely. Type the macro,
including its parameters and the
closing curly bracket. As soon as
you close the macro, Confluence
will convert it to rich text format
and add it to the page. This means
that you can skip the macro
browser.

® This works if you have
'‘Autoformatting' enabled in the
editor settings in your user
profile.

® This does not work if you paste
the wiki markup onto the page.
You need to enter the closing
bracket manually.

®* Example: { bl ogpost s: cont
ent=titles|author=jsmt
h}

Displaying images and multimedia

Displaying images What to type Keyboard shortcut (Windows)
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Display an image attached to the
page

Displaying an image attached to
another page

Embedding multimedia files

Type an exclamation mark 'I" and !
start typing the image name to see
the suggested images to insert

onto the page. Press the arrow

keys to select the item you want.
Example:

I NoMatt
WMedia suggestions

HoMatterWWhat.png
HoMatterWWhere.png
NoMatchingPages.PNG

_mJ Open Image Browser
B insertother Media

Alternatively, use wiki markup ent
irely. Type the wiki markup for the
image insertion, including the
exclamation marks, the space
and/or page name (if different from
the current page) and the image
name, as well as any other
allowed parameters. As soon as
you type the closing exclamation
mark, Confluence will convert the
image to rich text format and add it
to the page. This means that you
can skip the image browser.

® This works if you have
‘Autoformatting' enabled in the
editor settings in your user
profile.

® This does not work if you paste
the wiki markup onto the page.
You need to enter the closing
exclamation mark manually.

® Example: ! NoMat t er What . p
ng| al i gn=right!

Exactly the same as when the !
image is attached to the same

page.

What to type Keyboard shortcut (Windows)
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Embedding a video, movie or Type an exclamation mark '!" and !
audio file into a page select 'Insert Other Media'.
Example:

!
Media suggestions

MoMatterWhere.png

MoMatterWhat. png

. Chocs2 jpg

E& crocolstesaucenadsBysaran-28Jan2010 01 .
Bl croccakenadsBysarah-200pxJPG

:&I Open Image Browser

B Insert Other Media

Or type {' and start typing the
macro name 'Multimedia'.
Example:

{ mul

Macro suggestions

D. Open Macro Browser

Enabling and disabling autocomplete and autoformatting

You can enable or disable the editor's autocomplete and autoformatting functions, by editing the settings in your
user profile.

In summary:

1. Choose your profile picture at top right of the screen, then choose Settings.
2. Choose Editor under '"Your Settings' in the left-hand panel.

For more details, see Editing User Settings.

Working with Text Effects
The Confluence editor supports most text effects available in standard text editing applications.
Applying paragraph styles

Choose a paragraph style from the editor toolbar, or click in the paragraph and use one of the keyboard
shortcuts Ctrl+(0-8) .

Screenshot: Choosing paragraph styles from the editor toolbar
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Paragraph B I |
Paragraph

Heading 1 r
Heading 2
Heading 3

Heading 4

Heading 5

Heading 6

Freformatted

Quote

On this page:

Applying paragraph styles
Applying character formats
Applying colours to text
Aligning text

Indenting text

Related pages:

® Using the Editor
® Keyboard Shortcuts
® Confluence User's Guide

Applying character formats

To apply a character format, select the text and click one of the editor toolbar buttons, or use a keyboard
shortcut. Some formats are available from the 'More' menu.

Screenshot: Text formatting buttons on the editor toolbar

B I U N A

Format Shortcut Key
Bold Ctrl+B

Italics Ctrl+l
Underline Ctrl+U
Strikethrough Ctrl+Shift+S
supScript none
Superscript none
Monospace none

o Choose Clear Formatting from the ‘More' menu to remove all formatting.

Applying colours to text

To apply a colour to text, select the text and choose the colour option in the editor toolbar. To see the available
colours, choose the dropdown arrow next to the colour option.
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Screenshot: Picking colours from the editor toolbar

[ | A i =
. AEEEEEEN |
ENEEEEEN
| ENER
| |
Aligning text

You can align text to the left, right or centre of a content block. Select the text and click the appropriate
alignment option on the editor toolbar.

Screenshot: Left, centre and right alignment options on the editor toolbar

Indenting text

You can move text to the left or right by a predefined sequence of indentations. Confluence determines the size
of the indentation. Select the text and click the left or right indentation option on the editor toolbar.

Screenshot: Left and right indentation options on the editor toolbar

Working with Links

You can create links to pages, blog posts, anchors, attachments, external websites, JIRA issues and more.
Links can be text or images, and can be added in many different ways.

Links to pages within your Confluence site are relative, which means that you can move pages and rename
pages without breaking links.

This page explains the most common ways to create links.

Inserting a text link
To insert a link on a page:

1. Select some text or position your cursor where you want to insert the link.

2. Choose Link on the toolbar or use the keyboard shortcut Ctrl+K.

3. Select a page, blog post or attachment, or enter an external URL (see below for how to link to particular
types of content).

4. Enter or modify the link text - this is the text that will appear on the page. If this field is left blank, the page
name or URL will be used as the link text.

5. Choose Insert.

Alternatively you can type [ followed by the page or attachment name. Autocomplete will suggest matching items
for you.

You can also paste a URL directly onto your page. Confluence will automatically create the link, and if the URL
is for a page in the current site, the page name will be set as the link text.
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On this page:

Inserting a text link

Inserting an image link

Modifying a link

Removing a link

Linking to specific types of content

Linking to Confluence pages from other websites
Linking to comments

Using shortcut Links

Trackback

Related pages:

® \Working with Anchors
® |nserting JIRA Issues
® Confluence User's Guide

Inserting an image link
To link from an image:

1. Select an image on your page.

2. Choose Link on the Image Properties toolbar.

3. Select a page, blog post or attachment, or enter an external URL (see below for how to link to particular
types of content).

4. Choose Insert.

150px = | B || Original Border ® |ink Properties

Modifying a link
To modify a link:

1. Select the link text or image .
2. Choose Edit from the link properties toolbar.
3. Modify the link and choose Save.

Click to find out more

Goto Link = Edit | Unlink

Removing a link

To remove a link:

1. Select the link text or image
2. Choose Unlink from the properties toolbar.

Linking to specific types of content

Confluence supports many methods for creating links. Some of the common ones are listed here.
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Type of link

Link to a page

Link to a page in another space

Link to a blog post

Link to an attachment or image on this page

Link to an attachment on another page

Link to a website

Link to an email address

46

Ways to do this

Choose Link > Search then enter part of the page
name.

Choose Link > Recently viewed and select a page
from the list.

Type [ and enter part of the page name then select
the page from the list.

Paste the URL of the page onto your page
(Confluence will automatically create the link).

Choose Link > Search enter part of the page name
and select All Spaces from the drop down.

Choose Link > Advanced then enter the space key
followed by the page name spacekey: nypage.

Type [ and enter part of the page name then select
the page from the list.

(you can hover over each suggestion to see which
space the page is from).

Choose Link > Search and enter part of the blog
post name.

Type [ and enter part of the blog post hame then
select the blog post from the list.

Choose Link > Attachment then upload or select an
attachment from the list.

Type [ and enter part of the attachment file name
then select the attachment from the list.

Choose Link > Search and enter part of the
attachment name.

Type [ and enter part of the attachment file name
then select the attachment from the list

(you can hover over each suggestion to see which
space the page is from).

Choose Link > Web Link then enter the website
URL.

Type or paste the URL onto the page (Confluence will
automatically create the link).

Choose Link > Web Link then enter the email
address.

Type or paste the email address onto the page
(Confluence will automatically create a ‘mailto:' link).
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Link to an anchor on a page

Link to a heading on a page

Link to a comment on a page

Link to an undefined page
(a page that does not exist yet)

Link to a personal space or user profile

Link to a JIRA issue
(where Confluence is connected to JIRA)

Linking to Confluence pages from other websites

Choose Link > Advanced then enter the anchor
name in one of the formats below.

For an anchor on this page: #anchor nane.

For an anchor on another page in this space: page
name#anchor nane.

For an Anchor on another page in another space: sp
acekey: page nane#anchor nane.

See Working with Anchors for more information on
using anchors.

Choose Link > Advanced then enter the heading in
one of the formats below. Heading text is case
sensitive and must be entered without spaces.

For a heading on this page: #MyHeadi ng.

For a heading on another page in this space: Page
Nanme#MyHeadi ng.

For a heading on another page in another space: spa
cekey: Page Name#MyHeadi ng.

Be aware that these links will break if you edit the
heading text. Consider using the Table of Contents m
acro or an Anchor instead.

Go to the comment, right click the Date at the bottom
of the comment and copy the link. Paste the link
directly onto your page or choose Link > Web Link a
nd paste in the URL.

Type [$ then enter the Comment ID ('12345' in this
example): [ $12345]

Choose Link > Advanced then enter the new page
name (a page will be created on click).

Type [ then enter the new page name then choose In
sert link to create page .

See Managing Undefined Pages for more information
on undefined pages.

Choose Link > Search then enter the user's name
and select their personal space homepage or their
profile from the list.

Type [ then enter the user's name and select their
personal space homepage or their profile from the
list.

Paste the JIRA issue URL - Confluence will
automatically create a JIRA Issue macro.

The best way to link to a Confluence page from outside Confluence, for example on a website or in an email

message, is to use the tiny link which is a permanent URL. This ensures that the link to the page is not broken if

the page name changes.
To access the permanent URL for a page:

1. View the page you wish to link to.
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2. Choose Tools > Link to this page.
3. Copy the Tiny Link.
4. Use the tiny link in your website or email message.

You do not need to use the tiny link to link to pages within your Confluence site. Confluence automatically
updates links when you rename or move a page to another space.

If you want to link to specific content such as anchors, headings or comments you need to use the following link
syntax. Note that there are no spaces in the page name, anchor name or heading text.

In the examples below, the anchor name is 'InsertLinkAnchor' and the heading text is 'Insert a link'.

Purpose Link syntax
Link to an anchor http://nyconfl uence. com di spl ay/ spaceke
(from an external website) y/ pagenane#pagenane- anchor name

Example from this page:

https://confluence. atl assi an. conf di spl a
y/ DOC/ Wor ki ng+wi t h+Li nks#Wor ki ngwi t hLi n
ks-1nsertLi nkAnchor

Link to a heading http://nyconfl uence. com di spl ay/ spaceke
(from an external website) y/ pagenane#pagenamne- headi ngt ext

Example from this page:

https://confluence. atl assi an. contf di spl a
y/ DOC/ Wor ki ng+wi t h+Li nks#Wor ki ngwi t hLi n
ks-Insertalink

Link to a comment http://nyconfl uence. com di spl ay/ spaceke
(from an external website) y/ pagename?f ocusedConment | d=comment i d#c
oment - corment i d

Example from this page:

https://confl uence. atl assi an. coni di spl a
y/ DOC/ Wor ki ng+wi t h+Li nks?f ocusedComment
| d=368640803#comment - 368640803

Some things to note when linking to anchors from a website or email message:

® The page name is repeated in the URL, after the # sign. The second occurrence of the page name is
concatenated into a single word, with all spaces removed.

® There is a single dash (hyphen) between the concatenated page name and the anchor name.

® The anchor name in the full URL is concatenated into a single word, with all spaces removed.

® The anchor name is case sensitive. You must use the same pattern of upper and lower case letters as
you used when creating the Anchor.

Linking to comments

You can add a link to a comment by using the comment URL (a permanent link), or by using wiki markup to link
to the Comment ID.

To find out the comment URL and comment ID:

1. Go to the comment you wish to link to.
2. Choose the Date at the bottom of the comment and examine the URL.

The number after 'comment-' is the Comment ID. An example is shown here.

htt ps://confl uence. atl assi an. coni di spl ay/ DOC/ Wor ki ng+wi t h+Li nks?f ocusedC
omrent | d=368640803#coment - 368640803

You can use wiki markup directly in the editor to link to a comment. Enter [$ followed by the Comment ID, for
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example [ $12345] where '12345' is the Comment ID.

Using shortcut Links

If you have configured shortcut links on your Confluence site, then you can link to an external site using a
shortcut link that looks like this:CONF- 17025@ i r a.

Our Confluence site (where this documentation is housed) is configured to allow shortcut links to our JIRA site,
using the shortcut @i r a. So the shortcut link CONF- 17025@ i r a produces this link.

To add a shortcut link using the 'Insert Link' dialog:

1. Choose Link > Advanced and enter or paste the shortcut link into the Link field. Shortcut links are
case-insensitive.

2. Modify or enter link text - this is the text that will appear on the page.

3. Choose Insert.

You can also type '[' and choose Insert Web Link > Advanced to enter a shortcut link.

See Configuring Shortcut Links for more details.

Trackback

Trackback enables two sites can stay informed each time one site refers to the other using trackback 'pings’.

In Confluence, Trackback can be enabled by a site administrator in the Administration Console. When
Trackback is enabled, any time you link to an external webpage that supports Trackback Autodiscovery,
Confluence will send a Trackback ping to that page to inform it that it has been linked to.

Confluence pages also support Trackback Autodiscovery, and when Trackback is enabled, can receive
trackback pings sent by other sites.

To see who has sent a Trackback ping to a Confluence page:

1. Go to the page.
2. Choose Tools > Page Information.

Any Trackback pings the page has received will be listed under the page's Incoming Links.

Confluence incoming trackback pings only work with referenced pages that are public (anonymously viewable).
Working with Anchors

Anchors are used to enable links to a specific location on a page. Anchor links can be especially useful when
navigating between sections of a long document, or when you want to link to a segment of a page instead of the
top of the page.

Anchors are invisible to the reader when the page is displayed.
There are two steps to using an anchor:

1. Create an anchor on the page.
2. Create a link to the anchor.

Creating an anchor

Use the Anchor macro to mark the location you want to link to.

1. Add the Anchor macro to a page.
a. In the Confluence editor, choose Insert > Other Macros.
b. Find and select the required macro.

Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a
list of suggested macros. Details are in Using Autocomplete.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will
open, where you can edit the parameters of the macro.

2. Specify the name of your anchor. For example, 'bottom' or 'important information'. See the 'Anchor
Name' parameter described below.
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On this page:

® Creating an anchor
® Creating a link to an anchor
* Notes

Related pages:
® Working with Links

Macro options (parameters)

Parameters are options that you can set to control the content or format of the macro output. Where the
parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro
browser, it will be listed below in brackets (exanpl e).

Parameter Default Description

Anchor Name None This is the anchor name that you
will use when creating the link.

® The anchor name can include
spaces. Confluence will
remove the spaces
automatically when building a
URL that points to this anchor.

® The anchor name is case
sensitive. You must use the
same pattern of upper and
lower case letters when
creating the link as you used
when creating the Anchor
macro.

Creating a link to an anchor

You can link to an anchor from:

® A page on the same Confluence site. The link may be on the same page as the anchor, another page in
the same space, or a page in another space on the same Confluence site.
* Another web page or another Confluence site, using a specifically formatted URL.

To link to an anchor from within the same Confluence site:

1. Select some text or position your cursor where you want to insert the link.
2. Choose Link on the toolbar or press Ctrl+K.
3. Choose Advanced and enter the anchor name in the Link field following the format below.

Anchor location Link syntax for anchor Examples
Same page #anchor name #bottom
#important information
Page in same space page name#anchor name My page#bottom
My page#important information
Page in different space spacekey: page DOC:My page#bottom

name#anchor name )
DOC:My page#important

information
The anchor name is case sensitive. You must use the same pattern of upper and lower case letters as

you used when creating the Anchor macro.
4. Enter or modify the Link Text - this is the text that will appear on the page. If this field is left blank, the
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page name or URL will be used as the link text..
5. Choose Insert.

Screenshot: The 'Advanced' option in the link dialog

Insert Link Help
Search Here you can insert a link into the page using Wiki Markup.
Recently Viewed
Link | #goodstuff
Attachments
Toinsert alinkto a new page, type in the desired paage title.
Web Link To insert an anchor link, type #anchomame.
Advanced Link Text | link to the good stuff
Hint: type "[" in the Editor to see a list of suggested pages and insert a link Insert = Cancel

To link to an anchor from another web page or another Confluence site:

Use a full URL in the following format:

Link syntax Examples

http://nyconfl uence. con di spl ay/ spaceke http://myconfluence.com/display/DOCS/My+page#My
y/ pagenane#pagenane- anchor nane page-bottom

http://myconfluence.com/display/DOCS/My+page#My
page-importantinformation

Notes about the full URL:

® The page name is repeated in the URL, after the # sign. The second occurrence of the page name is
concatenated into a single word, with all spaces removed.

® There is a single dash (hyphen) between the concatenated page name and the anchor name.

® The anchor name in the full URL is concatenated into a single word, with all spaces removed.

® The anchor name is case sensitive. You must use the same pattern of upper and lower case letters as
you used when creating the Anchor macro.

Notes

® Table of contents on page: Consider using the Table of Contents Macro to generate a list of links
pointing to the headings on the page. The list of links will appear on the page, and will be automatically
updated each time someone changes the wording of a heading.

® Linking to headings: You can link directly to the headings of a page. See Working with Links. However,
if someone changes the wording of a heading, those direct links will be broken. Use the Anchor macro to
ensure a lasting link within the body of a page.

® Site welcome message: If you are adding an anchor to a page that you are using in the site welcome
message, you can only link to that anchor from another page. Internal links within that page will not work.

®* Templates: When you are previewing a template, a link to an anchor is displayed as a 'broken’ link.
However, when you create a page using the template the resulting page will have the correct link.

Displaying Images
You can display an image on a Confluence page when:

®* The image is attached to the page.
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® The image is attached to another page in the same Confluence site, even if in another space.
® The image is on a remote web page.

Once the image is displayed on the page, you can:

Move the image to a new position on the page by dragging or cut and paste.
Change how the image appears on the page.

Add a title and alt text for the image.

Link from an image to another page.

Displaying an image attached to the page

There are several methods for attaching image files to a page.
Once you have attached an image to a page, there are different methods for choosing where on the page the
image should appear:

Using the 'Insert Image' dialog

Once an image is attached to the page, you can edit the page to choose where the image should appear.
On this page:

Displaying an image attached to the page
Displaying an image attached to a different page
Displaying an image from a remote web page
Controlling the image appearance

Setting other image attributes

Displaying a gallery of images

Image file formats

Related pages:

Deleting an Image
Working with Links
Working with Attachments
Choosing a Profile Picture
Confluence User's Guide

To position an attached image on the page:

1. While editing the page, position the cursor where you want to place the image.
2. Choose Insert > Image and choose the Attached Images tab.
3. Select the required image and choose Insert (or just double-click the image).

Using autocomplete

Once an image is attached to the page, you can use autocomplete while editing the page to choose where the
image should appear.

To position an attached image on the page:

1. While editing the page, position the cursor where you want to place the image.
2. Trigger the autocomplete function by typing '!".
3. Choose the image from the list that appears.

Using drag-and-drop

Depending on the browser you are using, you can attach and position an image in one step. While you are
editing a page, simply drag-and-drop an image file on to the page. The image is attached to the page and is
placed at the current cursor position.

Displaying an image attached to a different page

You can display an image that is attached to a different page of the same Confluence site, as long as you know
the name of the image. This approach can make it easier to manage and reuse your images by allowing you to
keep them all in the same place.

To display an image attached to a different page:
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While editing the page, position the cursor where you want to place the image.
Choose Insert > Image and choose the Search tab.

Enter the name of the image.

Choose whether to search the current space or All Spaces and choose Search.
Select the required image from the search results and choose Insert.

aprwNE

Alternatively, you can cut and paste the image from another page (the image will still only be attached to the
original page).

Displaying an image from a remote web page

You can display an image from a remote web page on your Confluence page, without needing to attach it to your
page. You need to know the URL for the image, not for the web page it appears on. Note that you should have
permission to use that image on your page.

To display an image located on a web page:

1. While editing the page, position the cursor where you want to place the image.

2. Choose Insert > Image and choose From the Web.

3. Type in the URL for the image. An example is: http://atlassian.wpengine.netdna-cdn.com/wp-content/uplo
ads/AtlassianBushRegeneration-12January2012-083-trunc.jpg

4. Choose Preview to check that the URL and image are correct.

5. Choose Insert.

Alternatively, you can simply cut and paste the image from a web page.

Controlling the image appearance

When editing the page, select the image to show the image properties panel. The panel allows you to set the
display size, add a border and effects and link the image to other pages.

To set the size of the image, do one of the following:

® Choose one of the size 'preset’ buttons (the image width in pixels is displayed to the left).
® Choose the image size text and enter a new image width in pixels (you can specify a size between 16px
and 900px).

Images are displayed as thumbnails.
To add a border to the image:

® Choose Border in the image properties panel.
To add a hyperlink to the image:

® Choose Link in the image properties panel.
To align an image:

® Select the image and choose the paragraph alignment buttons on the editor toolbar.
® If you choose the left or right alignment, the text will wrap around the image. The text does not wrap for
centre alignment.

To add effects to an image:

® Choose Properties > Effects in the image properties panel.
® Select an effect and choose Save.

Note: The Instant Camera effect only works with Latin character languages, due to a lack of handwriting style
fonts in multi-byte languages.

To add a caption to an image:

Choose Effects in the image properties panel and choose the Instant Camera image effect.
Save the page.

Choose Tools > Attachments to go to the 'Attachments' view of the page.

Choose Properties next to the image file.

Add a comment to the attachment. The text in your comment will appear as the image caption.

Created in 2014 by Atlassian. Licensed under a Creative Commons Attribution 2.5 Australia License.


http://creativecommons.org/licenses/by/2.5/au/
http://atlassian.wpengine.netdna-cdn.com/wp-content/uploads/AtlassianBushRegeneration-12January2012-083-trunc.jpg
http://atlassian.wpengine.netdna-cdn.com/wp-content/uploads/AtlassianBushRegeneration-12January2012-083-trunc.jpg
https://confluence.atlassian.com/display/CONF55/Confluence+Glossary#ConfluenceGlossary-thumbnails
https://confluence.atlassian.com/display/CONF55/Using+the+Editor#UsingtheEditor-toolbar

Confluence 5.5 Documentation

You will need to re-enter the comment each time you upload a new version of the image.

Screenshot: The image properties panel beneath an image

H':JL Kicks!

300px = | ® @ Original Border =1 ink Properties

Screenshot: Examples of image border effects

Instant Camera

Curl Shadow Snapshot Crop Shadow

Setting other image attributes
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You can add a title and alt text to your image in the image properties panel. The image title displays when the
user hovers over the image or views the full size image. The alt text is used by screen readers and when the
image cannot be shown.

To add a title and alt text:

® Choose Properties > Title in the image properties panel.
® Enter atitle and alt text and choose Save.

Other attributes can also be set by using the Insert > Wiki Markup function from the editor toolbar, then using
the syntax described in Confluence Wiki Markup.

Displaying a gallery of images
See the Gallery Macro.

Image file formats

You can attach image files of any format to a page. Confluence supports the following image formats in the
Gallery macro and when displaying an image on a page:

* gif

* jpeg

® png

®* bmp (depending on browser support)

Deleting an Image

This page describes how to remove an image from a page. You may want to remove the image from the content
of the page, but leave the image available in Confluence. Or you may want to remove the image from
Confluence entirely.

Removing an image from the content of a page
A Confluence page can display one or more images, as described in Displaying Images.
To remove an image from the content of a page:

1. Edit the page.

2. Select the image. The image properties panel will appear, letting you know that the image is selected.
3. Press the Delete key on your keyboard.

4. Save the page.

The image will no longer appear as part of the page content. If the image file was originally uploaded as an
attachment on the current page or another page, the image is still available in Confluence. If you want to to
remove the attachment, follow the steps below.

Removing an image attachment from Confluence
To remove an image file from Confluence, you must remove the attachment. See Deleting an Attachment.

Note: A page can display an image that is attached to another page. If you remove an image that is used on a
page, readers will see an error message on that page.

Example error message that appears when image attachment is removed:
?  Unknown Attachment
Related pages:
® Displaying Images
® Working with Attachments
® Confluence User's Guide
Working with Tables

Confluence pages can include multi-row and multi-column tables. You can highlight cells, rows and columns in
different colours. When viewing the page, people can sort the table by clicking the column headers.
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Inserting a table
To create a table:

1. While editing the page, place your cursor at the point where you want to insert the table.

2. Choose Table on the toolbar.

3. A dropdown menu will appear, showing a table with a variable number of rows and columns. Click in a
cell to set the number of columns and rows for your table.

4. Add content and more rows and columns as needed. See below for guidelines on what you can do with
your table in the editor.

Screenshot: Inserting a table with 3 rows and 3 columns

ETable

Ix3

On this page:
® |nserting a table
® \What you can do with your table in the editor
® Shortcut keys
® Sorting the table in view mode

Related pages:

® Working with Page Layouts and Columns and
Sections

® Using the Editor

® Confluence User's Guide

What you can do with your table in the editor

While editing a page, place your cursor inside a table to see the table toolbar.

Insert row Cut, copy & paste rows Remove column Heading row Highlight (colour) cells

g A | = || R |8 | & || WY B H BB B - B

Remove row Insert column Merge and Split Heading column Remave table

Using the table toolbar you can:

Insert an empty row above the current one.

Insert an empty row below the current one.

Remove the current row.

Cut the current row and copy it to the clipboard.

Copy the current row to the clipboard.

Paste the row from the clipboard to the current row.

Insert an empty column to the left of the current one.

Insert an empty column to the right of the current one.

Remove the current column.

Merge the selected cells.

Split the selected merged cells.

Mark a row as a table header. The cells in the row will be highlighted in grey and the text will be bold.
Mark a column as a table header. The cells in the column will be highlighted in grey and the text will be
bold.

® Highlight cells with a background colour.
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®* Remove the table.

Shortcut keys

Windows Action

Ctrl+Shift+c Copy the current table row, or the
selected rows.

Ctrl+Shift+i Insert a table. (Opens the Insert
Table dialog.)

Ctrl+Shift+v Paste the table rows from your

clipboard, placing them above the
current row.

Ctrl+Shift+x Cut the current table row, or the
selected rows.

Alt+Up Arrow Add a row above the current row.

Alt+Down Arrow Add a row below the current row.
For more editor keyboard shortcuts, see Keyboard Shortcuts.

Sorting the table in view mode

57

Mac OS X
Cmd+Shift+c

Cmd+Shift+i

Cmd+Shift+v

Cmd+Shift+x

Alt+Up Arrow

Alt+Down Arrow

When readers view a table on a page, they can sort the table by clicking the sort icons in the header row.

Screenshot: A colourful, sortable table

Document Author Reviewer
Getting Started Sandy Joan
Installation Guide  Sandy Pete

Upgrade Guide Juan Lise

Using Symbols, Emoticons and Special Characters

You can add various symbols and special characters to Confluence pages. You can also use them in other
places that display content, such as blog posts, comments, the dashboard welcome message and the

configuration panels offered by the Documentation theme.

Inserting symbols and special characters

To add a symbol to your page:

1. Edit the page.

2. Choose Insert > Symbol. This will display the 'Insert Custom Character' window.

3. Choose a symbol to insert it.
On this page:
® |nserting symbols and special characters
® |nserting emoticons
® Preventing emoticons from appearing

Related pages:

® Quick Reference Guide for the Confluence Editor
® Confluence Wiki Markup
® Confluence User's Guide

Screenshot : Available symbols
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Symbol
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Cancel

Inserting emoticons
There are two ways to add an emoticon, or smiley, to your page.
By choosing an emoticon from those available:

1. Choose Insert > Emoticon.
2. Choose an emoticon to insert it.

By typing a character combination:
You can insert emoticons by typing commonly-used character combinations. For example, the following code
appears as an emoticon when the page is rendered.

7))

The above example creates this emoticon: =

This table shows the emoticons (and other icons) available in Confluence, and the character combinations that
create them:

e e89090P700B0AO0B0 2 C LR SR

PQe ®» 3 —

)« P D ) ¢ (0 OH O x O 6 2 © @ O 6r ¢ ¢ ¢
) ) n) fh) ) 9 b))

(S
~
~
~

at

Preventing emoticons from appearing

To undo the conversion of a character combination into an emoticon, press Ctrl+Z (Windows) or Cmd+Z (Mac).
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To prevent Confluence from converting text to emoticons automatically, disable ‘Autoformatting’ in your user
profile. See Editing User Settings.

The Confluence knowledge base has an article on disabling emoticons for the Confluence site as a whole.

Using Autocomplete

When using the Confluence editor, you can type a trigger character or press a keyboard shortcut to see a list of

suggested links, files or macros to add to your page, or to mention another user (and automatically notify them of

this).
Summary of autocomplete

What you want to do

Trigger character

Keyboard shortcut

Description

59

Add a link on your page [ Ctrl+Shift+K See a list of suggested
pages or other locations
to link to from your page.
More...

Display an image, video, ! Ctrl+Shift+M See a list of suggested

audio file or document on images, multimedia files

your page and documents to embed
in your page. More...

Add a macro on your { None See a list of suggestions

page as you begin typing a
macro name. More...

Notify another user by @ None See a list of suggested

email that you have users to mention. More...

mentioned them on your
page

On this page:

® Summary of autocomplete

® Using autocomplete for links

® Using autocomplete for images,
videos, audio files and
documents

® Using autocomplete for macros

® Using autocomplete for
mentions

® Cancelling autocomplete
Enabling and disabling
autocomplete

® [gnoring autocomplete

Related pages:

Working with Links
Using Images

Working with Macros
Keyboard Shortcuts
User Profile Overview
Confluence User's Guide

Using autocomplete for links

Type '[', or press Ctrl+Shift+K, to see a list of suggested pages or other locations to link to from your page. You
can link to pages, user profiles, images, documents and other file attachments.

To autocomplete a link:

1. Edit the page.
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2. Click where you want to insert a link and do one of the following:
®* Type T and then the first few characters of the page title, user's name, image name or file name.
® Type the first few characters of the page title, user's name, image name or file name (or select
relevant text) and then press Ctrl+Shift+K.
3. Click the relevant link from the list of suggestions.

If the item you need is not in the list, either:

® Choose Search for 'xxx' to continue looking for the page within Confluence, or
® Choose Insert Web Link to insert a link to an external web page using the link browser.

Screenshot: Autocomplete for a link

| want to add a link to [ sam|

Link suggestions
(5] Sample Page
@) Sample Space

Q, Search for ‘sam’
& Insert Web Link

+ Insert Link to Create Page

Using autocomplete for images, videos, audio files and documents

You can use the autocomplete as a fast way of embedding images, videos, audio files and documents into your
page. Type an exclamation mark or press Ctrl+Shift+M to see a list of suggested images, multimedia files and
documents to display on your page. You can use autocomplete to embed the following file types:

®* |mages — any format that Confluence supports. See Displaying Images.

® Videos, audio files and all multimedia formats that Confluence supports. See Embedding Multimedia
Content.

® Office documents supported by the Confluence Office Connector: Word, Excel and PowerPoint.

® PDFfiles.

ﬂ Autocomplete works most efficiently for files that are already attached to the Confluence page. See Attaching
Files to a Page.

To embed an image, video, audio file or document:

1. Edit the page.
2. Click where you want to insert the image, video, audio file or document and do one of the following:
* Type 'I"and then the first few characters of the image, file or document name.
* Type the first few characters of the name of the image, file or document (or select relevant text)
and then press Ctrl+Shift+M.
3. Choose the relevant file from the list of suggestions.

If the item you need is not in the list, either:

® Choose Open Image Browser to find images and documents using the image browser, or
® Choose Insert Other Media to embed videos, audio and other multimedia files using the macro
browser. Insert the 'Multimedia' macro to display your multimedia file.

Screenshot: Autocomplete for an image or document
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| want to add an image |

Media suggestions
"% iBugs.gif
G{;g. iAngryNerdsGr.png

i#: DefaultSpacelLogo_AngryNerds.png

Open Image Browser

2 Insert Other Media

Using autocomplete for macros

Type '{' to see a list of suggested macros to add to your page.

Autocomplete provides access to all available macros in your Confluence site, including any user macros that
your administrator has added and made visible to all.

o You need to know the name of macro. Autocomplete for macros will only match the name of the macro, not
the description.

To autocomplete a macro using '{":

1.
2. Click where you want to insert the macro.

3. Type '{" and then the first few characters of the macro name.

4,

5. Configure the macro by completing the form fields as prompted.

Edit the page.

Choose the relevant macro from the list of suggestions.

If the macro you need is not in the list, choose Open Macro Browser in the list of suggestions to continue
looking for the macro in the macro browser. See Working with Macros.

Screenshot: Autocomplete for a macro

| want to add a macro {

Macro suggestions

@ Info

= Status
Gallery

= Table of Contents

= Open Macro Browser

Using autocomplete for mentions

You can use autocomplete to automatically notify another Confluence user that you have mentioned them in a

page, blog post, or comment. Type '@' and part of the person's name, to see a list of suggested users.

Note: Use the person's full name. Autocomplete will recognise users' full names only, not their usernames.
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To mention someone using '@":

1.
2.

In the editor, type '@' then the first few characters of the person’'s name or username.
Choose the user's name from the list of suggestions.

Screenshot: Autocomplete for mentions

| want to mention someone @ josh|

User suggestions

) Josh user

Cancelling autocomplete

The autocomplete starts automatically when you press the trigger characters. You may want to close the
autocomplete menu or escape from autocomplete once it has started.

There are a few different ways to stop the autocomplete once it has started:

Press the escape key, 'Esc’, on your keyboard.

Click somewhere else in the editor panel.

Press an arrow key to move out of the autocomplete area.

For the link autocomplete only: enter a right-hand square bracket, like this: ]

Enabling and disabling autocomplete

You can turn off the triggering of autocomplete by the [' and ' characters. This will prevent the autocomplete
from starting automatically when you press one of the trigger characters. You can also turn it back on again.

Notes:

This setting does not affect the keyboard shortcuts for autocomplete (Ctrl+Shift+K and Ctrl+Shift+M).
Even if the trigger characters are disabled, you can still use the keyboard shortcuts for autocomplete.
This setting affects only you. Other people using Confluence can enable or disable the setting on their
user profiles independently.

Note that autocomplete is enabled by default.

To enable or disable the autocomplete trigger characters:

1
2
3.
4

5.

. Choose your profile picture at top right of the screen, then choose Settings.
. Choose Editor under 'Your Settings' in the left-hand panel.

Choose Edit.

. Either:

® Disable autocompletion by selecting Disable Autocomplete.
® Enable autocompletion by clearing Disable Autocomplete.
Choose Submit.

Screenshot: User settings for the editor
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People

Rach Admin

Profle Network Status Updates Favourites Waiches Drafts Settings

GADGETS

View QAuth Access Tokens . .
Editor Settings

YOUR SETTINGS Disable Autocomplete

Password Disable Autocomplete in the Editor, where it allows links to be inserted

Email with the trigger [ and images with the trigger 1.

Editor Disable Autoformatting
Disable Autoformatting in the Editor, where it allows wiki-formatted text to
be converted to its Rich Text equivalent (e.g. "h1. title” for a heading).

Edit

Ignoring autocomplete

You can add macros, links and images by wiki markup alone. Type the macro, including its parameters and the
closing curly bracket. Add a link, such as an anchor link, and end it with a square bracket. Insert an image or
other embedded object, enclosed between exclamation marks. As soon as you close the macro, link, or
embedded image, Confluence will convert it to rich text format and add it to the page.

More information about mouse-free macros, links and images:

® Quick Reference Guide for the Confluence Editor
® Video

Working with Page Layouts and Columns and Sections
There are two ways to modify the layout of a Confluence page. You can:

® use Page Layouts to add sections and columns, or
® use macros to add sections and columns.

Page layouts provides a simple, visual representation of your page layout in the editor, while the macros are
more flexible and allow for greater complexity in your layout.

Using page layouts

The Page Layouts tool allows you to structure your page using horizontal sections and vertical columns. By
adding multiple sections with different column configurations you can build quite complex layouts very easily.
On this page:

® Using page layouts
® Using the Section and Column macros

Screenshot: Editor view of a page showing three sections with different column configurations.
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+ Add section = @ Remove section 1+ Move up |+ Move down

Start by adding a horizontal section to your page.
To add a section:

1. Choose the Page Layout button on the editor toolbar.
2. The Page Layout toolbar appears. Choose Add Section.

The new section appears below your current content. The boundaries of the section are indicated by dotted
lines. These are not visible when you view the page.

To change the column layout in a section:

1. Place your cursor in the section you wish to change.
2. Choose a layout from the Page Layout toolbar (for example two column, three column).

Any text, images or macros in your section are not lost when you change the column layout. When you decrease
the number of columns, Confluence will move your content to the left. When you increase the number of
columns, Confluence will add blank columns to the right of your existing content.

To move a section to another part of the page:

1. Place your cursor in the section you wish to move.
2. Choose the Move up or Move down buttons.

The section and all of its content will be moved above or below other sections on the page.

To delete a section:

1. Place your cursor in the section you wish to remove.
2. Choose Remove section.

The section and all of its content will be removed.

Notes about Page Layouts

® Column width - The width of the columns are fixed. If you need more than three columns, or columns of
a specific width, you should use the Section and Column macros described below.

® Very wide tables. The width of each column is set to a percentage of the page width. The icons in the
drop down menu indicate the relative widths for each layout. In most cases, Confluence will adapt the
width of the columns to fit the width of the page. If a column includes a large table, the content may not fit
into the width of the page. You will see a horizontal scroll bar when viewing the page.

Using the Section and Column macros

You can use the Section and Column macros to add a set of columns to the page. The Section macro defines an
area that will contain the columns. You can have as many sections as you like. Within each section, you can
have as many columns as you like.

The Section and Column macros are useful if you want to define a specific percentage or pixel width for each
column.

To add a section and some columns to a page:
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oukwnE

In the Confluence editor, choose Insert > Other Macros.
Find the Section macro, select it and insert it onto the page.
Choose Insert > Other Macros again.

Find and insert the Column macro.

Add your content to the column.

Insert as many columns as you like within the section.

Screenshot: A section and two columns in the editor

Sectian | border = true

Column

Content for column 1 goes here

Column

Content for column 2 goes here

When you see the page in view mode, the above layout is displayed like this:

Content for column 1 goes here
Content for column 2 goes here

Macro parameters

Parameters are options that you can set to control the content or format of the macro output. Where the
parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro
browser, it will be listed below in brackets (exanpl e).

Parameters of the Section macro

Parameter

Show Border

Parameters of the Column macro

Parameter

Column Width

Notes about sections and columns

Default

false

Default

100% of the page width, divided
equally by the number of columns
in the section.

Description

Select this option to draw a border
around the section and columns.

Note: Without a Column macro,
the border will not be displayed
correctly.

Description

Specify the width of the column, in
pixels (for example, 400px) or as
a percentage of the available width
(for example, 50%.

® All content within your section must be enclosed within a Column macro, otherwise the section layout will
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not work as expected.
® You can put tables inside columns.

Working with Macros

Using a macro, you can add extra functionality or include dynamic content on a page. For example, the Attachm
ents macro will list a page's attachments in the page itself, so that readers do not have to visit the Attachments
tab.

Adding a Macro to your Page

Including Macros with the Macro Browser

To add a macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of
suggested macros. Details are in Using Autocomplete.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open,
where you can edit the parameters of the macro.

Macro Parameters
Many macros allow you to include optional parameters to control the macro's output.
With the Attachments Macro, for instance, you have two optional parameters allowing you to:

* Specify the file formats of the attachments displayed.
® Choose whether or not you want old versions of the attachments displayed.

Macro Placeholders
Macro placeholders are displayed in the editor where you have added a macro to the page.
When editing a page, you can:

® Double-click a macro placeholder (or click the placeholder and choose Edit) to open the macro dialog
window, where you can edit the macro's parameters.
® Select a macro placeholder to cut, copy and paste the macro.

On this page:

Adding a Macro to your Page

Macros Shipped with your Confluence Installation
Information about Other Macros

Writing your own Macros

Macros Shipped with your Confluence Installation

When you download your Confluence installation file, many macros are shipped with the download. Below is a
list of the macros currently shipped with Confluence. Click a macro name for details of the usage, including
optional parameters and examples.

Activity Stream Macro
Anchor Macro
Attachments Macro
Blog Posts Macro
Change-History Macro
Chart Macro

Cheese Macro
Children Display Macro
Code Block Macro
Column Macro
Content by Label Macro
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Content by User Macro
Content Report Table Macro
Contributors Macro
Contributors Summary Macro
Create from Template Macro
Create Space Button Macro
Excerpt Include Macro
Excerpt Macro

Expand Macro

Favourite Pages Macro
Gadget Macro

Gallery Macro

Global Reports Macro
HTML Include Macro

HTML Macro

IM Presence Macro

Include Page Macro

Info Macro

JIRA Chart Macro

JIRA Issues Macro

JUnit Report Macro

Labels List Macro
Livesearch Macro
Loremipsum Macro
Multimedia Macro
Navigation Map Macro
Network Macro

Noformat Macro

Note Macro

Office Excel Macro

Office PowerPoint Macro
Office Word Macro

Page Index Macro

Page Properties Macro
Page Properties Report Macro
Page Tree Macro

Page Tree Search Macro
Panel Macro

PDF Macro

Popular Labels Macro
Profile Picture Macro
Recently Updated Dashboard Macro
Recently Updated Macro
Recently Used Labels Macro
Related Labels Macro

RSS Feed Macro

Search Results Macro
Section Macro

Space Attachments Macro
Space Details Macro

Space Jump Macro

Spaces List Macro

Status Macro

Table of Contents Macro
Table of Content Zone Macro
Task Report Macro

Tip Macro

User List Macro

User Profile Macro

User Status List Macro
View File Macro

Warning Macro

Created in 2014 by Atlassian. Licensed under a Creative Commons Attribution 2.5 Australia License.


http://creativecommons.org/licenses/by/2.5/au/

Confluence 5.5 Documentation 68

® Widget Connector Macro

Information about Other Macros

Other macros are available as plugins or as user macros, and can be installed by your Confluence
administrator. For example, macros that may be of interest are available from Adaptavist, CustomWare and the
Confluence SharePoint Connector.

Writing your own Macros
To learn how to write your own macro, take a look at the following documentation:

® User macros are simple template-like macros that allow you to create simple formatting macros using the
Confluence web interface. Read more about Writing User Macros.
® The Confluence Plugin Guide tells you how to develop a plugin for Confluence.

Activity Stream Macro
The Activity Stream macro is a specific instance of the Gadget macro. It inserts an Activity Stream gadget onto

your page. For instructions, see Activity Stream Gadget.
Related pages:

® Activity Stream Gadget
® Gadget Macro
® Confluence User's Guide

Anchor Macro

Allows you to link to a specific part of a page. For more information on using anchors see Working with Anchors.

Code Examples

The following examples are provided for advanced users who want to edit the underlying markup for a
Confluence page.

Macro name: anchor

Macro body: None.

Storage format example

<ac: structured-macro ac: nane="anchor">
<ac: paraneter ac: nanme="">here</ ac: par anet er >
</ ac: structured-nmacro>

Wiki markup example

{anchor: her e}

Attachments Macro

Displays a list of attachments on a given page. For more information see Displaying a List of Attachments.

Code examples

The following examples are provided for advanced users who want to edit the underlying markup for a
Confluence page.

Macro name: att achment s

Macro body: None.
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Parameter name

old

patterns

sort By

page

sort Or der

| abel s

upl oad

Required

No

No

No

No

No

No

No

Default

fal se

(None)

dat e

The page on which the
macro exists.

The default sort order is
determined by the sort B

y type:

® Reverse
chronological for
'date’.

® |argest to smallest
for 'size'.

® Alphabetical for
‘name’.

(None)

fal se

Parameter description
and accepted values

Available values:

* fal se - Displays
only the latest version
of each attachment.

® true — Displays all
versions of each
attachment, including
the old versions.

A comma-separated list

of regular expressions,

used to filter the

attachments by file

name. Note that the

parameter values must

be regular expressions.

For example:

® To match a file suffix
of 'jpg’, use . *j pg (n
ot*.j pg).
® To match file names

ending in 'jpg’ or
‘png’, use . *j pg,. *p
ng

Available values:

dat e

si ze

nanme

createdate

Page name, used to
display attachments from
another page.

Available values:

® ascendi ng
® descendi ng

A comma-separated list
of labels. Confluence will
show only attachments
that have all the labels
specified. (The match is
an AND, not an OR.)

Determines whether the
list of attachments will
include options allowing
users to browse for, and
attach, new files.
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previ ew No true Determines whether a
preview of the attached
file appears when the
item is expanded.

Storage format example

<ac: structured-nmacro ac: nane="attachnments">
<ac: paraneter ac:nanme="ol d">fal se</ ac: par anet er >
<ac: paraneter ac:nanme="patterns">. *png, .*j pg</ac: paranet er >
<ac: paraneter ac:nanme="sortBy">nane</ ac: par anet er >
<ac: par aneter ac: nanme="page">
<ac:|ink>
<ri:page ri:content-title="My page about chocol ate"/>
</ac:|ink>
</ ac: par anet er >
<ac: paranet er ac: nanme="sort Order">descendi ng</ ac: par anet er >
<ac: paraneter ac:nanme="| abel s">chocol at e, cooki es</ ac: par anet er >
<ac: paraneter ac: nanme="upl oad" >f al se</ ac: par anet er >
</ ac: structured- nacr o>

Wiki markup example

{attachnents: ol d=f al se| patterns=. *png, . *j pg| sort by=nane| page=My page about
chocol at e| sort order =descendi ng| | abel s=chocol at e, cooki es| upl oad=f al se| previ ew=f al se}

Blog Posts Macro

The Blog Posts macro allows you to display blog posts on a Confluence page. Clicking on a title takes you to the
blog post.

Using the Blog Posts Macro
To add the Blog Posts macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of
suggested macros. Details are in Using Autocomplete.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open,
where you can edit the parameters of the macro.

Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the
parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro
browser, it will be listed below in brackets (exanpl e).

Parameter Required Default Description
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Content Type to No titles Available values:
Display i ,
® titles — Display only
(cont ent) the title of each blog
post.

® excerpts — Display
a short excerpt from
each blog post. If the
post contains an
Excerpt macro, the
Blog Posts macro will
display the content
defined in the Excerpt
macro. If the post
does not contain an
Excerpt macro, the
Blog Posts macro will
display the first few
sentences of the
post.

® entire - Display the
whole content of
each blog post.

Time Frame No no limit Specify how far back in

(tinme) time Confluence should
look for the blog posts to
be displayed.

Available values:

®* m— Minutes

® h — Hours, so '12h'
displays blog posts
created in the last
twelve hours.

® d — Days, so'7d’
displays blog posts
created in the last
seven days.

* w— Weeks
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Restrict to these Labels No None Filter the results by label.

(1 abel) The macro will display
only the blog posts which
are tagged with the
label(s) you specify here.

You can specify one or
more label values,
separated by a comma
or a space.

® To exclude content
which matches a
given label, put a
minus sign (-)
immediately in front
of that label value.
For example: If you
specify a label value
of - badpage you will
get only content
which is not labelled
with 'badpage’.

® To indicate that the
results must match a
given label value, put
a plus sign (+)
immediately in front
of that label value.
For example: If you
specify a label value
of +super page, +go
odpage you will get
only content which
has at least two

labels, being
'superpage' and
‘goodpage’.
Restrict to these Autho  No None Filter the results by
rs author. The macro will
(aut hor) display only the blog

posts which are written
by the author(s) you
specify here.

You can specify one or
more authors, separated
by a comma.

For example: j snith, j
br own

To include content from
one user, but exclude
from another user: j sm
th,!jbrown

Restrict to these No @self, i.e. the space

Spaces which contains the page

(spaces) on which the macro is
coded
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This parameter allows
you to filter content by
space. The macro will
display only the pages
which belong to the
space(s) you specify
here.

You can specify one or
more space keys,
separated by a comma
or a space.

® To exclude content in
a specific space, put
a minus sign (-)
immediately in front
of that space key. For
example: If you
specify a space key
of - BADSPACE you
will get only content
which is not in the
BADSPACE.

® To indicate that the
results must come
from a specific space,
put a plus sign (+)
immediately in front
of that space key. For
example: If you
specify a space key
of +GOODSPACE you
will get only content
in GOODSPACE.
(Note that this is not
particularly useful,
because each
content item belongs
to one space only. If
you put a plus sign
next to one space
key and list other
space keys too, the
other space keys will
be ignored.)

Special values:
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Maximum Number of No
Blog Posts

(max)

Sort By No
(sort)

15

creation

®* @el f — The current
space.

* @ersonal — All pe
rsonal spaces.

* @l obal — All site s
paces.

®* @avorite —The
spaces you have
marked as favourite.

® @avourite —The
same as @ avorite
above.

® @l |l — All spaces in
your Confluence site.

® * — The same as @
Il above.

When specifying a
personal space,
remember to use the tilde
(~) sign in front of the
username, such as ~j bl
0ggs or ~j bl oggs@xa
nmpl e. com

Specify the maximum
number of results to be
displayed. Note that the
results are sorted first,
and then the maximum
parameter is applied.

Specify how the results
should be sorted. If this
parameter is not
specified, the sort order
defaults to descending
order (newest first) based
on the creation date.

Values:

® title — Sort
alphabetically by title.

® creation — Sort by
the date on which the
content was added.

* modified — Sort by
the date on which the
content was last
updated.
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Reverse Sort No false Select to change the sort

(reverse) from descending to
ascending order (oldest
first). Use this parameter
in conjunction with the S
ort By parameter. This
parameter is ignored if
the Sort By parameter is
not specified.

In storage format and
wikimarkup a value of t r
ue changes the sort
order.

Code examples

The following examples are provided for advanced users who want to edit the underlying markup for a
Confluence page.

Macro name: bl og- post s

Macro body: None.

Storage format example

<ac: structured-nmacro ac: nanme="bl og- posts">
<ac: paraneter ac:nane="content">titles</ac: paraneter>
<ac: paraneter ac:name="spaces">
<ri:space ri:space-key="ds"/>
</ ac: par anet er >
<ac: paramet er ac: nane="aut hor" >
<ri:user ri:userkey="12345678912345678912345678912345"/ >
</ ac: par anet er >
<ac: paraneter ac:nane="tinme">4w</ac: par anet er >
<ac: paraneter ac:nane="sort">creation</ac: paranet er>
<ac: paraneter ac:name="nmax">10</ac: par anet er >
<ac: paraneter ac: nanme="| abel s">chocol at e, cooki es</ ac: par anet er >
</ ac: struct ured- nacr o>

Wiki markup example

{bl og-posts:content=titles|spaces=@el f, ds|author=jsnith|tine=4w reverse=true|sort=
creation| max=10| | abel =chocol at e, cooki es}

Change-History Macro

The Change-History macro shows the history of updates made to a page: version number, author, date and
comment. It displays the information inline.

Screenshot: The Change-History macro in Confluence
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This is the change history macro
Version Date Comment
Current Version (v. 4) Feb 19, 2013 16:27 Rach Admin:
Formatting change
V.3 Feb 19, 2013 16:27 Rach Admin:
Added the change history macro
V. 2 Feb 19, 2013 16:26 Rach Admin:
Added a macro
V. 1 Feb 19, 2013 16:25 Rach Admin

To add the Change-History macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of
suggested macros. Details are in Using Autocomplete.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open,
where you can edit the parameters of the macro.

Note: There are no parameters for this macro.

Code examples

The following examples are provided for advanced users who want to edit the underlying markup for a
Confluence page.

Macro name: change- hi story
Macro body: None.

Parameters: None.

Storage format example

<ac:structured-nmacro ac: name="change-hi story"/>

Wikimarkup example

{change- hi st ory}

Chart Macro
The Chart macro allows you to display a chart based on tabular data. When you add the macro to a page, you:

* supply the data to be charted by the macro as a table in the placeholder of the macro.
® edit the macro parameters in the Macro Browser to configure the format of the chart.

Screenshot 1: A table of data in the Chart macro placeholder
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il Chart | type = timeSeries | columns = Weeks, Issues Burndown | dataCrientation = vertical | tim...

Weeks Issues Burndown
04/07/2011 81
11/07/2011 68
18/07/2011 &7
25/07/2011 &6
01/08/2011 &5
08/08/2011 &5
15/08/2011 64
22/08/2011 44
29/08/2011 24
05/09/2011 0

Screenshot 2: The resulting chart
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On this page:

® Using the Chart Macro
® Parameters
® Examples
® Pie Chart
Bar Chart
3D Bar Chart
Time Series Chart
XY Line Chart
XY Area Chart
Area Charts
® Gantt Chart
® Code examples
® Chart type parameters
® Chart display parameters
® Chart title and label
parameters
Chart data parameters
Chart colour parameters
Chart axis parameters
Pie chart Parameters
Chart attachment
parameters
® Wiki markup example

Using the Chart Macro

To add the Chart macro to a page:

1. Edit the page and use autocomplete to add the Chart macro. (Type {chart}'.)

2. Enter your chart data as one or more tables in the body of the macro placeholder. (See the screenshot ab
ove.)

Click the macro placeholder and choose Edit.

Select a chart type using the Type parameter (see below).

Choose other parameter settings in the macro browser, as described below.

Click Refresh in the 'Preview' area, to check that the chart appears as you expect.

Click Save to add the chart to your page.

Click Save again when you are ready to save the page.

©NOoOOA®

Parameters

Chart Type Parameters | Display Control Parameters | Title and Label Parameters | Data Specification
Parameters | Colour Parameters | Axis Parameters | Pie Chart Parameters | Attachment Parameters

Chart Type Parameters

These parameters determine the type of chart to display and the way the chart looks.

Parameter Default Description

Type pie The type of chart to display. XY
charts have numerical x- and
y-axes. The x values may
optionally be time-based (see the
Time Series parameter).

Standard — pie, bar, line, area

XY Plots — xyArea, xyBar, xyLine,
xyStep, xyStepArea, scatter,
timeSeries

Other — gantt
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Display Orientation

Show in 3D

Stacked Values

Show shapes

Opacity

Display Control Parameters

Parameter
Width
Height

Display rendered data

Image format

Title and Label Parameters

Parameter
Chart Title
Chart Subtitle

Horizontal-axis Label
Vertical-axis Label

Show Legend

Data Specification Parameters

vertical

false

false

true

® 75 percent for 3D charts

® 50 percent for non-stacked
area charts

® 100 percent for all other charts

Default
300
300

false

png

Default
none

none

none
none

true

79

Applies to area, bar and line
charts.

® vertical — y-axis is vertical
® horizontal — x-axis is
vertical

Applies to area, bar and line
charts.

Applies to area and bar charts.

Applies to line charts. Shapes are
shown at each data point.

A percentage value between 0
(transparent) and 100 (opaque)
that determines how opaque the
foreground areas and bars are.

Description
The width of the chart in pixels.
The height of the chart in pixels.

Sets whether to display the
rendered body of the macro
(usually the data tables). By
default, the chart data table isn't
rendered.

®* before — the data are
displayed before the chart.

* after — the data are
displayed after the chart.

The image format to be used for
the chart.

* png
® jpg

Description
The title of the chart.

A subtitle for the chart, using a
smaller font than for Title.

The label for the x-axis (domain).
The label for the y-axis (range).

Show a legend or key.

The data for the chart is taken from tables found when the macro body is rendered. These options control how
this data is interpreted. By default, numeric and date values are interpreted according to the Confluence global
default language (locale) formats. If conversion fails, other languages defined in Confluence will be tried.

Additional conversion options can be specified using the parameters below.
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Parameter

Tables

Columns

Content Orientation

Time Series

Date format

Time Period

Language

Default

all first level tables

all columns

horizontal

false

Confluence language defined date
formats

Day

none

80

Description

Comma separated list of table ids
and/or table numbers (starting at
1) contained within the body of the
macro that will be used as the data
for the chart. If data tables are
embedded in other tables, then
table selection will be required.
This occurs when more complex
formatting is done (for example
using section and column macros).

Comma separated list of column
labels and/or column titles and/or
column numbers for tables used
for chart data. This applies to all
tables processed. Columns are
enumerated starting at 1. Column
label is the text for the column in
the header row. Column title is the
(html) title attribute for the column
in the header row.

® vertical — data table
columns will be interpreted
as series.

® horizontal — data tables
rows will be interpreted as
series.

® true — the x values in an
XY plot will be treated as
time series data and so will
be converted according to
date formats.

For time series data, the date
format allows for additional
customization of the conversion of
data to date values. If a Date
format is specified, it will be the
first format used to interpret date
values. Specify a format that
matches the time series data. See
simple date format.

The time period for time series
data. Defines the granularity of
how the data is interpreted. Valid
values are: Millisecond, Second,
Minute, Hour, Day, Week, Month
, Quarter, Year.

Use in combination with the Count
ry parameter to form a locale.
These additional number and date
formats will be used for data
conversion before the default
languages.

Valid values are 2 character ISO
639-1 alpha-2 codes.
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Country

Forgive

Colour Parameters

Colours are specified using hexadecimal notation or HTML colour names.

Parameter
Background Colour
Border Colour

Colours

Axis Parameters

none

true

Default
White

no border

Use in combination with the Lang
uage parameter to form a locale.

Valid values are 2 character ISO

3166 codes.

® true — the macro tries to
convert numeric and date
values that do not totally
match any of the default or
user-specified formats.

® false — enforce strict data
format. Data format errors
will cause the chart to not
be produced.

Description
Background of the chart.
Border around the chart.

Comma-separated list of colours
used to customise category,
sections, and series colours.

Depending on the chart type, the range and domain axis may be customised. These values are automatically
generated based on the data but can be overridden by specifying one or more more of these parameters.

Parameter
Range Minimum Value
Range Maximum Value

Range Axis Tick Unit

Range Axis Label Angle

Domain Axis Lower Bound

Domain Axis Upper Bound

Default
none
none

none

none

none

none

Description
Range axis lower bound.
Range axis upper bound.

Range axis units between axis tick
marks.

Angle for the range axis label in
degrees.

Only applies to XY plots. Domain
axis lower bound. For a date axis,
this value must be expressed in
the date format specified by the D
ate format parameter.

Only applies to XY plots. Domain
axis upper bound. For a date axis,
this value must be expressed in
the date format specified by the D
ate format parameter.
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Domain Axis Tick Unit

Domain Axis Label Angle

Category Label Position

Date Tick Mark Position

Pie Chart Parameters

Parameter

Pie Section Label

none

none

none

start

Default

Show only the pie section key
value

82

Only applies to XY plots. Domain
axis units between axis tick marks.
For a date axis, this value
represents a count of the units
specified in the Time Period para
meter. The Time Period unit can
be overridden by specifying a
trailing character: y (years), M
(months), d (days), h (hours), m
(minutes), s (seconds), u
(milliseconds).

Only applies to XY plots. The
angle for the domain axis label, in
degrees.

Placement of the axis label text for
categories.

® up45 — 45 degrees going
upward

® up90 — 90 degrees going
upward

®* down45 — 45 degrees
going downward

® down90 — 90 degrees
going downward

Placement of the date tick mark.

® start —tick mark is at
the start of the date period.

® mddl e —tick markisin
the middle of the date
period.

® end — tick mark is at the
end of the date period.

Description

Format for how pie section labels
are displayed. The format uses a
string with special replacement
variables:
®* 9%0% is replaced by the pie
section key.
® %1% is replaced by the pie
section numeric value.
® 9%2% is replaced by the pie
section percent value.

Example 1: "%0% = %1%" would
display something like
"Independent = 20"

Example 2: "%0% (%62%)" would
display something like
"Independent (20%)"
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Pie Section Explode No exploded sections Comma separated list of pie keys
that are to be shown exploded.
Note: requires jFreeChart version
1.0.3 or higher.

Attachment Parameters

These are advanced options that can be used for chart versioning, to enable automation and to improve
performance. Use these options carefully! Normally, the chart image is regenerated each time the page is
displayed. These options allow for the generated image to be saved as an attachment and have subsequent
access re-use the attachment. This can be useful especially when combined with the Cache Pluginto improve
performance. Depending on the options chosen, chart images can be versioned for historical purposes.

Parameter Default Description

Attachment none The name and location with which
the chart image will be saved as
an attachment. The user must be
authorised to add attachments to
the page specified.

® MattachmentName.png —
the chart is saved as an
attachment to the current
page.

® page™attachmentName.pn
g — the chart is saved as
an attachment to the page
name provided.

® space:page”attachmentNa
me.png — the chart is
saved as an attachment to
the page name provided in
the space indicated.

Attachment Version new Defines the the versioning
mechanism for saved charts.

® new — creates new
version of the attachment.

® replace — replaces all
previous versions of the
chart. To replace an
existing attachment, the
user must be authorized to
remove attachments for the
page specified.

® keep — only saves a new
attachment if an existing
export of the same name
does not exist. An existing
attachment will not be
changed or updated.

Attachment Comment none Comment used for a saved chart
attachment.
Thumbnail false ® true — the chart image

attachment will be shown
as a thumbnail.

Chart Type Parameters | Display Control Parameters | Title and Label Parameters | Data Specification
Parameters | Colour Parameters | Axis Parameters | Pie Chart Parameters | Attachment Parameters
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Examples

Pie Chart

Parameters in Macro Browser Data Table in Macro

Placeholder
Type pie
) ) Fish 2011

Chart Title Fish Sold 2011 Type

Show Legend true Herring 9,500

Content Orientation vertical Salmon 2,900
Tuna 1,500

Bar Chart

Parameters in Macro Browser Data Table in Macro

Placeholder
Type bar
) ) Fish 2010 2011

Chart Title Fish Sold Type

Show Legend true Herri 9,500 8,300
ng
Salm 2,900 4,200
on

Tuna 1,500 1,500

3D Bar Chart

Parameters in Macro Browser Data Table in Macro
Placeholder
Type bar
) 200 201 201
Show in 3D true 9 0 1

Rendered Chart

Fish Sol¢

Herring —

B Herring {9,500 - 68%)
B Salmon (2,200 - 21%) 0

Rendered Chart

Fish ¢

qann
4,000
EJUUU
F.a00
4,0
6,000

5,000

4Jﬁﬁﬁ
3,000
2,000

1 J I:I I:I I:I I .

2010

W Herring m 5al

Rendered Chart
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Opacity 50

Show Legend true

Time Series Chart

Parameters in Macro Browser

Type Time Series
Date Format MM/yyyy
Time Period Month

Content Orientation  vertical

Range Axis Lower 0
Bound

Show Legend true

XY Line Chart

Parameters in Macro Browser

Type xyLine

Show Legend true

Data Tables in Macro Placeholder

Month

1/2011
2/2011
3/2011
4/2011
5/2011
6/2011
7/2011
8/2011
9/2011

10/201
1

11/201
1

12/201
1

Re
ven
ue

Ex
pen
se

Reven
ue

31.8
41.8
51.3
33.8
27.6
49.8
51.8
77.3
73.8
97.6

101.2

113.7

Data Table in Macro

12.

43.

6

Month

1/2011
2/2011
3/2011
4/2011
5/2011
6/2011
7/2011
8/2011
9/2011

10/201
1

11/201
1

12/201
1

14

Placeholder
12
Re 41.

31.

41. 45
1

410
31. i
1 1]

2009

o
201

W Eevenue B

Expen 1o
ses 100
41.1 "
43.8 70
45.3
45.0 i
44.6 a0
43.8
51.8 0

0114

-
&

52.3

01/

53.8
55.6

61.2

63.7

Rendered Chart

23
12.
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ven 1 8 4 45
ue
40
Ex 31. 41. 43.
pen 1 8 6 35
se -
25
20
15
10
5
12 13 14 15 16 17
— FEVENLE =
XY Area Chart
Parameters in Macro Browser Data Table in Macro Rendered Chart
Placeholder
Type xyArea
12 14 23
Show Legend true

Re 41. 31. 12.
ven 1 8 4
ue

Ex 31. 41. 43
pen 1 8 6

se
12 13 14 15 16 17
A Fevenue &
Area Charts
Example 1
Parameters in Macro Browser Data Table in Macro Rendered Chart
Placeholder
Type area
Sat 200 201 201
Show Legend true isf 9 0 1
Width 300 CIE
ion
Height 300
'9 Ver 20 23 34
Opacity 50 y
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sati
sfie

Sat 40 34 23
isfi
ed

Dis 25 26 25
sati
sfie

Ver 15 17 18

dis

. 2009
sati

20

sfie mVery satisfied m Satisfiec

I Very dissatisfied

Example 2

Parameters in Macro Data Table in Macro Rendered Chart
Browser Placeholder

Type area

Sat 200 201 201 Loo
Show Legend true isf 9 0 1 5

Width 300 act 80
on .
Height 300
i Ver 12 23 31

Stacked Values true y
sati
sfie
d

Sat 1 34 36
isfi
ed

2009

Dis 4 6 22

21

sati m Very satisfied m Satisfiec

sfie

d Weny dissatisfied

Ver 2 7 12

y
dis
sati
sfie
d

Gantt Chart

Parameters in Macro Browser Data Table in Macro Rendered Chart
Placeholder

Type gantt

) Pla Sta En Sta
Width 300 n rt d tus
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Height 200 Sta
ge
Columns »1,2,3,4 1

Date format MM/dd/yyyy

Sta
ge

Sta
ge

Act
ual

Sta
ge

Sta
ge

Sta
ge

Code examples

6/
25
/2
01

7/
13
/2
01

12
/1
/2
01

Sta
rt

6/
25
/2
01

71
29
/2
01

12
/1
o/

20
13

7/

10
/2
01

11
/2
8/

20
13

12
/2
5/

20
13

En

7/
26
/2
01

12
/10
1/

20
13

12
/12
5/

20
13

30
%

40
%

Sta
tus

10

0%

40
%

o7g01j2zo1s 09j01/2c

Stage 1

Stage 2

Stage 3

The following examples are provided for advanced users who want to edit the underlying markup for a

Confluence page.

Macro name: chart

Macro body: Accepts rich text, consisting of tables that hold the chart's data.

This macro recognises a large number of parameters, listed here by type for convenience.

~ See all parameters...

Chart type parameters

These parameters determine the type of chart to display and how the chart looks.

Parameter Required Default

Description
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type

orientation

3D

st acked

showShapes

opacity

Chart display parameters

Parameter

wi dt h

hei ght

No

No

No

No

No

No

Required

No

No

pi e

verti cal

fal se

fal se

true

® 75 percent for 3D
charts

® 50 percent for
non-stacked area
charts

® 100 percent for all
other charts

Default
300

300

89

The type of chart to
display. XY charts have
numerical x- and y-axes.
The x values may
optionally be
time-based. See the t i
nmeSer i es parameter.

Available values:

® Standard charts -
pie, bar, I|ine,
area

® XY plots — xyAr ea,
xyBar, xyLi ne,
xy St ep,
Xy St epAr ea,
scatter,
ti meSeries

® Other charts — gant
t

The display orientation.
Applies to area, bar and
line charts.

Available values:

® vertical - y-axis
is vertical

® horizontal —
X-axis is vertical

Show in three
dimensions. Applies to
area, bar and line
charts.

Stacked values. Applies
to area and bar charts.

Applies to line charts.
Shapes are shown at
each data point.

A percentage value
between 0 (transparent)
and 100 (opaque) that
determines how opaque
the foreground areas
and bars are.

Description

The width of the chart in
pixels.

The height of the chart
in pixels.
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dat aDi spl ay

i mageFor nat

Chart title and label parameters

Parameter
title
subTitl e

xLabel

yLabel

| egend

Chart data parameters

No

No

Required
No
No
No

No

No

fal se

png

Default
(None)
(None)
(None)

(None)

fal se

90

Determines whether to
display the body of the
macro, consisting of the
data table. By default,
the chart data table is
not displayed.

Available values:

® false —the datais
not displayed.

® trueorafter —
the data is displayed
after the chart.

® before - the data
is displayed before
the chart.

The image format to be
used for the chart.

Available values:

® png
* ipg

Description
The title of the chart.
A subtitle for the chart.

The label for the x-axis
(domain).

The label for the y-axis
(range).

Determines whether to
show a legend (key) for
the chart.

The data for the chart is taken from tables found in the macro body. The parameters below control how this
data is interpreted. By default, numeric and date values are interpreted according to the Confluence global
default language (locale) formats. If conversion fails, other languages defined in Confluence will be tried. You

can specify additional conversion options using the parameters below.

Parameter

Required

Default

Description
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t abl es

col ums

dataOrientation

timeSeries

No

No

No

No

All first level tables

All columns

hori zont al

fal se

91

You can supply a
comma-separated list of
table IDs and/or table
numbers (starting at 1)
contained within the
body of the macro that
will be used as the data
for the chart. If data
tables are embedded in
other tables, then table
selection will be
required. This occurs
when more complex
formatting is done (for
example using section
and column macros).

You can supply a
comma-separated list of
column labels and/or
column titles and/or
column numbers for
tables used for chart
data. This applies to all
tables processed.
Columns are
enumerated starting at
1. Column label is the
text for the column in the
header row. Column title
is the HTML title
attribute for the column
in the header row.

The content orientation.
By default, the data
tables will be interpreted
as columns
(horizontally)
representing domain
and x values.

Available values:

® vertical - data
table columns will be
interpreted as
series.

® horizontal - dat
a tables rows will be
interpreted as
series.

If 't rue’, the x values in
an XY plot will be
treated as time series
data and so will be
converted according
date formats.
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dat eFor mat

ti mePeri od

| anguage

country

No

No

No

No

Confluence language
defined date formats

day

(None)

(None)

For time series data, the
date format allows for
additional customisation
of the conversion of data
to date values. If adat e
For mat is specified, it
will be the first format
used to interpret date
values. Specify a format
that matches the time
series data. See simple
date format.

The time period for time
series data. Defines the
granularity of how the
data is interpreted.

Available values: mi | |'i
second, second,

m nute, hour, day,
week, nonth,
quarter, year

Use in combination with
the count ry parameter
to form a locale.

These additional
number and date
formats will be used for
data conversion before
the default languages.

Available values are the
two-character 1ISO 639-1
alpha-2 codes.

Use in combination with
the | anguage paramet
er to form a locale. Valid
values are the
two-character ISO 3166
codes.
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forgive

Chart colour parameters

Colours are specified using hexadecimal notation or HTML colour names.

Parameter

bgCol or

bor der Col or

col ors

Chart axis parameters

No

Required
No

No

No

true

Default

White

No border

93

Determines whether the
macro will forgive (allow)
some data formatting
errors.

Available values:

® true — the macro
tries to convert
numeric and date
values that do not
totally match any of
the default or
user-specified
formats.

®* fal se —the macro
enforces strict data
formatting. If there
are data format
errors, the chart will
not be produced.

Description

Background colour of
the chart.

Colour of the border
around the chart.

A comma-separated list
of colours used to
customise the colours of
categories, sections,
and series.

Depending on the chart type, the range and domain axis may be customised. These values are automatically
generated based on the data but can be overridden by specifying one or more more of these parameters.

Parameter

rangeAxi sLower Boun
d

rangeAxi sUpper Boun
d

rangeAxi sTi ckUni t

rangeAxi sLabel Angl
e

Required
No

No

No

No

Default
(None)

(None)

(None)

(None)

Description

Minimum value for the
range axis.

Maximum value for the
range axis.

Range axis units
between axis tick marks.

Angle for the range axis
label in degrees.
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domai nAxi sLower Bou
nd

domai nAxi sUpper Bou
nd

domai nAxi sTi ckUni t

domai nAxi sLabel Ang
le

cat egor yLabel Posi t
i on

No

No

No

No

No

(None)

(None)

(None)

(None)

(None)

94

Only applies to XY plots.
Domain axis lower
bound. For a date axis,
this value must be
expressed in the date
format specified by the d
at eFor mat parameter.

Only applies to XY plots.
Domain axis upper
bound. For a date axis,
this value must be
expressed in the date
format specified by the d
at eFor mat parameter.

Only applies to XY plots.
Domain axis units
between axis tick marks.
For a date axis, this
value represents a count
of the units specified in
the ti mePeri od param
eter. The t i nePeri od
unit can be overridden
by specifying a trailing
character: y (years), M(
months), d (days), h (ho
urs), m(minutes), s (sec
onds), u (milliseconds).

Only applies to XY plots.
The angle for the
domain axis label, in
degrees.

Placement of the axis
label text for categories.

Available values:

® up45 — 45 degrees
going upward

® up90 — 90 degrees
going upward

®* down45 — 45
degrees going
downward

® down90 — 90
degrees going
downward
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dat eTi ckMar kPosi ti
on

Pie chart Parameters

Parameter

pi eSecti onLabel

pi eSecti onExpl ode

Chart attachment parameters

No

Required
No

No

start

Default

Show only the pie
section key value

No exploded sections

95

Placement of the date
tick mark.

Available values:

® start —tick mark
is at the start of the
date period.

® i ddl e —tick mark
is in the middle of
the date period.

® end — tick mark is
at the end of the
date period.

Description

Formatof pie section
labels. The format uses
a string with special
replacement variables:
® 9%9%is replaced by
the pie section key.
® 9% %is replaced by
the pie section
numeric value.
* 9%2%is replaced by
the pie section
percent value.

Example 1: To display
something like
'Independent = 20"

%% =
%%

Example 2: To display
something like
'Independent (20%)":

%%
(%29

A comma-separated list
of pie keys that are to be
shown exploded. Note:
requires jFreeChart
version 1.0.3 or higher.

These are advanced options that can be used for chart versioning, to enable automation and to improve
performance. Use these options carefully! Normally, the chart image is regenerated each time the page is
displayed. These options allow for the generated image to be saved as an attachment and have subsequent
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access to re-use the attachment. This can be useful especially when combined with the Cache plugin to
improve performance. Depending on the options chosen, chart images can be versioned for historical

purposes.
Parameter Required Default Description
attachnent No (None) The name and location

where the chart image
will be saved as an
attachment. The user
must be authorised to
add attachments to the
page specified.

Available syntax for this
parameter:

¢ Mattachment Name
. png — the chart is
saved as an
attachment to the
current page.

® page
nane”at t achnent
Nane. png — the
chart is saved as an
attachment to the
page name
provided.

® spacekey: page n
ane”at tachment N
anme. png — the
chart is saved as an
attachment to the
page name provided
in the space
indicated.
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at t achment Ver si on

at t achment Comment

t hunbnai |

Storage format example

No

No

No

new

(None)

fal se

Defines the the
versioning mechanism
for saved charts.

Available values:

® new— creates new

version of the
attachment.

repl ace —
replaces all previous
versions of the chart.
To replace an
existing attachment,
the user must be
authorised to
remove attachments
for the page
specified.

keep — only saves
a new attachment if
an existing export of
the same name
does not exist. An
existing attachment
will not be changed
or updated.

Comment used for a
saved chart attachment.

If t rue, the chart
image attachment will
be shown as a
thumbnail (small,
expandable) image.

Below is a simple example of a pie chart. See more examples in Storage Format Examples for Chart Macro.
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<ac:structured-nmacro ac: nane="chart">
<ac: paraneter ac:nane="title">Fi sh Sol d</ ac: par aneter >
<ac: paraneter ac:nanme="type">pi e</ac: par anet er >
<ac:rich-text-body>
<t abl e>
<t body>
<tr>
<t h>
<p>Fi sh Type</ p>
</th>
<t h>
<p>2004</ p>
</th>
<t h>
<p>2005</ p>
</th>
</[tr>
<tr>
<t h>
<p>Herri ng</ p>
</th>
<t d>
<p>9, 500</ p>
</td>
<td>
<p>8, 300</ p>
</td>
</tr>
<tr>
<t h>
<p>Sal non</ p>
</th>
<td>
<p>2, 900</ p>
</td>
<t d>
<p>4, 200</ p>
</td>
</[tr>
<tr>
<t h>
<p>Tuna</ p>
</th>
<t d>
<p>1, 500</ p>
</td>
<t d>
<p>1, 500</ p>
</td>
</[tr>
</ t body>
</tabl e>
</ac:rich-text-body>
</ ac: structured- macr o>

Wiki markup example

Below is a simple example of a pie chart. See more examples in Wiki Markup Examples for Chart Macro.
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{chart:type=pie|title=Fish Sol d}
|| Fish Type || 2004 || 2005 |
|| Herring | 9,500 | 8,300

|| Salmon | 2,900 | 4,200

|| Tuna | 1,500 | 1,500

{chart}

Confluence Storage Format Examples for Chart Macro

This page is an extension of the documentation for the Chart Macro. This page contains additional examples for
the Chart macro.

Pie chart
Here is a simple example of a pie chart.

Storage format
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<ac:structured-macro ac: nane="chart">
<ac: paraneter ac:nane="title">Fi sh Sol d</ ac: par anet er >
<ac: paraneter ac:nanme="type">pi e</ac: par anet er >
<ac:rich-text-body>
<t abl e>
<t body>
<tr>
<t h>
<p>Fi sh Type</p>
</th>
<t h>
<p>2004</ p>
</th>
<t h>
<p>2005</ p>
</th>
</tr>
<tr>
<t h>
<p>Herri ng</ p>
</th>
<t d>
<p>9, 500</ p>
</td>
<t d>
<p>8, 300</ p>
</td>
</tr>
<tr>
<t h>
<p>Sal non</ p>
</th>
<t d>
<p>2, 900</ p>
</td>
<td>
<p>4, 200</ p>
</td>
</[tr>
<tr>
<t h>
<p>Tuna</ p>
</th>
<td>
<p>1, 500</ p>
</td>
<t d>
<p>1, 500</ p>
</td>
</tr>
</ t body>
</ tabl e>
</ac:rich-text-body>
</ ac: structured- macr o>

Resulting chart
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Fish Sold

2005

2004

m2004 (1,500 -50% m2005 (1,500 - 50%)

Bar chart
Here is a simple example of a bar chart.

Storage format
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<ac: nmacro ac:nane="chart">
<ac: paraneter ac:nane="title">Fi sh Sol d</ ac: par anet er >
<ac: paraneter ac:nanme="type">bar</ac: par anet er >
<ac:rich-text-body>
<t abl e>
<t body>
<tr>
<t h>
<p>Fi sh Type</p>
</th>
<t h>
<p>2004</ p>
</th>
<t h>
<p>2005</ p>
</th>
</[tr>
<tr>
<t h>
<p>Herri ng</ p>
</th>
<t d>
<p>9, 500</ p>
</td>
<t d>
<p>8, 300</ p>
</td>
</[tr>
<tr>
<t h>
<p>Sal non</ p>
</th>
<t d>
<p>2, 900</ p>
</td>
<t d>
<p>4, 200</ p>
</td>
</[tr>
<tr>
<t h>
<p>Tuna</ p>
</th>
<t d>
<p>1, 500</ p>
</td>
<td>
<p>1, 500</ p>
</td>
</tr>
</ t body>
</ tabl e>
</ac:rich-text-body>
</ ac: macr o>

Resulting chart

Created in 2014 by Atlassian. Licensed under a Creative Commons Attribution 2.5 Australia License.

102


http://creativecommons.org/licenses/by/2.5/au/

Confluence 5.5 Documentation 103
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Time series chart
Here is an example of a time series chart.

Storage format

<ac:structured-nmacro ac: nane="chart">
<ac: paraneter ac:nane="tinePeriod">Mnt h</ac: paranet er >
<ac: paraneter ac:nane="dataOrientation">vertical </ ac: paraneter>
<ac: paraneter ac:nanme="rangeAxi sLower Bound" >0</ ac: par anet er >
<ac: paranet er ac:nane="dat eFor mat">MV yyyy</ ac: par anet er >
<ac: paraneter ac:nane="type">tinmeSeries</ac: paraneter>
<ac: paraneter ac:nane="donai naxi srot ateti ckl abel ">true</ac: par anet er >
<ac:rich-text-body>
<t abl e>
<t body>
<tr>
<t h>
<p>Mont h</ p>
</th>
<t h>
<p>Revenue</ p>
</th>
</tr>
<tr>
<t d>
<p>1/2005</ p>
</td>
<t d>
<p>31. 8</ p>
</td>
</tr>
<tr>
<t d>
<p>2/ 2005</ p>
</td>
<t d>
<p>41. 8</ p>
</td>
</tr>
<tr>
<t d>
<p>3/ 2005</ p>
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</td>
<t d>
<p>51. 3</ p>
</td>
</tr>
<tr>
<t d>
<p>4/ 2005</ p>
</td>
<t d>
<p>33. 8</ p>
</td>
</tr>
<tr>
<t d>
<p>5/2005</ p>
</td>
<t d>
<p>27. 6</ p>
</td>
</tr>
<tr>
<t d>
<p>6/2005</ p>
</td>
<t d>
<p>49. 8</ p>
</td>
</tr>
<tr>
<t d>
<p>7/2005</ p>
</td>
<t d>
<p>51. 8</ p>
</td>
</tr>
<tr>
<t d>
<p>8/ 2005</ p>
</td>
<t d>
<p>77. 3</ p>
</td>
</tr>
<tr>
<t d>
<p>9/ 2005</ p>
</td>
<t d>
<p>73. 8</ p>
</td>
</tr>
<tr>
<t d>
<p>10/ 2005</ p>
</td>
<t d>
<p>97. 6</ p>
</td>
</tr>
<tr>
<t d>
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<p>11/ 2005</ p>
</td>
<t d>
<p>101. 2</ p>
</td>
</[tr>
<tr>
<t d>
<p>12/ 2005</ p>
</td>
<t d>
<p>113. 7</ p>
</td>
</[tr>
</t body>
</t abl e>
<t abl e>
<t body>
<tr>
<t h>
<p>Mont h</ p>
</th>
<t h>
<p>Expenses</ p>
</th>
</[tr>
<tr>
<t d>
<p>1/2005</ p>
</td>
<t d>
<p>41. 1</ p>
</td>
</[tr>
<tr>
<t d>
<p>2/ 2005</ p>
</td>
<t d>
<p>43. 8</ p>
</td>
</[tr>
<tr>
<t d>
<p>3/ 2005</ p>
</td>
<t d>
<p>45. 3</ p>
</td>
</[tr>
<tr>
<t d>
<p>4/ 2005</ p>
</td>
<t d>
<p>45. 0</ p>
</td>
</[tr>
<tr>
<t d>
<p>5/2005</ p>
</td>
<t d>

Created in 2014 by Atlassian. Licensed under a Creative Commons Attribution 2.5 Australia License.

105


http://creativecommons.org/licenses/by/2.5/au/

Confluence 5.5 Documentation

<p>44. 6</ p>
</td>
</[tr>
<tr>
<t d>
<p>6/2005</ p>
</td>
<t d>
<p>43. 8</ p>
</td>
</[tr>
<tr>
<t d>
<p>7/ 2005</ p>
</td>
<t d>
<p>51. 8</ p>
</td>
</[tr>
<tr>
<t d>
<p>8/ 2005</ p>
</td>
<t d>
<p>52. 3</ p>
</td>
</[tr>
<tr>
<t d>
<p>9/ 2005</ p>
</td>
<t d>
<p>53. 8</ p>
</td>
</[tr>
<tr>
<t d>
<p>10/ 2005</ p>
</td>
<t d>
<p>55. 6</ p>
</td>
</[tr>
<tr>
<t d>
<p>11/2005</ p>
</td>
<t d>
<p>61. 2</ p>
</td>
</[tr>
<tr>
<t d>
<p>12/ 2005</ p>
</td>
<t d>
<p>63. 7</ p>
</td>
</[tr>
</ t body>
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</t abl e>
</ac:rich-text-body>
</ ac: structured-nmacro>

Resulting chart
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XY line chart

Here is an example of an XY line chart.

Storage format

Created in 2014 by Atlassian. Licensed under a Creative Commons Attribution 2.5 Australia License.


http://creativecommons.org/licenses/by/2.5/au/

Confluence 5.5 Documentation 108

<ac:macro ac: nanme="chart">
<ac: paraneter ac:nanme="type">xyline</ac: paraneter>
<ac:rich-text-body>
<t abl e>
<t body>
<tr>
<t h>
<p>&nbsp; </ p>
</th>
<t h>
<p>12</ p>
</th>
<t h>
<p>14</ p>
</th>
<t h>
<p>23</ p>
</th>
</[tr>
<tr>
<t d>
<p>Revenue</ p>
</td>
<td>
<p>41. 1</ p>
</td>
<t d>
<p>31. 8</ p>
</td>
<t d>
<p>12. 4</ p>
</td>
</tr>
<tr>
<t d>
<p>Expense</ p>
</td>
<t d>
<p>31. 1</ p>
</td>
<t d>
<p>41. 8</ p>
</td>
<td>
<p>43. 6</ p>
</td>
</[tr>
</t body>
</ tabl e>
</ac:rich-text-body>
</ ac: macr o>

Resulting chart
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XY bar chart
Here is an example of an XY bar chart.

Storage format
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<ac:structured-macro ac: nane="chart">
<ac: paranet er ac: name="opacity">60</ac: paranet er >
<ac: paraneter ac: name="type">xybar </ ac: par anet er >
<ac:rich-text-body>
<t abl e>
<t body>
<tr>
<t h>
<p> </ p>
</th>
<t h>
<p>2005</ p>
</th>
<t h>
<p>2006</ p>
</th>
<t h>
<p>2007</ p>
</th>
</tr>
<tr>
<t d>
<p>Revenue</ p>
</td>
<t d>
<p>41. 1</ p>
</td>
<td>
<p>31. 8</ p>
</td>
<t d>
<p>12. 4</ p>
</td>
</tr>
<tr>
<td>
<p>Expense</ p>
</td>
<t d>
<p>31. 1</ p>
</td>
<t d>
<p>41. 8</ p>
</td>
<t d>
<p>43. 6</ p>
</td>
</tr>
</t body>
</ tabl e>
</ac:rich-text-body>
</ ac: structured- macr o>

Resulting chart
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XY area chart
Here is an example of an XY area chart.

Storage format
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<ac:structured-nmacro ac: name="chart">
<ac: paraneter ac: nanme="type">xyarea</ ac: par anet er >
<ac:rich-text-body>
<t abl e>
<t body>
<tr>
<t h>
<p> </ p>
</th>
<t h>
<p>12</ p>
</th>
<t h>
<p>14</ p>
</th>
<t h>
<p>23</ p>
</th>
</[tr>
<tr>
<t d>
<p>Revenue</ p>
</td>
<t d>
<p>41. 1</ p>
</td>
<t d>
<p>31. 8</ p>
</td>
<t d>
<p>12. 4</ p>
</td>
</tr>
<tr>
<t d>
<p>Expense</ p>
</td>
<t d>
<p>31. 1</ p>
</td>
<t d>
<p>41. 8</ p>
</td>
<td>
<p>43. 6</ p>
</td>
</[tr>
</t body>
</ tabl e>
</ac:rich-text-body>
</ ac: structured-nmacro>

Resulting chart
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Here are two examples of area charts.

Storage format for area chart 1
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<ac: structured-nacro ac: name="chart">

<ac: par anet er ac:nane="hei ght">300</ac: par anet er >
<ac: par aneter ac:nane="| egend" >t rue</ ac: par anet er >
<ac: paraneter ac:nane="w dt h">300</ ac: par anet er >
<ac: paraneter ac:nane="opacity">50</ac: paranet er>
<ac: paraneter ac:nane="type">area</ ac: paranet er >
<ac: par anet er ac: nane="dat aDi spl ay" >t rue</ ac: par anet er >
<ac:rich-text-body>
<t abl e>
<t body>
<tr>
<t h>
<p>Sati sfaction</p>
</th>
<t h>
<p>2002</ p>
</th>
<t h>
<p>2003</ p>
</th>
<t h>
<p>2004</ p>
</th>
</tr>
<tr>
<td>
<p>Very sati sfied</p>
</td>
<td>
<p>20</ p>
</td>
<t d>
<p>23</ p>
</td>
<t d>
<p>34</ p>
</td>
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</tr>
<tr>
<t d>
<p>Sati sfied</ p>
</td>
<t d>
<p>40</ p>
</td>
<td>
<p>34</ p>
</td>
<t d>
<p>23</ p>
</td>
</tr>
<tr>
<td>
<p>Di sati sfi ed</ p>
</td>
<t d>
<p>25</ p>
</td>
<t d>
<p>26</ p>
</td>
<t d>
<p>25</ p>
</td>
</tr>
<tr>
<t d>
<p>Very disati sfied</p>
</td>
<t d>
<p>15</ p>
</td>
<td>
<p>17</ p>
</td>
<t d>
<p>18</ p>
</td>
</tr>
</ t body>
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</tabl e>

</ ac:rich-text-body>
</ ac: structured-mcro>

Resulting area chart 1
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Storage format for area chart 2

2002 2003 2004
20 23 34
40 34 23
25 26 25
15 17 18

<ac:structured-macro ac: nane="chart">

<ac: par anet er
<ac: par anet er
<ac: par anet er
<ac: par anet er
<ac: par anet er
<ac: par anet er

ac:
ac:
ac:
ac:
ac:
ac:

name="st acked" >t r ue</ ac: par anet er >
nanme="hei ght " >300</ ac: par anet er >
nanme="| egend" >t r ue</ ac: par anet er >
name="wi dt h" >300</ ac: par anet er >
nanme="t ype" >ar ea</ ac: par anet er >
nanme="dat aDi spl ay" >t rue</ ac: par anet er >

<ac:rich-text-body>

<t abl e>
<t body>
<tr>
<t h>

<p>Sati sfacti on</p>

</th>

<t h>

<p>2002</ p>

</th>

<t h>

<p>2003</ p>

</th>

<t h>

<p>2004</ p>

</th>

</tr>
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<tr>
<t d>
<p>Very sati sfied</p>
</td>
<td>
<p>12</ p>
</td>
<t d>
<p>23</ p>
</td>
<t d>
<p>31</ p>
</td>
</tr>
<tr>
<t d>
<p>Sati sfi ed</ p>
</td>
<t d>
<p>1</ p>
</td>
<t d>
<p>34</ p>
</td>
<td>
<p>36</ p>
</td>
</[tr>
<tr>
<t d>
<p>Di sat i sfi ed</ p>
</td>
<td>
<p>4</ p>
</td>
<t d>
<p>6</ p>
</td>
<t d>
<p>22</ p>
</td>
</tr>
<tr>
<t d>
<p>Very disatisfied</p>
</td>
<t d>
<p>2</ p>
</td>
<t d>
<p>7</ p>
</td>
<td>
<p>12</ p>
</td>
</[tr>
</ t body>
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</t abl e>
</ ac:rich-text-body>
</ ac: struct ured-macr o>

Resulting area chart 2

100

2002 2003 2004

mVery satisfied m5atisfied m Disatisfied
WVery disatisfied

Satisfaction 2002 2003 2004
Very satisfied 12 23 31
Satisfied 1 34 36
Disatisfied 4 6 22
Very disatisfied 2 7 12

Wiki Markup Examples for Chart Macro

This page is an extension of the documentation for the Chart Macro. This page contains additional examples for
the Chart macro.

Pie chart
Here is a simple example of a pie chart.
Wiki markup
{chart:type=pie|title=Fish Sold}
|| Fish Type || 2004 || 2005 ||
|| Herring | 9,500 | 8,300 |
|| Salnon | 2,900 | 4,200 |

|| Tuna | 1,500 | 1,500 |
{chart}

Resulting chart
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Fish Sold

2005

2004

m2004 (1,500 -50% m2005 (1,500 - 50%)

Bar chart
Here is a simple example of a bar chart.

Wiki markup

{chart:type=bar|title=Fish Sold}
|| Fish Type || 2004 || 2005 |
|| Herring | 9,500 | 8,300 |

|| Salmon | 2,900 | 4,200

|| Tuna | 1,500 | 1,500

{chart}

Resulting chart

Fish Sold

9,000
8,000
7,000
6,000
5,000
4,000
3,000
2,000
1,000

2004 2005

B Herring m Salmon ® Tuna

Time series chart
Here is an example of a time series chart.

Wiki markup
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{chart:type=tineSeries|dat eFor mat =MV yyyy| ti nePeri od=Mont h|
dataOri entation=vertical | rangeAxi sLower Bound=0| domai naxi srot at eti ckl abel =t r ue}

|| Month || Revenue ||
| 1/2005 | 31.8 |
| 2/2005 | 41.8 |
| 3/2005 | 51.3 |
| 4/2005 | 33.8 |
| 5/2005 | 27.6 |
| 6/2005 | 49.8 |
| 7/2005 | 51.8 |
| 8/2005 | 77.3 |
| 9/2005 | 73.8 |
| 10/2005 | 97.6 |
| 11/2005 | 101.2 |
| 12/2005 | 113.7 |
|| Month || Expenses ||
| 1/2005 | 41.1 |
| 2/2005 | 43.8 |
| 3/2005 | 45.3 |
| 4/2005 | 45.0 |
| 5/2005 | 44.6 |
| 6/2005 | 43.8 |
| 7/2005 | 51.8 |
| 8/2005 | 52.3 |
| 9/2005 | 53.8 |
| 10/2005 | 55.6 |
| 11/2005 | 61.2 |
| 12/2005 | 63.7 |
{chart}
Resulting chart

110

100

ag

1]

5]

50

40

30

20

10
1] i i i i i i i 5 i i i

= FEvEnue =Expenses
XY line chart

Here is an example of an XY line chart.

Wiki markup
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{chart:type=xyline}

[T 12 0] 14 || 23 ||

| Revenue | 41.1 | 31.8 | 12.4
| Expense | 31.1 | 41.8 | 43.6
{chart}

Resulting chart

12 13 14 15 16 17 18 19 20 21 22 23
= FEyene = Fxpense

XY bar chart

Here is an example of an XY bar chart.

Wiki markup

{chart:type=xybar| opacity=60}

[| || 2005 || 2006 || 2007 |

| Revenue | 41.1 | 31.8 | 12.4 |

| Expense | 31.1 | 41.8 | 43.6 |
{chart}

Resulting chart
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45
40
35
30
25
20
15

10

2,005 2,006 2,007

B Eevenue N Expense

XY area chart
Here is an example of an XY area chart.
Wiki markup

{chart:type=xyarea}

[ 11 12 0] 14 ] 23 ||

| Revenue | 41.1 | 31.8 | 12.4

2.4 |
| Expense | 31.1 | 41.8 | 43.6 |
{chart}

Resulting chart

45
40
35
30
25
20
15

10

12 13 14 15 16 17 18 19 20 21 22 23

m Revenue m Expense

Area chart
Here are two examples of area charts.

Wiki markup for area chart 1
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{chart:type=area| dat aD spl ay=true| | egend=t r ue| wi dt h=300| hei ght =300| opaci t y=50}
|| Satisfaction || 2002 || 2003 ||

| Very satisfied | 20 | 23 | 34 |
| Satisfied | 40 | 34 | 23 |
| Disatisfied | 25| 26 | 25 |

| Very disatisfied | 15| 17 | 18 |

{chart}

Resulting area chart 1
40
35
30
25
20
15

ia

2002 2003 2004

mVery satisfied m Satisfied m Disatisfied
Wery disatisfied

Satisfaction 2002
Very satisfied 20
Satisfied 40
Disatisfied 25
Very disatisfied 15

Wiki markup for area chart 2

{chart:type=area| dat aD spl ay=true| | egend=t r ue| wi dt h=300| hei ght =300| st acked=t r ue}

|| Satisfaction || 2002 || 2003 ||
| Very satisfied | 12 | 23 | 31 |
| Satisfied | 1| 34| 36 |

| Disatisfied | 4| 6| 22 |

| Very disatisfied | 2| 7| 12 |
{chart}

Resulting area chart 2
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2002 2003 2004
mVery satisfied m5atisfied m Disatisfied
Wery disatisfied

Satisfaction 2002 2003 2004
Very satisfied 12 23 31
Satisfied 1 34 36
Disatisfied 4 6 22
Very disatisfied 2 7 12

Cheese Macro

The Cheese macro simply displays the words "I like cheese!" You can use this macro to test the Confluence
macro functionality. (£

To add the Cheese macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of
suggested macros. Details are in Using Autocomplete.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open,
where you can edit the parameters of the macro.

Note: There are no parameters for this macro.
Code examples

The following examples are provided for advanced users who want to edit the underlying markup for a
Confluence page.

Macro name: cheese
Macro body: None.

Parameters: None

Storage format example

<ac: structured-macro ac: nane="cheese"/ >

Wiki markup example
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{cheese}

Children Display Macro

Use the Children Display macro to list the child pages of a page and the further descendants (children's
children). By default, the macro displays links to the child pages as shown in the screenshot below. People
viewing the page will see only the links for pages that they have permission to view.

Screenshot: The Children Display macro in Confluence

This is the Children Display macro

« Step 1 - download the game

 Step 2 - Play

« Step 3 - share your favourite nerd
Sample page

Games as a communication medium

Using the Children Display macro

To add the Children Display macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of
suggested macros. Details are in Using Autocomplete.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open,
where you can edit the parameters of the macro.
Example

This list of child pages is generated by a Children Display macro on this page:

® Child Page 1
® Child Page 2

Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the
parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro
browser, it will be listed below in brackets (exanpl e).

Parameter Default Description
Show Descendants false Choose whether to display all the
(all) parent page's descendants.

If t r ue shows the complete tree of
pages underneath the parent
page, regardless of Depth of
Descendants
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Parent Page
(page)

Number of Children
(first)

Depth of Descendants
(dept h)

Heading Style
(style)

Include Excerpts
(excerpt)

Sort Children By
(sort)

Reverse Sort
(reverse)

Code examples

current

none

none

none

false

Manual if manually ordered,
otherwise alphabetical

false

125

Specify the page to display
children for, from either the current
space or a different space. Enter:

® '/' —tolist the top-level
pages of the current space, i.e.
those without parents.

® ' pagenane' — to listthe
children of the specified page.

® 'spacekey:' —tolistthe
top-level pages of the specified
space.

® 'spacekey: pagenane' —to
list the children of the specified
page in the specified space.

Restrict the number of child pages
that are displayed at the top level.

Enter a number to specify the
depth of descendants to display. F
or example, if the value is 2, the
macro will display 2 levels of child
pages.

This setting has no effect of Show
Descendants is enabled.

Choose the style used to display
descendants.

Display excerpts for the child
pages, if they exist.

Optional. Choose:

® creation — to sort by content
creation date

® title — to sort alphabetically on
title

®* modified — to sort of last
modification date.

Use with the Sort Children By par
ameter. When set, the sort order
changes from ascending to
descending.

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a

Confluence page.
Macro name: chi | dren

Macro body: None.

Storage format example
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<ac: structured-nmacro ac: nane="chil dren">
<ac: parameter ac:nane="reverse">true</ac: paraneter>
<ac: paraneter ac:name="sort">creation</ac: paraneter>
<ac: paranet er ac: nane="styl e">h4</ac: par anet er >
<ac: par anet er ac: nane="page">
<ac: |ink>
<ri:page ri:content-title="Home"/>
</ac:|ink>
</ ac: par anet er >
<ac: paramet er ac: nane="excerpt">true</ac: paraneter>
<ac: parameter ac:nane="first">99</ac: paraneter >
<ac: par anet er ac: nanme="dept h">2</ac: par anet er >
<ac: paraneter ac:nane="all">true</ac: paraneter>
</ ac: struct ured- nacr o>

Wiki markup example

{children:reverse=true| sort=creation|styl e=h4| page=Hone| excer pt=true| first=99| depth
=2| al | =t rue}

Child Page 1

Grandchild
Child Page 2

This page is used to test the {children} macro.
Related Topics

Children Display Macro
Code Block Macro

The Code Block macro allows you to display source code in your document with the appropriate syntax
highlighting. The code block displays on the page as shown below:

public static void main(String[] args)

{
Systemout.printin("Hello Wrld!l");

}

Using the Code Block Macro
To add the Code Block macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of
suggested macros. Details are in Using Autocomplete.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open,
where you can edit the parameters of the macro.

You type the code block directly into the macro placeholder in the editor. Note that any white space contained in
the placeholder is not manipulated in any way by the Code Block macro. This is to provide the writer with
flexibility over code indentation.

Parameters
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Parameters are options that you can set to control the content or format of the macro output. Where the
parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro
browser, it will be listed below in brackets (exanpl e).

Parameter Default Description
Syntax highlighting java Specifies the language (or
(1 anguage) environment) for syntax

highlighting. The default language
is Java but you can choose from
one of the following
languages/environments:

actionscript3
bash
csharp (C#)
coldfusion
cpp (C++)
CSS

delphi

diff

erlang
groovy
htmI/xml
java

javafx
javascript
none (no syntax highlighting)
perl

php
powershell
python
ruby

scala

sql

vb

Title none Adds a title to the code block. If
specified, the title will be displayed
in a header row at the top of the

code block.
Collapsible false If selected, the code macro's
(col |l apse) content will be collapsed upon

visiting or refreshing the
Confluence page. Clicking the exp
and sour ce link allows you to
view this content. If false, the code
macro's content is always
displayed in full.

Show line numbers false If selected, line numbers will be

(1'i nenunbers) shown to the left of the lines of
code.

First line number 1 When Show line numbers is

(firstline) selected, this value defines the

number of the first line of code.
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Theme

Configuring the Code Block macro

You can configure the Code Block macro to use a specific language and theme by default and also upload new
lanuages. You need Confluence Administrator permissions to change the default theme and language and Sy
stem Administrator permissions to upload new languages.

To set the default appearance of code blocks in your site:

Default

Specifies the colour scheme used
for displaying your code block.
Many of these themes are based
on the default colour schemes of
popular integrated development
environments (IDEs). The default
theme is Confluence (also known
as Default), which is typically
black and coloured text on a blank
background. However, you can
also choose from one of the
following other popular themes:

DJango
Emacs
FadeToGrey
Midnight
RDark
Eclipse
Confluence

1. Choose the cog icon E: then choose General Configuration under Confluence Administration.

2.
3. Select a Default Theme and Default Language.
4,

All new code blocks will use the default theme and language unless you specify otherwise. Existing code blocks

Choose Configure Code Macro.

Choose Save.

will be unchanged.

To add an additional language:

PoONPE

5.

Choose the cog icon E: then choose General Configuration under Confluence Administration.

Choose Configure Code Macro.
Choose Add a new language.

Locate your language file and enter a Name for the new language (this will appear when selecting the

language).
Choose Add.

Language files must be correctly formatted JavaScript files and adhere to the Custom Brush syntax. You can

find some examples of language files here.

To disable or remove a user-installed language:

1.
2.
3.

4,

The language will no longer appear in the Code Macro.

Choose the cog icon E: then choose General Configuration under Confluence Administration.

Choose Manage Add-ons.

Go to User-installed Add-ons and locate the add-on for your uploaded language - it will appear like this
'‘Custom Code Macro Highlighting for..."

Choose Uninstall or Disable.

Code examples

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a

Confluence page.
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Macro name: code

129

Macro body: Accepts plain text.

Storage format example

The following example shows all parameters and a body:

<ac: structured-nmacro ac: nane="code" >

<ac:
<ac:
<ac:
<ac:
<ac:
<ac:
<ac:

par anet er
par anet er
par anet er
par anet er
par anet er
par anet er

ac:
ac:
ac:
ac:
ac:
ac:

nane="title">This is ny title</ac: paraneter>
nane="t hene" >FadeToGr ey</ ac: par anet er >
name="|i nenunber s" >t rue</ ac: par anet er >
name="| anguage" >xm </ ac: par anet er >
nane="firstline">0001</ac: par anet er >
nane="col | apse" >t rue</ ac: par anet er >

pl ai n-t ext - body><! [ CDATA[ <b>Thi s is ny code</b>]]></ac: pl ai n-text-body>
</ ac: structured- macro>

Below are three examples of the Code Block macro with various optional parameters used.

Description

Markup What you will get

Code block macro with a body and

no optional parameters

<ac: structured-macro this is ny code
ac: nane="code" >

<ac: pl ai n-t ext - body>
<I[CDATA[this is ny
code] ] ></ac: plain-te

xt - body>
</ ac: structured- nacr
0>
Code block macro with a body and o
the optional language parameter <ac: structured-macro this is ny code

defined

ac: nane="code" >
<ac: par anet er

ac: nane="I| anguage" >h

tm /xm </ ac: paranet e

r>

<ac: pl ai n-t ext - body>
<I[CDATA[this is ny

code]]></ac:plain-te
xt - body>

</ ac: structured- macr
0>
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Code block macro with a body and
optional title, line numbers and lan
guage parameters defined

<ac: structured-nmacro

ac: nane="code" > This is my title
<ac: par anmet er

ac: name="title">This

is nmy

title</ac: paraneter>
<ac: par anet er

ac: name="11i nenunbers

">t rue</ ac: par anet er

>

this is ny code

<ac: par anet er
ac: nane="I| anguage" >h
tm /xm </ ac: paranete
r>

<ac: pl ai n-t ext - body>
<I[ CDATA[this is ny

code] ] ></ac: plain-te
xt - body>

</ ac: structured-nacr
0>

Wiki markup example

{code:title=This is ny

title|theme=FadeToG ey| | i nenunbers=true|l anguage=htm /xm | firstline=0001|col | apse=t
rue}

This is ny code

{code}

Column Macro

Used with the Section macro to define columns on a page. See Working with page layouts and columns and
sections.

Code examples

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a
Confluence page.

Macro name: col umm

Macro body: Accepts rich text.

Parameter name Required Default Parameter description
and accepted values
wi dt h No 100% of the page width,  The width of the column.
divided equally by the Can be specified either in
number of columns in the  pixels (for example, 400
section. px) or as a percentage of

the available page width
(for example, 50%).

Storage format example
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<ac: structured-nmacro ac: nane="col um" >
<ac: paranet er ac: nanme="w dt h">100px</ ac: par anet er >
<ac:rich-text-body>
<p>This is the content of <strong>col umm 1</strong>.</p>
</ac:rich-text-body>
</ ac: structured- macr o>

Wiki markup example

{col um: wi dt h=100px}
This is the content of *colum 1*.
{col um}

Content by Label Macro

The Content by Label macro displays links to pages, blog posts and attachments that have been tagged with
specific labels.

A working example
Below is a working example of the Content by Label macro, displaying content with the label 'LDAP'.

[2] Testing LDAP Connection using JXplorer (Atlassian Development)
Idap

[_§] Customising atlassianUserContext.xml (Confluence 2.7)
Idap

(£) Customising atlassian-user.xml (Confluence 2.8)
Idap

(€] Customising atlassian-user.xml (Confluence 2.9)
Idap

[2] LDAP Error Code 50 (JIRA Knowledge Base)
Idap

Showing first 5 of 877 results

Using the Content by Label Macro

To add the Content by Label macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of
suggested macros. Details are in Using Autocomplete.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open,
where you can edit the parameters of the macro.

Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the
parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro
browser, it will be listed below in brackets (exanpl e).

Parameter Default Description
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Label(s)
(1 abel s)

Author(s)
(aut hor)

None

None

Filter by label(s). The macro will
display only the content tagged
with the label(s) specified here.
See also the Operator parameter
below.

This parameter is required.
Specify one or more labels,
separated by a comma or a single
space.

® To exclude content which
matches a given label, put a
minus sign (-) immediately in
front of that label value. For
example: If you specify a label
value of - badpage you will get
only content which is not
labelled with 'badpage’.

® To indicate that the results mu
st match a given label value,
put a plus sign (+) immediately
in front of that label value. For
example: If you specify a label
value of +super page, +good
page you will get only content
which has at least two labels,
being 'superpage' and
'‘goodpage’'.

Filter by author. The macro will
display only the content created or
updated by the author(s) specified
here.

Specify one or more authors,
separated by a comma.
For example: j sm t h, j br own

To include content from one user,
but exclude from another user: j s
mth,!jbrown
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Include this Content Type Only
(type)

Show Labels for Each Page
(showLabel s)

Show Space Name for Each
Page
(showSpace)

List Title
(title)

Maximum Number of Pages
(max)

Display Excerpts
(excerpt)

all

true

true

None

15

false

133

Filter by content type. The macro
will display only the content of the
type specified here.

Specify one or more content types,
separated by a comma or a space.

To exclude content of a given
content type, put a minus sign (-)
immediately in front of that content
type. For example: If you specify a
content type of - bl ogpost you
will get pages and all other content
except for blog posts.

Available values:

® page — Pages.

® bl ogpost or news — Blog
posts, also known as news
items.

® attachment — Attachments

Show or hide labels in the results.

Show or hide spaces in the
results.

Add a title or heading to the list.

Limit the maximum number of
results to be displayed. Note that
the results are sorted first, and
then the maximum parameter is
applied.

Include excerpts from each page
listed. Note that you must have
defined excerpts on each of those
pages, by adding the excerpt
macro to the page. Only the first
few lines of the excerpt for each
page are displayed.
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Restrict to these Spaces
(spaces)

@all

134

Filter by space. The macro will
display only the content which
belongs to the space(s) specified
here.

Specify one or more space keys,
separated by a comma or a space.

® To exclude contentin a
specific space, put a minus
sign (-) immediately in front of
that space key. For example: If
you specify a space key of - BA
DSPACE you will get only
content which is not in the
BADSPACE.

® To indicate that the results mu
st come from a specific space,
put a plus sign (+) immediately
in front of that space key. For
example: If you specify a
space key of +GOCDSPACE you
will get only content in
GOODSPACE. (Note that this
is not particularly useful,
because each content item
belongs to one space only. If
you put a plus sign next to one
space key and list other space
keys too, the other space keys
will be ignored.)

Special values:

® @el f — The current space.

® @ersonal — All personal sp
aces.

* @l obal — All site spaces.

® @avorite— The spaces
you have marked as favourite.

® @avourite —The same as
@ avorit e above.

® @l | — All spaces in your
Confluence site.

¢ * _The same as @l | above

When specifying a personal

space, remember to use the tilde
(=) sign in front of the username,
such as ~j bl oggs or ~j bl oggs@
exanpl e. com
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Operator
(operator)

Sort By
(sort)

Reverse Sort
(reverse)

Code examples

OR

modified

false
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The operator to apply when
matching content against the
labels specified in the Label(s) par
ameter:

® OR - Display content with any
of the non-prefixed labels.

® AND - Display content with all
of the specified non-prefixed
labels.

@ Note that this parameter
only modifies the behaviour of
the Label(s) parameter and
only affects label values
without a plus (+) or minus (-)
sign prefix.

Specify how the results should be
sorted.

Values:

® title — Sort alphabetically by
title.

® creation — Sort by the date
on which the content was
added.

* modified — Sort by the date
on which the content was last
updated.

Note: If this parameter is not
specified, the sort order defaults to
descending, based on the last
modification date (latest first). To
change the sort order from
ascending to descending, use the
Reverse Sort parameter.

Select Reverse Sort to change
the sort from descending to
ascending. Use this parameter in
conjunction with the Sort By para
meter. Reverse Sort is ignored if
Sort By is not specified.

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a

Confluence page.

Macro name: cont ent byl abel

Macro body: None.

Storage format example
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<ac: structured-nmacro ac: nane="cont ent byl abel ">
<ac: par aneter ac:nane="spaces"/>
<ac: par anet er ac: nanme="aut hor " >adm n, smaddox</ ac: par anet er >
<ac: paraneter ac:nane="title">M | abelled pages</ac: paraneter>
<ac: par anet er ac: nane="showLabel s">f al se</ ac: par anet er >
<ac: paraneter ac:nane="reverse">true</ac: paraneter>
<ac: paraneter ac:name="sort">creation</ac: paraneter>
<ac: par anet er ac:name="nmax">10</ac: par anet er >
<ac: par aneter ac: nane="excer pt">true</ac: paraneter>
<ac: paramnet er ac:nane="|abel s">chocol at e, cake</ ac: par anet er >
<ac: paranet er ac: name="showSpace" >f al se</ ac: par anet er >
<ac: paraneter ac:nanme="type">page</ac: paraneter >
<ac: par anet er ac: nane="oper at or " >AND</ ac: par anet er >

</ ac: struct ured- nacr o>

Wikimarkup example

{cont ent byl abel : spaces=@er sonal , @el f| aut hor =adni n, sraddox| titl e=My | abel | ed
pages| showLabel s=f al se| reverse=true| sort =creati on| max=10| excer pt =t rue| | abel s=chocol
at e, cake| showSpace=f al se| t ype=page| oper at or =AND}

Content by User Macro

The Content by User macro generates a tabulated list of the content items, throughout the Confluence
installation, that have been created by a specified Confluence user. The list includes all current pages,
comments and spaces created by the user. Each item in the table is linked to its corresponding page, page
comment or space dashboard.

Note that items for page comments contain a link to the page, followed by a second link to the comment itself,
with these separated by a greater-than sign (>).

Using the Content by User macro

To add the Content by User macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of
suggested macros. Details are in Using Autocomplete.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open,
where you can edit the parameters of the macro.

Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the
parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro
browser, it will be listed below in brackets (exanpl e).

Parameter Required Default Description

Username yes none The Confluence
username for a person

(name) who has created content.

Parameter is unnamed in
wikimarkup.

Code examples
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The following examples are provided for advanced users who want to inspect or edit the underlying markup for a
Confluence page.

Macro name: cont ent - by— user
Macro body: None.
Storage format example
<ac: structured-macro ac: nanme="content - by- user ">
<ac: paraneter ac:nane="">
<ri:user ri:userkey="12345678912345678912345678912345"/ >

</ ac: par anet er >
</ ac: structured-nmacro>

Wikimarkup example

{content-by-user:jsmth}

Content Report Table Macro

The Content Report Table macro displays a set of pages and blog posts in tabular format, based on the labels
specified in the macro parameters.

A working example

Below is a working example of the Content Report Table macro, displaying content with the label 'LDAP'.

Title Creator Modified
Connecting to an Internal Sarah Maddox [Atlassian] Nov 28, 2013
Directory with LDAP

Authentication

Requesting Support for External Matt Ryall [Atlassian] Sep 25, 2013
User Management

User Management Limitations Sarah Maddox [Atlassian] Sep 25, 2013
and Recommendations

Diagrams of Possible Sarah Maddox [Atlassian] Sep 25, 2013
Configurations for User

Management

Synchronising Data from External ~ Sarah Maddox [Atlassian] Sep 25, 2013
Directories

Configuring an SSL Connection Sarah Maddox [Atlassian] Sep 25, 2013
to Active Directory

Configuring the LDAP Connection  Sarah Maddox [Atlassian] Sep 25, 2013
Pool

Managing Multiple Directories Sarah Maddox [Atlassian] Sep 13, 2013
Connecting to LDAP or JIRA or Nick Faiz Apr 29, 2013
Other Services via SSL

Connecting to an LDAP Directory Sarah Maddox [Atlassian] Jul 30, 2012
Configuring User Directories Sarah Maddox [Atlassian] Jul 03, 2012
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Managing Nested Groups Sarah Maddox [Atlassian] Apr 26, 2012

Using the Content Report Table Macro

To add the Content Report Table macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of
suggested macros. Details are in Using Autocomplete.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open,
where you can edit the parameters of the macro.

Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the
parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro
browser, it will be listed below in brackets (exanpl e).

Parameter Required Default Description
Label(s) No None This parameter is
(1 abel s) required. Specify one or

more labels, separated
by a comma. The macro
will display the content
tagged with any of the
label(s) specified here.

For example, if you
specify labels 'A" and 'B',
the macro will display all
pages that have the label
'A', and all pages that
have the label 'B’, and all
pages that have both

those labels.
Space(s) Yes (All spaces) Specify one or more
(spaces) space keys, separated

by a comma or a space.
The macro will display
only the content which
belongs to the space(s)
specified here.

When specifying a
personal space,
remember to use the tilde
(=) sign in front of the
username, such as ~j bl
0oggs or ~j bl oggs@xa
mpl e. com
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Maximum Number of No 20 Define the maximum
Pages number of pages that the
(maxResul t's) macro will show in a

single set of results. If
there are more pages to
be shown, the macro will
display a link labelled
'Find more results'.
People viewing the page
can choose the link to go
to a search view, which
shows all pages tagged
with the specified
label(s).

Which pages will
appear? Before
displaying the results,
Confluence will sort them
by the date the page was
last modified. The
most-recently
created/updated pages
will appear first.

Code examples

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a
Confluence page.

Macro name: cont ent -report-tabl e

Macro body: None.

Storage format example

<ac:structured-nmacro ac: name="content-report-table">
<ac: paramet er ac: nane="spaces" >
<ri:space ri:space-key="DOC'/ >
</ ac: par anet er >
<ac: paranet er ac: nane="1| abel s" >LDAP</ ac: par anet er >
<ac: paraneter ac:nanme="anal yti cs-key">neeti ng-notes</ac: paranet er >
<ac: paramet er ac: nane="maxResul t s">5</ac: par anet er >
</ ac: structured- nacr o>

Wiki markup

Wiki markup is not available for this macro. You cannot add this macro via wiki markup.

Contributors Macro

The Contributors macro displays a list of Confluence users who have made a contribution of some type to a
page. It can also be used to list watchers of the page.

The scope of this macro can be extended to include the immediate children or descendants of the specified
page. The list of contributors can be based on people who have:

® authored or edited the page(s)
® contributed comments or added labels to the page(s), or
® are simply watching the page(s).
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Screenshot: Example list of Contributors

e Rach Admin
= Josh User

« Sophie Staunton

This is the Contributors macro

In this example, the Display Format parameter has been set to list.

Using the Contributors Macro

To add the Contributors macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of

suggested macros. Details are in Using Autocomplete.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open,

where you can edit the parameters of the macro.

Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the
parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro

browser, it will be listed below in brackets (exanpl e).

Parameter

Contribution Type
(i nclude)

Description

Filters by either the type of
contribution made to a page (and
optionally its descendant pages),
or the watches on the page.
Contribution types are:

® aut hor s - includes people
who created or have edited the
page(s)

® comment s - includes people
who have added comments to
the page(s)

® | abel s -includes people who
have added labels to the
page(s)

® wat ches - includes people
who are watching the page(s).

You can specify one or more
contribution types, separated
by commas.
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Sort By
(order)

Reverse Sort
(reverse)

Maximum Number of
Contributors

(linit)

Display Format
(rmode)

Show Anonymous
Contributions?
(showAnonynous)

Show Count?
(showCount)

Show Last Contribution Time?

(showLast Ti ne)

Page Name
(page)

Label(s)
(1 abel s)

count

false

no limit

inline

false

false

false

current

none
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Specifies the criteria used to sort
contributors. Sort criteria are:

® count - sorts people based on
the total number of
contributions to the page(s)

® name - sorts people into
alphabetical order

® update - sorts people based
on the date of their last
contribution to the page(s).

Reverses the sort order of
contributors in the list. Must be
used in conjunction with the Sort
By parameter.

Limits the number of contributors
in the list. If a number is not
specified, all contributors are
included.

Sets how the list of contributor's
names is formatted:

® inline — a comma-separated
list
® |ist — a bullet list.

Sets whether to include those who
contributed anonymously to a

page.

Sets whether to show the number
of times each person made a
contribution of the specified Contri
bution Type.

Sets whether to show the last time
each person made a contribution
of the specified Contribution
Type.

Specifies the page to use when
generating the list of contributors.
If Page Name and Space(s) are
left blank, the current page is
assumed.

Filters the list of contributors to
those who created the specified
labels from a page. You can
specify one or more labels,
separated by commas.
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Space(s)
(spaces)

Content Type
(cont ent Type)

Blog Post Date
(publ i shDat €e)

Include Page Hierarchy
(scope)

Show Selected Pages
(showPages)

Custom "None Found" Message
(noneFoundMessage)

Code examples

current

both pages and blog posts

none

specified page only

false

default message
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Specifies the space key of the
Confluence space that contains
the page set in Page Name or
alternatively, specifies the spaces
to search. Space keys are
case-sensitive.

This parameter also takes special
values, including:

* @l obal — All site spaces.

® @ersonal — All personal sp
aces.
* @l | — All spaces in your

Confluence site.

You can specify one or more
space keys or special values,
separated by commas.

If no Page Name and Label(s)
are specified, all pages from
the specified set of spaces are
included.

Restricts the content type to use
when generating the list of
contributors:

® pages — pages
®* blogposts — blog posts.

Specifies the publish date for a
blog post. The date format
required is: YYYY/MM/DD.

Specifies additional pages to
include when generating the list of
contributors:

® children — just the child
pages of the specified page

® descendants — all
descendants of the specified

page.

Sets whether to show a list of the
pages used to generate the list of
contributors.

Specifies the message to be used
to override the default message
that is displayed when no
contributors are found.

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a

Confluence page.
Macro name: contri butors

Macro body: None.

Storage format example
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This example specifies a content type of blog posts:

<ac:macro ac: nane="contri butors">

<ac:
<ac:
<ac:
<ac:
<ac:
<ac:
f ound</ ac: par anet er >
<ac:
<ac:
<ac:
<ac:
<ac:
<ac:
<ac:
<ac:

par amet er
par amet er
par anet er
par amet er
par amet er
par anmet er

par amet er
par amet er
par anmet er
par anmet er
par amet er
par amet er
par anmet er
par anmet er

</ ac: macr o>

Wikimarkup example

ac:
ac:
ac:
ac:
ac:
ac:

ac:
ac:
ac:
ac:
ac:
ac:
ac:
ac:

nane="1imt">10</ ac: par anet er >
nane="spaces" >ds, @er sonal </ ac: par anet er >
name="reverse" >t rue</ ac: par anet er >

nanme="| abel s">chocol at e, cake</ ac: par anet er >
nanme="showPages" >t r ue</ ac: par anet er >
nane="noneFoundMessage" >Ch dear, no contributors

nanme="showCount " >t r ue</ ac: par anet er >

name="cont ent Type" >bl ogpost s</ ac: par anet er >

nane="i ncl ude" >aut hor s, conment s, | abel s, wat ches</ ac: par anet er >
nane="node" >l i st </ ac: par anet er >
nanme="showAnonynous" >t r ue</ ac: par anet er >

nane="or der" >updat e</ ac: par anet er >
nane="showLast Ti ne" >t r ue</ ac: par anet er >

nane="publ i shDat e">2012/ 06/ 30</ ac: par anet er >

This example specifies a content type of blog posts:

{contributors:linit=10| spaces=ds, @ersonal | reverse=true|l abel s=chocol at e, cake| showP
ages=t r ue| noneFoundMessage=0Ch dear, no contributors

f ound| showCount =t r ue| cont ent Type=Dbl ogpost s| i ncl ude=aut hor s, conment s, | abel s, wat ches
node=l i st | showAnonynous=t r ue| or der =updat e| showLast Ti ne=t r ue| publ i shDat e=2012/ 06/ 30}

This example specifies a content type of pages:

{contributors:lint=10| spaces=ds, @ersonal | reverse=true| scope=descendant s| | abel s=ch
ocol at e, cake| showPages=t r ue| noneFoundMessage=0h dear, no contributors

f ound| showCount =t r ue| cont ent Type=pages| i ncl ude=aut hor s, corment s, | abel s, wat ches| node
=l i st | showAnonynous=t r ue| or der =updat e| page=ds: Advanced Topi cs| showLast Ti ne=t r ue}

Contributors Summary Macro

The Contributors Summary macro displays a table of contribution-based statistics for a set of pages. These
statistics can be grouped according to individual pages or individual contributors.

The default scope for this macro is an individual page, but this can be extended to include the immediate
children or descendants of a specified page. The statistics cover the following types of contributions:

edits to the page(s)

comments added to the page(s)
labels added to the page(s)
people watching the page(s)

A simple example of the Contributors Summary macro is shown in the screenshot below. It lists statistics for the
number of times each contributor has edited, added comments and added labels to this page.

Screenshot: Example Contributors Summary table of statistics

In this example, all default parameter settings are used. For more information about this macro's parameters,
refer to the Parameters section below.

Using the Contributors Summary Macro
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To add the Contributors Summary macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of
suggested macros. Details are in Using Autocomplete.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open,
where you can edit the parameters of the macro.

Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the
parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro
browser, it will be listed below in brackets (exanpl e).

Parameter Default Description
Group By contributors Specifies the basis for grouping
(grouphby) contribution-based statistics:

® contributors — group by the
people who have contributed

® pages — group by the pages
used to find contributors.

Created in 2014 by Atlassian. Licensed under a Creative Commons Attribution 2.5 Australia License.


http://creativecommons.org/licenses/by/2.5/au/

Confluence 5.5 Documentation

Columns to Display
(col ums)

edits,comments,labels

145

Sets the columns that should
appear in the table. The statistics
or type of information presented
depends on the basis for grouping
set with the Group By parameter.
Statistics may be calculated for:

¢ edi t s — the number of times
each contributor has edited the
page(s) or the number of edits
made to each page.

® edited— alist of the pages
edited by each contributor or a
list of contributors who have
edited each page.

® conment s — the number of
times each contributor has
added comments to the
page(s) or the number of
comments on each page.

® conment ed — a list of pages
to which each contributor has
added comments or a list of
contributors who have
commented on each page.

® | abel s — the number of
times each contributor has
added labels to the page(s) or
the number of labels on each
page.

® | abel ed — a list of pages to
which each contributor has
added labels or a list of
contributors who have added a
label to each page.

® | abel I'i st — alist of labels
either added by each
contributor or on each page.

®* wat ches — the number of
pages being watched by each
contributor/person or the
number of contributors/people
watching each page.

®* wat chi ng — a list of pages
being watched by each
contributor/person or a list of
contributors/people watching
each page.

® | ast updat e — the last time
each contributor made an
update or when each page
was last updated. Valid
updates can include edit,
comment or label modifications
to a page.

One or more columns can be
used.
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Sort By
(order)

Reverse Sort
(reverse)

Maximum Number of ltems
(limt)

Show Anonymous
Contributions?
(showAnonynous)

Show Zero Counts?
(showZer oCount s)

Page Name
(page)

Label(s)
(1 abel s)

edits

false

no limit

false

false

current

none
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Sets the criterion used for sorting
items in the table. The items
sorted depend on the basis for
grouping set with the Group By pa
rameter. Sort criteria are:

® edits — sorts items in the
table based on the total
number of edits made, either
by a contributor or to a page.

® name — sorts items in the
table in alphabetical order,
either by contributor or page
name.

® editTi me — sorts items in
the table based on when the
contributor last edited a page
(or a specified set of pages) or
when the page was lasted
edited.

® updat e — sorts items in the
table based on when the
contributor last made any
contribution to a page (or a
specified set of pages) or when
the page last had any
contribution made to it.

Reverses the sort order of items in
the table, as specified using the S
ort By parameter. (Used only in
conjunction with the Sort By para
meter.)

Limits the number of contributors
or pages in the table to the value
specified. If no number is
specified, all items are included.

Includes individuals who have
made anonymous contributions to
a page.

Sets whether contributors or
pages are included for which a
calculated statistic is zero.

Sets the page for which to
calculate the contribution-based
statistics. If no values for Page
Name and Space(s) are specified,
the current page is assumed.

Restricts the contribution-based
statistics to the specified labels
only. You can specify one or more
labels, separated by commas.
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Space(s)
(spaces)

Content Type
(cont ent Type)

Blog Post Date
(publ i shDat e)

Include Page Hierarchy
(scope)

Code examples

current

both pages and blog posts

none

specified page only

147

Specifies the space key of the
Confluence space which contains
the specified page name or
alternatively, specifies a scope of
spaces to search. Space keys are
case-sensitive.

This parameter also takes special
values, including:

* @l obal — All site spaces.

® @ersonal — All personal sp
aces.

® @l | — All spaces in your
Confluence site.

You can specify one or more
space keys or special values,
separated by commas.

If no Page Name and Label(s) are
specified, all pages from the
specified set of spaces are
included.

Restricts page types to either
pages (pages) or blog posts (blog
posts). If no value is specified in
the Macro Browser, both pages
and blog posts are included.

Available values pages and bl og
post s.

Specifies the publish date for a
blog post. The date format
required is: YYYY/MM/DD.

Includes either the immediate chil
dren or all descendants of the
specified page. If no value is
indicated in the Macro Browser,
only the specified page is
included.

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a

Confluence page.

Macro name: cont ri but or s- surmary

Macro body: None.

Storage format example

This example specifies a content type of blog posts:
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<ac: structured-nmacro ac: nanme="contri butors-sumary" >
<ac: parameter ac:nane="limt">10</ac: paraneter >
<ac: paraneter ac:name="spaces">
<ri:space ri:space-key="ds"/>
<ri:space ri:space-key="@ersonal "/>
</ ac: par anet er >
<ac: paranet er ac: nane="reverse">true</ac: par anet er >
<ac: par anet er ac: nanme="showAnonynous" >t rue</ ac: par anet er >
<ac: par anet er ac: nane="order " >updat e</ ac: par anet er >
<ac: paramnet er ac:nane="|abel s">chocol at e, cake</ ac: par anet er >
<ac: paraneter ac:nanme="col ums">edits, corments, | abel s, | ast updat e</ ac: par anet er >
<ac: par anet er ac: nane="gr oupby" >pages</ ac: par anet er >
<ac: paranet er ac: nane="cont ent Type" >bl ogpost s</ ac: par anet er >
<ac: paramet er ac: nane="showZer oCount s" >t rue</ ac: par anet er >
<ac: paranet er ac: name="publ i shDat e">2012/ 06/ 07</ ac: par anet er >
</ ac: structured- nacr o>

This example specifies a content type of pages:

<ac: structured-nmacro ac: nane="contri butors-sumary" >

<ac: parameter ac:nane="limt">10</ac: paraneter >
<ac: paraneter ac:name="spaces">

<ri:space ri:space-key="ds"/>

<ri:space ri:space-key="@ersonal "/>
</ ac: par anet er >
<ac: paranet er ac: nanme="reverse">true</ ac: par anet er >
<ac: par anet er ac: nanme="showAnonynous" >t rue</ ac: par anet er >
<ac: par anet er ac: nanme="scope">descendant s</ ac: par anet er >
<ac: par anet er ac: nanme="order">updat e</ ac: par anet er >
<ac: par aneter ac:nanme="page">

<ac:|ink>

<ri:page ri:content-title="Advanced Topi cs" ri:space-key="ds"/>

</ac:link>
</ ac: par anet er >
<ac: par anet er ac: nane="1| abel s">chocol at e, cake</ ac: par anet er >
<ac: paraneter ac:nane="col ums">edits, comments, | abel s, | ast updat e</ ac: par anet er >
<ac: par anet er ac: name="groupby" >pages</ ac: par anet er >
<ac: par anet er ac: nane="cont ent Type" >pages</ ac: par anet er >
<ac: par anet er ac: nanme="showZer oCount s" >t rue</ ac: par anet er >

</ ac: structured- macr o>

Wiki markup example
This example specifies a content type of blog posts:
{contributors-sumrary:|imt=10| spaces=ds, @er sonal | rever se=t rue| showAnonynous=t r ue

or der =updat e| | abel s=chocol at e, cake| col unmms=edi t s, conment s, | abel s, | ast updat e| gr oupby
=pages| cont ent Type=bl ogpost s| showZer oCount s=t r ue| publ i shDat e=2012/ 06/ 07}

This example specifies a content type of pages:

{contributors-sumrary:|imt=10| spaces=ds, @er sonal | rever se=t r ue| showAnonynous=t r ue
scope=descendant s| or der =updat e| page=ds: Advanced

Topi cs| | abel s=chocol at e, cake| col ums=edi t s, comment s, | abel s, | ast updat e| gr oupby=pages
| cont ent Type=pages| showZer oCount s=t r ue}
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Create from Template Macro

The Create from Template macro displays a button on a page, linked to a specific template. When someone
clicks the button, the macro opens the editor, ready to add a new page, and adds content to the page based on

the given template.

When adding the macro to the page, you can specify a blueprint or a user-created template in the macro. You
will also specify the name of the button displayed, and the space in which the new page will appear.

Example

Screenshot: A page with three buttons, all displayed by the 'Create from Template' macro

Pages / Doc Theme Test Space Home 2 Edit * Share 5 Tools
How to write documentation

Added by Sarah Maddoy, last edited by Sarah Maddox on Mar 14, 2013 (view change)

Done all your analysis and chatted to the SMEs? Now's the time to create your page. Choose a template:

Shared files Meeting notes Product reguirements

Using the Create from Template Macro

To add the Create from Template macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of
suggested macros. Details are in Using Autocomplete.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open,
where you can edit the parameters of the macro.

Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the
parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro

browser, it will be listed below in brackets (exanpl e).

Parameter Required Default Description

Button Text ‘Create from Template' The description that
people will see when
viewing this macro on the

page.

Template Name None Select the template or
blueprint to base the new

page on. Only global and
user-created templates
for the current space
appear (unless you have
specified a different
space in the 'Space Key'
field).
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Template Title Blank Specify a default title for
pages created using this
macro (optional). You
can include
@currentDate,
@spaceName and
@spaceKey variables in

the title.
Space Key The space where the Supply the unique space
current page is located identifier (space key), to

determine where the new
page will be created
when someone uses this
macro to create a page.

Code examples

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a
Confluence page.

Macro name: create-fromtenpl ate
Macro body: None.

Parameters for storage format differ from those available in the macro browser as follows.

Parameter name Required Default Parameter description
and accepted values
tenpl ateld Required for (None) The ID of a user-created
user-created templates template. This is the

unique identifier that
Confluence assigns
when you create a
template. For example, 2
99630593. To find the
ID of a template, edit the
template and look at the
URL in your browser.
The template ID is given
in the URL parameter
named entityl d.

bl uepri nt Modul eCom  Required for blueprints (None)
pl et eKey

t enpl at eNane Yes (None) The ID of a user-created
template (for example, 2
99630593) or the
qualified name of the
add-on that defines the
blueprint (for example, ¢
om at | assi an. conf |
uence. pl ugi ns. conf
| uence-shared-file
s-plugin:file-Ilist
- bl uepri nt).

but t onLabel Yes 'Create from Template' The description that
people will seeing when
viewing this macro on the

page.
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spaceKey Yes The space where the The unique space
current page is located identifier, to determine
where the new page will
be created when
someone uses this
macro to create a page.

Title No (None) The title for pages
created using this macro.
You can include @urre
nt Dat e, @paceNane a
nd @paceKey variables
in the title. This title will
override any title
specified in a blueprint
template.

Storage format example

This example specifies a user-created template:

<ac:structured-macro ac: nanme="create-fromtenpl ate">
<ac: paraneter ac:nanme="tenpl at el d'>299630593</ ac: par anet er >
<ac: paramet er ac:nane="buttonLabel ">Blitz test</ac:paraneter>
<ac: paraneter ac:nane="spaceKey">
<ri:space ri:space-key="DOCTHEME"/ >
</ ac: par anet er >
<ac: paraneter ac:nanme="tenpl at eNane" >299630593</ ac: par anet er >
</ ac: structured- nacr o>

This example uses a blueprint:

<ac:structured-macro ac: nanme="create-fromtenpl ate">

<ac: par anet er
ac: nane="bl uepri nt Modul eConpl et eKey" >com at | assi an. conf | uence. pl ugi ns. conf | uence- sh
ared-files-plugin:file-list-blueprint</ac:paraneter>

<ac: paraneter ac:name="buttonLabel ">Shared fil es</ac: paranet er >

<ac: paraneter ac: nane="spaceKey">

<ri:space ri:space- key="DOCTHEME"/ >

</ ac: par anet er >

<ac: par anet er
ac: nanme="t enpl at eNane" >com at | assi an. conf | uence. pl ugi ns. confl uence-shared-fil es-plu
gin:file-list-blueprint</ac:paraneter>
</ ac: structured- nacr o>

Wikimarkup

Wiki markup is not available for this macro. You cannot add this macro via wiki markup.
Create Space Button Macro

The Create Space Button macro displays a create space icon that links to the 'Create Space' page. To see this
icon, viewers need the 'Create Space' permission which is assigned by a site administrator.

Using the Create Space Button macro

To add the Create Space Button macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.
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Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of
suggested macros. Details are in Using Autocomplete.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open,
where you can edit the parameters of the macro.

Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the
parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro
browser, it will be listed below in brackets (exanpl e).

Parameter Default Description
Icon Size large Specify whether to use large or
si ze small icon. Available values:

® large

®* small

Code examples

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a
Confluence page.

Macro name: cr eat e- space- button

Macro body: None.

The following additional paramteters are available in storage format and wikimarkup.

Parameter name Required Default Parameter description
and accepted values

wi dth No Natural size of icon The width of the icon to
be displayed, specified in
pixels. Confluence will
stretch or shrink the
width of the icon to the
number of pixels
specified.

(1:1 pixel ratio)

Note: This parameter is
not available via the
macro browser.

hei ght No Natural size of icon The height of the icon to
be displayed, specified in
pixels. Confluence will
stretch or shrink the
height of the icon to the
number of pixels
specified.

(1:1 pixel ratio)

Note: This parameter is
not available via the
macro browser.

Storage format example
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<ac: structured-macro ac: nanme="cr eat e- space- button">
<ac: paramet er ac: nane="si ze">smal | </ ac: par anet er >
<ac: paranet er ac: nanme="hei ght " >50px</ ac: par anet er >
<ac: paranet er ac: nanme="w dt h" >50px</ ac: par anet er >
</ ac: structured- nacr o>

Wikimarkup example

{create-space-button:size=snall}
{creat e-space- but t on: hei ght =50px| wi dt h=50px}

Excerpt Include Macro

The Excerpt Include macro is used to display 'excerpted’ (that is, a segment of) content from one page in
another.

Before you can use this macro, the excerpt must have been defined using the Excerpt macro. Note that you can
have more than one Excerpt Include macro on a page (although you can have only one Excerpt macro on a

page).
Example

The paragraph below shows an example of an Excerpt Include macro, containing content from an excerpt which
we have defined on the Excerpt Macro page. On the Excerpt Include macro below, we have set the options to
show both the title of the page and the panel surrounding the content.

Excerpt Macro

Define a part of a page as the page's 'excerpt' which can then be displayed in another page.

Using the Excerpt Include Macro

To add the Excerpt Include macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of
suggested macros. Details are in Using Autocomplete.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open,
where you can edit the parameters of the macro.

Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the
parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro
browser, it will be listed below in brackets (exanpl e).

Parameter Default Description
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Page Containing the Excerpt none Type the name of the page that

(defaul t - paraneter) contains the excerpt to be
displayed. You can use an excerpt
from a page in the same space or
another space in the same wiki.

When you type the name of the
page into the Excerpt Include
macro dialog, Confluence will offer
a list of matching pages, including
those from other spaces.

Alternatively, you can type the
space key followed by a colon (%)
and the page name, like this:

SPACEKEY: Page
nane

This parameter is unnamed in

wikimarkup.
Remove Surrounding Panel false Determines whether Confluence
(nopanel) will display a panel around the

excerpted content. The panel
includes the title of the page
containing the excerpt, and the
border of the panel. By default, the
panel and title are shown.

Code examples

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a
Confluence page.

Macro name: excer pt -i ncl ude

Macro body: None.

Storage format example

<ac: nmacro ac: nane="excerpt-include">

<ac: paramet er ac: nane="nopanel ">true</ ac: par anet er >

<ac: def aul t - par anet er >My page nane</ ac: def aul t - par anet er >
</ ac: macr o>

Wikimarkup example

{excerpt-include: My page nane| nopanel =t rue}

Excerpt Macro

The Excerpt macro is used to mark a part of a page's content for re-use. Defining an excerpt enables other
macros, such as the Excerpt Include and Blog Posts macros, to display the marked content elsewhere.

You can only define one excerpt per page. In other words, you can only add the Excerpt macro once to a page.
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Using the Excerpt Macro

To add the Excerpt macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of
suggested macros. Details are in Using Autocomplete.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open,
where you can edit the parameters of the macro.

To add reusable content to the macro:

1. Add your content inside the Excerpt macro placeholder.

2. Choose the macro placeholder to see the options panel, and select the option to Display on new line or
to Display inline. The default is to display the content of the macro on a new line. If you choose the inline
option, the content of the macro will form part of the same paragraph as the text preceding and following
it. Note that this option affects only the page that contains the Excerpt macro. It does not affect any pages
where the content is reused.

Screenshot: The Excerpt macro placeholder and options panel

Text before the Excerpt macro
Excerpt

This is my reusable text

Edit Remove

New line  Inline

Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the
parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro
browser, it will be listed below in brackets (exanpl e).

Parameter Default Description

Hide Excerpted Content false Controls whether the page content

(hi dden) contained in the Excerpt macro
placeholder is displayed on the
page.

Note that this option affects only
the page that contains the Excerpt
macro. It does not affect any
pages where the content is
reused.

Code examples

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a
Confluence page.

Macro name: excer pt

Macro body: Accepts rich text.
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The following additional parameter is available in storage format and wikimarkup. It performs the same function
as the options panel in the editor.

Parameter name Required Default Parameter description
and accepted values

atl assi an-macro-ou No BLOCK Determines whether the

tput-type content of the Excerpt

macro body is displayed
on a new line or inline.

Available values:

® BLOCK - Displays the
content of the macro
on a new line.

®* | NLI NE — Displays
the the content of the
macro as part of the
same paragraph as
the text preceding
and following it.

Note that this option
affects only the page that
contains the Excerpt
macro. It does not affect
any pages where the
content is reused.

Storage format example

<ac: structured-macro ac: nane="excerpt">

<ac: paramet er ac: nane="hi dden">true</ ac: par anet er >

<ac: paraneter ac:name="atl assi an-nmacr o-out put -t ype" >BLOCK</ ac: par anet er >

<ac:rich-text-body>

<p>This is the <strong>text</strong> 1 want to reuse in other pages. This text

is inside an Excerpt nmacro.</p>

</ac:rich-text-body>
</ ac: structured- nmacr o>

Wikimarkup example

{excerpt: hi dden=t rue| at| assi an- macr o- out put - t ype=BLOCK}
This is the *text* | want to reuse in other pages. This text is inside an Excerpt

Macr o.
{excerpt}

Expand Macro
The Expand macro displays an expandable/collapsible section of text on your page.

Here is an example:
~ Expand me...
This text is hidden until you expand the section.

Using the Expand Macro
To insert the Expand macro into a page using the macro browser:

1. In the Confluence editor, choose Insert > Other Macros.
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2. Find and select the required macro.

Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of
suggested macros. Details are in Using Autocomplete.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open,
where you can edit the parameters of the macro.

Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the
parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro
browser, it will be listed below in brackets (exanpl e).

Parameter Default Description

Title Click here to expand... Defines the text that appears next
to the expand/collapse icon.

Code examples

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a
Confluence page.

Macro name: expand

Macro body: Accepts rich text.

Storage format example

<ac: structured-macro ac: name="expand" >
<ac: paraneter ac:name="title">Expand ne...</ac: paraneter>
<ac:rich-text-body>
<p>This text is hidden until you expand the section.</p>
</ac:rich-text-body>
</ ac: structured- nacr o>

Wikimarkup example

{expand: This is ny nessage}
This text is _hidden_ until you expand it.
{expand}

Notes

® Textis expanded in PDF and HTML exports. When you export the page to PDF or HTML, the text
between the macro tags is expanded so that readers can see it in the PDF and HTML versions of the

page.
® Nesting your Expand macros. You can put one Expand macro inside another, and Confluence will
correctly show and hide the contents of all Expand macros, including the nested ones.

Favourite Pages Macro
Use the Favourite Pages macro to display a list of your favourite pages.
The output of the Favourite Pages macro appears as in the following screenshot.

Screenshot: The Favourite Pages Macro in Confluence
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This is the Favourite Pages macro

Favourite Pages

Displaying pages recently added to your favourites list.
Why I loved Angry Nerds (Angry Merds)

Which nerd are you? (Angry Merds)

»* % %

[;] Cur new logo (Angry Merds)

Using the Favourite Pages Macro

To insert the favourite pages macro into a page using the Macro Browser:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of
suggested macros. Details are in Using Autocomplete.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open,
where you can edit the parameters of the macro.

There are no parameters for this macro.
Code examples

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a
Confluence page.

Macro name: f avpages
Macro body: None.

Parameters: None.

Storage format example

<ac:structured-macro ac: nane="f avpages"/ >

Wiki markup example

{favpages}

Gadget Macro

Gadgets are small applications that can offer dynamic content. They are typically served from a web application
server and can be re-used in many other web applications. In Confluence, use the Gadget macro to add gadgets
to pages or blog posts.

Confluence comes bundled with a few of its own gadgets that you can add to your pages or blog posts. The
Confluence gadgets are listed in Confluence Gadgets. However, you can access additional gadgets in this list if
your Confluence Administrator has:

* |nstalled additional gadgets in Confluence (typically as a Confluence plugin) or
® Registered gadgets served from an external web application or website (such as those from a JIRA
installation or iGoogle).
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Unlike other macros, the name of each gadget macro is unique and follows the convention "<gadget-name>
macro", where <gadget-name> is the name supplied by the gadget itself.

Inserting gadgets into a Confluence page or blog post

To add a gadget to a page:

1.
2.
3.

5.
6.
7.

Edit your page or blog post.
Choose Insert > Other Macros.
Click External Content to see a list of gadgets configured for use in your Confluence installation.

(Some Confluence macros like the JIRA Issues, RSS Feed, and Widget Connector macros also appear in

this category because they can also access external content.)

. Click the desired gadget to access its parameters and properties.

Almost all gadgets allow you to set basic parameters (listed below), which appear on the right of the
macro dialog. Each gadget may also have its own set of parameters, which appear on the left of the
macro dialog.

Set the parameters to your requirements.

Click Refresh to preview your changes.

Click Insert to add the gadget to the page.

Editing gadgets on a Confluence page or blog post

To edit an existing gadget on a page or blog post:

1. Edit your page or blog post.

2. Click the Gadget macro placeholder and choose Edit (or double-click the placeholder).
3.
4
5

Set the gadget's parameters to your requirements.

. Click Refresh to preview your changes.
. Save the gadget.

Standard gadget parameters

Almost all gadgets allow you to set basic parameters (listed below), which appear on the right of the macro
dialog. Each gadget may also have its own set of parameters, which appear on the left of the macro dialog.

Parameter Default Description

Width 450 pixels Set the width of the gadget, using

one of the following conventions:

® Width in pixels, using px or
plain numbers. For example, 5
00px or 500

® A percentage of the page
width, using % For example,
50%

® Automatic resizing of the
gadget to fit 100% of the page
width: aut o

Border true Places a thin grey border around

the gadget.

Contents of a Gadget macro

In the addition to the standard parameters, the gadget macro contains ‘parameter-like’ content, which represents
specific property settings that are particular to each gadget. Hence they are not documented here. Typically, this

content would only be changed by customising the gadget's default properties using the macro browser.

Code examples

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a
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Confluence page.
Macro name: gadget
Macro body: None.

The following additional parameters are available in storage format and wikimarkup.

Parameter name Required Default Parameter description
and accepted values

url Yes (none) This is the location of the
gadget specification
(XML file).

pref erences No (Gadget-dependent) Specific property settings

that are particular to
each gadget.

A note about editing a gadget's properties (preferences) in markup: It is possible to edit the values of these
properties directly in the wiki markup or storage format. However, this will allow the entry of invalid values. If a
gadget property supports a certain set of values, the macro browser will restrict the user to selecting only valid
values for that property. For that reason, we recommend that you use the macro browser to edit a gadget's
properties.

Storage format example

This example shows the Confluence Page gadget:

<ac: structured-nmacro ac: nane="gadget ">

<ac: paraneter ac:name="wi dt h">500</ ac: par anet er >

<ac: par anet er ac: name="bor der">f al se</ ac: par anet er >

<ac: par anet er
ac: name="url ">rest/ gadgets/ 1.0/ g/ com atl assi an. confl uence. pl ugi ns. gadget s: conf | uenc
e- page- gadget / gadget s/ conf | uence- page- gadget . xm </ ac: par anet er >

<ac: par anet er
ac: nane="pr ef er ences" >spaceNane=Docunent at i on&anp; spaceKey=DOC&anp; qui ckfi nd- space=
Docunent at i on&anp; pagel d=753666&anp; pageNane=Docunent at i on%20Honme&anp; qui ckfi nd- pag
e=Docunent at i on%20Hone&anp; i sEdi t abl e=t r ue&anp; i sConf i gur ed=t r ue&anp; r ef resh=15&anp
; showLi nk=f al se</ ac: par anet er >
</ ac: structured- macr o>

This example shows the Confluence News gadget:

<ac: structured-nmacro ac: nane="gadget ">
<ac: par anet er
ac: name="url ">rest/gadgets/ 1. 0/ g/ com atl assi an. conf | uence. pl ugi ns. gadget s: conf | uenc
e- news- gadget / gadget s/ conf | uence- news- gadget . xm </ ac: par anet er >
<ac: paramnet er ac: nane="preferences"/>
</ ac: structured- nmacr o>

Wiki markup example

This example shows the Confluence Page gadget:
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{ gadget : wi dt h=500| bor der =f al se| ur| =rest/ gadget s/ 1. 0/ g/ com at | assi an. conf | uence. pl ug
i ns. gadget s: conf | uence- page- gadget / gadget s/ conf | uence- page- gadget . xm }
spaceNanme=Docunent at i on&spaceKey=DOC&qui ckfi nd- space=Docunent at i on&pagel d=753666&pa
geNanme=Docunent at i on%20Honme&qui ckf i nd- page=Docunent at i on%20Hone& sEdi t abl e=t rue& sC
onfi gured=true& efresh=15&showLi nk=f al se

{gadget }

This example shows the Confluence News gadget:

{gadget : url =rest/ gadgets/ 1. 0/ g/ com at | assi an. conf | uence. pl ugi ns. gadget s: conf | uence-
news- gadget / gadget s/ conf | uence- news- gadget . xm }

{gadget }

Gallery Macro

The Gallery macro displays a collection of thumbnail images in a table, based on the images attached to a
Confluence page. When viewing the page, a user can click a thumbnail image to zoom into a screen-sized
image and then view the images as a slide show.

Overview:

® The images shown in the gallery are taken from the files attached to the Confluence page. You can also
specify a different page where the attachments are located. For information about attaching images to a
page, see Attaching Files to a Page.

® The captions below the images are drawn from the comments on the attachments. For information about
adding comments to attachments, see Attaching Files to a Page.

* By default, the gallery will include all the images attached to the page. You can also exclude or include
images using parameters.

® You can sort your images into a particular order.

® You can specify a title for the gallery and also configure how many columns you want for the table in
which your images are displayed.

lllustration: Live example of the Gallery macro

Some office photos, and a waterfall
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Here is the waterfall photo

[ IR

Using the Gallery macro
To insert the Gallery macro onto a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of
suggested macros. Details are in Using Autocomplete.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open,
where you can edit the parameters of the macro.

Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the
parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro
browser, it will be listed below in brackets (exanpl e).

The full list of parameters is shown in the following table. If the name of an attached file or page contains a
comma, you can refer to it in the relevant parameters below by enclosing it in single or double quotes, for
example "t hi s, that.jpg", theother.png

Parameter Default Description

Gallery Title Nothing Specify a title for your gallery.
(title)

Number of Columns 4 Specify the number of columns for
(col umms) your table.

Created in 2014 by Atlassian. Licensed under a Creative Commons Attribution 2.5 Australia License.


http://creativecommons.org/licenses/by/2.5/au/

Confluence 5.5 Documentation

Images to Exclude
(excl ude)

Include these Images Only
(i ncl ude)

Exclude Images with these
Labels
(excl udeLabel)

Include Images with these
Labels Only
(i ncl udeLabel)

Use Images in these Pages
(page)

Sort Images By
(sort)

No exclusions. Include all the
pictures on the page.

Include all the pictures on the
page.

No exclusions. Include all the
pictures on the page.

None. The images are not filtered
by label.

If no page is specified, the gallery
macro displays the images
attached to the page on which the
macro is used.

None. The sort order is
unspecified and therefore
unpredictable.

The gallery will ignore any pictures
specified. You can specify more
than one picture, separated by
commas.

Note: The filename and filetype for
this parameter are case-sensitive.
For example, 'my picture.PNG" will
not be recognised as 'my
picture.png'.

If you specifically include one or
more pictures, the gallery will
show only those pictures. You can
specify more than one picture,
separated by commas.

Note: The filename and filetype for
this parameter are case-sensitive.
For example, 'my picture.PNG' will
not be recognised as 'my
picture.png'.

The gallery will ignore any pictures
that have the specified label. You
can specify more than one label,
separated by commas. For
information on labelling the
attachments, see Adding Labels.

Filters the images to display,
based on a list of labels. If you
wish to enter more than one label,
separate the labels with commas.
Confluence will show only images
that have all the labels specified.
(The match is an AND, not an
OR.) For information on labelling
the attachments, see Adding
Labels.

Specify the title of the page which
contains the images you want
displayed. You can specify more
than one page name, separated
by commas. To specify a page in a
different space, use the following
syntax: SPACEKEY: Page Titl e

Specify an attribute to sort the
images by. Sort order is
ascending, unless you select the R
everse Sort parameter (see
below). Options are:

® name — file name.

® comment — comment linked to
the attached file.

® date — date/time last modified.

® sjze — size of the attached file.
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Reverse Sort Off. Sort order is ascending Used in combination with the Sort

(reverse) Images By parameter above. Use
Reverse Sort to reverse the sort
order, from ascending to
descending.

Available values in storage format
and wikimarkup:

® true - Sortorderis
descending.

®* fal se—Sortorderis
ascending.

Image file formats

You can attach image files of any format to a page. Confluence supports the following image formats in the
Gallery macro and when displaying an image on a page:

* gif

* jpeg

® png

®* bmp (depending on browser support)

Code examples

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a
Confluence page.

Macro name: gal | ery

Macro body: None.

Storage format example

<ac:structured-macro ac: nane="gal | ery">
<ac: paraneter ac:name="title">M holiday pictures</ac:paraneter>
<ac: paraneter ac:name="reverse">true</ac: paraneter>
<ac: paramet er ac:nane="sort">size</ac: paraneter>
<ac: par anet er ac: name="page">M/ pagel, ds: Wl cone to Confl uence</ac: paraneter>
<ac: par anet er ac: nane="excl udeLabel ">badl abel 1, badl abel 2</ ac: par anet er >
<ac: paraneter ac:nanme="col ums">3</ ac: par anet er >
<ac: paranet er ac: nanme="excl ude" >badpi ct ure. png</ ac: par anet er >
</ ac: structured- macr o>

Wiki markup example

{gallery:title=My holiday pictures|reverse=true|sort=size|page=My pagel, ds: Wl cone
to Confl uence| excl udeLabel =badl abel 1, badl abel 2| col utms=3| excl ude=badpi ct ure. png}

Global Reports Macro

The Global Reports macro displays a list of links to some reports about content on your site.

These reports include a list of new or updated pages, orphan pages, undefined pages, and RSS feeds for new
pages and blog posts.

Screenshot: The Global Reports macro
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This is the Global Reports macro

Global Reports

[y New or updated pages since your last login.

[y Find all pages that aren't linked from anywhere.
[ Find all undefined pages.

Feed for new pages and blogs.

Using the Global Reports Macro

To add the Global Reports macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of
suggested macros. Details are in Using Autocomplete.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open,
where you can edit the parameters of the macro.

Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the
parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro
browser, it will be listed below in brackets (exanpl e).

Parameter Default Description
Width of Table 99% Specify the width of the table in
(w dt h) which the links are displayed, as a

percentage of the window width.

Code examples

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a
Confluence page.

Macro name: gl obal -reports

Macro body: None.

Storage format example

<ac: structured-nmacro ac: nane="gl obal -reports">
<ac: paranet er ac:nane="w dt h">50%/ ac: par anet er >
</ ac: struct ur ed- nacr o>

Wikimarkup example

{gl obal -reports:w dt h=50%

HTML Include Macro

The HTML Include macro allows you to include the contents of an external HTML file in a Confluence page.

(D CAUTION: Including unknown HTML inside a webpage is dangerous.
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HTML can contain active scripting components. This means that it would be possible for a malicious
attacker to present a user of your site with script that their web browser would believe came from you.
Such code could be used, for example, to steal a user's authentication cookie and give the attacker their
Confluence login password.

Using the HTML Include Macro
To insert the HTML Include macro into a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of
suggested macros. Details are in Using Autocomplete.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open,
where you can edit the parameters of the macro.

Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the
parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro
browser, it will be listed below in brackets (exanpl e).

Parameter Required Default Description
HTML Page's URL Yes None The URL of the page to
(url) include.

Troubleshooting

® The HTML Include macro will only be available if it has been enabled by your Confluence administrator.
Also, your Confluence Administrator can define a whitelist of trusted URLSs. You will see an error message
on the Confluence page if the included URL is not in the whitelist.

® You can only use the HTML Include macro for pages with absolute links. If you use the macro to include
an HTML page that has relative links, navigating those links in the wiki results in a '‘Page Not Found' error.
See CONF-6567.

Code examples

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a
Confluence page.

Macro name: ht ml -i ncl ude

Macro body: None.

Storage format example

<ac: structured-nmacro ac: nane="htnl -incl ude">
<ac: paraneter ac:name="url">
<ri:url ri:value="http://ww.exanple.conl/>
</ ac: par anet er >
</ ac: structured-macro>

Wikimarkup example

{htm -include: url=http://ww. exanpl e. cont

HTML Macro
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The HTML macro allows you to add HTML code to a Confluence page.

ﬂ Note that the HTML macro will only be available if it has been enabled by your System Administrator.

Using the HTML Macro
To add the HTML macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of
suggested macros. Details are in Using Autocomplete.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open,
where you can edit the parameters of the macro.

There are no parameters for this macro.

Enter the HTML code into the body of the macro placeholder.

Code examples

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a
Confluence page.

Macro name: ht ni
Macro body: Text, consisting of HTML code.

Parameters: None.

Storage format example

<ac: structured-nmacro ac: name="htn ">

<ac: pl ai n-t ext - body><![ CDATA[ <a href="http://ww. atl assi an. com'>C i ck here</a> to
see the <b>Atl assi an</b> website.]]></ac: pl ai n-text-body>
</ ac: structured-nacro>

Wikimarkup example

{htm }<a href="http://ww. at| assi an. com'>Cl i ck here</a> to see the <b>Atl assi an</ b>
website. {htm}

IM Presence Macro

The IM Presence macro indicates graphically when a contact is signed into an Instant Messaging (IM) service.
The IM Presence macro appears as a small icon on the page.

Using the IM Presence Macro
To add the IM Presence macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of
suggested macros. Details are in Using Autocomplete.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open,
where you can edit the parameters of the macro.

Parameters
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Parameters are options that you can set to control the content or format of the macro output. Where the

parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro

browser, it will be listed below in brackets (exanpl e).

Parameter

User ID/Screen Name

Service
(service)

Show User ID
(showi d)

Code examples

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a

Confluence page.
Macro name: i m

Macro body: None.

Storage format example

<ac:structured-macro ac:nanme="im >

Description

Identify the user by their ID, account name or screen

name.
aim — AOL Instant Messenger
gtalk — Google Talk

icq—1CQ

jabber — Jabber

msn — MSN Instant Messenger
sametime — IBM Lotus Sametime

skype — Skype. Note: Skype requires 'Show my
status on the web' to be checked under 'Privacy
preferences

skypeme — Skype
wildfire — Openfire Server
yahoo — Yahoo! Messenger

Shows or hides the User ID of the contact.

<ac: paranet er ac: nane="showi d">f al se</ ac: par anet er >
<ac: paraneter ac: nanme="service">skype</ac: paranet er >
<ac: par anet er ac: nane="">M/SkypeNane</ ac: par amet er >

</ ac: structured-nmacro>

Wiki markup example

{i m MySkypeNane| servi ce=skype| showi d=f al se}

Include Page Macro

You can use the Include Page macro to display the contents of one Confluence page or blog post in another

page or blog post.

Using the Include Page Macro

To add the Include Page macro to a page:
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1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of
suggested macros. Details are in Using Autocomplete.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open,
where you can edit the parameters of the macro.

Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the
parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro
browser, it will be listed below in brackets (exanpl e).

Parameter Default Description

Page to Include None This is the name of the Confluence
page or blog post that you want to
include in the current page. Start
typing a page title, and Confluence
will suggest matching pages from
the current space and other
spaces.

Alternatively you can specify the
page as follows:

* |f the page or blog post is
located in another space, add
the space key and a colon in
front of the page name. For
example, DOC: My page
nane. The space key is case
sensitive.

® To include a blog post, specify
the date as well as the title of
the blog post. For example: / 2
010/ 12/ 01/ My bl og post.

® You can include pages from
personal spaces using ~usern
ane as the space key, where
‘username’' is the person's
username. For example, ~j sm
ith: My page nane.

Code examples

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a
Confluence page.

Macro name: i ncl ude

Macro body: None.

Storage format example
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<ac:structured-nmacro ac: nane="incl ude" >
<ac: paraneter ac:nanme="">
<ac: | ink>
<ri:page ri:content-title="My chocol ate page" ri:space-key="DOC"'/ >
</ac:link>
</ ac: par anet er >
</ ac: structured- nmacr o>

Wiki markup example

{incl ude: DOC: My chocol at e page}

Notes

® If you want to include part of a page rather than the whole page, use the Excerpt and Excerpt Include mac
ros.
® To display a page's contents, you need 'View' permission for that page. Similarly, people who view the
page will need 'View' permissions for the embedded page as well as the page into which it is embedded.
See space permissions or contact your Confluence space administrator for more information.
® If you want to embed an external page into a Confluence page, you need the HTML Include Macro.
Sample Include Page

Start of sample page content

Lorem ipsum dolor sit amet, consectetuer adipiscing elit. Aliquam fermentum vestibulum est. Cras rhoncus.
Pellentesque habitant morbi tristique senectus et netus et malesuada fames ac turpis egestas. Sed quis tortor.
Donec non ipsum. Mauris condimentum, odio nec porta tristique, ante neque malesuada massa, in dignissim
eros velit at tellus. Donec et risus in ligula eleifend consectetuer. Donec volutpat eleifend augue. Integer gravida
sodales leo. Nunc vehicula neque ac erat. Vivamus non nisl. Fusce ac magna. Suspendisse euismod libero eget
mauris.

End of sample page content
Info Macro

The Info macro allows you to highlight helpful information on a Confluence page. It creates a blue-coloured box
surrounding your text, as shown below.

Info Macro Example
This text is rendered inside the info macro.

Using the Info Macro

To add the Info macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of
suggested macros. Details are in Using Autocomplete.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open,
where you can edit the parameters of the macro.

Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the
parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro
browser, it will be listed below in brackets (exanpl e).
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Parameter

Optional Title
(title)

Show Information lcon
(icon)

Code examples

Default

none

true

171

Description

The title of the information box. If
specified, the title text will be
displayed in bold next to the icon.

If "false", the icon will not be
displayed.

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a

Confluence page.
Macro name: i nfo

Macro body: Accepts rich text.

Storage format example

The following example shows all parameters and a body:

<ac:structured-macro ac: name="info">
<ac: paraneter ac:nanme="icon">fal se</ac: par anet er >
<ac: paraneter ac:nanme="title">This is ny title</ac:paraneter>

<ac:rich-text-body>
<p>

<span>This i s </span> <enpi nportant</enr <span> i nformation. </ span>

</ p>
</ac:rich-text-body>
</ ac: structured-nmcro>

Below are some examples of the Info macro with various optional parameters used.

Description

Info macro with a body defined
and no optional parameters

Markup

<ac: structured-nmacro
ac: nanme="i nf 0" >

<ac:rich-text-body>

<p>This is
<enwi nport ant </ en
i nformation. </ p>

</ac:rich-text-body>
</ ac: structured-nmacr
o>

What you will get

(D This is important informati
on.
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Info macro with with a body and an
optional Title parameter defined

Info macro with a body and
optional Title and Icon parameters
defined

Wiki markup example

<ac: structured-nmacro
ac: nane="info">

<ac: par anmet er
ac: name="title">This
is nmy
title</ac: paraneter>

<ac:rich-text-body>

<p>This is
<enwi nport ant </ en®
i nformation. </ p>

</ac:rich-text-body>
</ ac:structured-nacr
o>

<ac: structured-nmacro

ac: nanme="info">
<ac: par anet er

ac: nane="icon">f al se

</ ac: par anet er >
<ac: par anet er

ac:nane="title">This

is ny

title</ac: paraneter>

<ac:rich-text-body>
<p>
<span>This is
</ span>
<en®i nport ant </ en®
<span>
i nf ormati on. </ span>
</ p>

</ac:rich-text-body>
</ ac: structured-nmacr
o>

{info:title=This is ny title|icon=fal se}

This is _inmportant_ information

{info}

JIRA Chart Macro

(i) This is my title
This is important informati
on.

This is my title
This is important information.

JIRA is Atlassian's issue tracking and project management system. By adding the JIRA Chart macro to a
Confluence page, you can display information about JIRA issues and projects as pie charts.

Before you can use this macro, your Confluence and JIRA sites must be connected via Application Links. People
viewing the page will see charts for publicly accessible issues from the JIRA site. If your JIRA site has restricted

viewing (that is, people need permission to view issues) then they will need to authenticate before seeing the
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charts. This macro is compatible with JIRA 5.x and later.

Adding the JIRA Chart macro to a page
Quick guide to using the macro on a Confluence page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of
suggested macros. Details are in Using Autocomplete.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open,
where you can edit the parameters of the macro.

Using the JIRA Chart Macro
To add a JIRA chart to your page:

1. Insert the JIRA Chart macro (see above).
2. Select your JIRA server.

If you have multiple JIRA instances linked to Confluence the drop down will default to the primary
application link.
3. Search for issues - you can enter the query in JQL or paste a JIRA URL directly into the search field.
4. Choose Preview to see the chart.
5. Choose Insert.

To find out more about searching for issues see Displaying issues via a JIRA Query Language (JQL) search.
You can further control how the chart appears on your page. Choose Display options:

® Chart by - select the JIRA field you want to segment the pie chart by.

® Width - define the total width of the chart area. You can enter values in pixels or percent. Leave blank to
auto fit.

® Show border - add a border around the chart area

® Show chart information - include a text summary under the chart with the total issues count and chart
by value.

Screenshot: The JIRA Chart Macro in the macro browser

Insert JIRA Chart

Project = '"CONF' AND fixVersion = '5.4" JAC

Search using any issue key, search URL. JIRA link, JQL or plain text

Fie Chart )
[=] = Preview

More to come

Resolved
g -

Awaiting
. Merge
- /=
\ ,f".l Quality
=" s Review
T
¥ Display options
Chartby | status [+]
Width | 90%
Enter a width in pixels, percent or leave blank to automatically resize
[C] Show border
[C] Show chart information
Select Macro Insert | Cancel

Disabling the JIRA Chart macro
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The functionality is provided by an add-on (plugin) called 'JIRA Macros'. This macro is also used for the JIRA
Issues macro. To make the macro unavailable on your site, you can disable the add-on. See Disabling and
enabling add-ons.

Notes

HTTPS: The JIRA Chart macro can access a JIRA site running under SSL provided the Confluence server is
configured to accept the JIRA SSL certificate. See Connecting to LDAP or JIRA or Other Services via SSL.

Authentication: If the query includes issues that require authentication (issues that are not visible to
anonymous users in JIRA), users will be prompted to authenticate to view charts on the Confluence page.

In order to search for issues in the macro browser you may need to authenticate. With JIRA 5.x you will be able
to search for unrestricted issues as an anonymous user, however with JIRA 6.x you must be authenticated to
search for any issues.

Code examples

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a
Confluence page.

Macro name: j i rachart
Macro body: None.

The following parameters are available in storage format.

Parameter name Required Default Parameter description
and accepted values

chart Type Yes Pie Type of chart to display.
Currently Pie is the only
available chart type.
Other types may be
added in future.

st at Type Yes Statuses The JIRA field to
segment the pie chart by:

® st at uses - displays
a breakdown of
issues by Status.

® all Fixfor -
displays a breakdown
of issues by chart by
all Fix Versions (use
ful if issues have
more than one fix
version).

® assignees -
displays a breakdown
of issues by the Assi
ghee name.

® priorities-
displays a breakdown
of issues by Priority.

® conponents -
displays a breakdown
of issues by Compon
ent.

® issuetype displays
a breakdown of
issues by Issue Type
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sho

W d

bor

wi nf or No False Displays text information
about the data below the
chart. Includes the Total
value and the Chart By
value.

Yes JQL query for the chart to
display.

th 600 (blank) This is the total width of
the chart area. Width can
be entered in pixels,
percent or left blank to fit
to the available space.

der No False Displays a border around
the chart area.

Storage format example

Example chart by Issue Type - note that Confluence will insert the ser ver and ser ver | d parameters, based
on settings in Application Links:

<ac:structured-macro ac: nanme="jirachart">
<ac: paraneter ac: nanme="chart Type" >pi e</ ac: par anet er >
<ac: par aneter ac:nane="st at Type">i ssuet ype</ ac: par anet er >
<ac: paramnet er ac: nane="showi nfor">true</ac: par anet er >
<ac: par anet er
ac: name="j gl " >pr oj ect ¥20¥8D¥R0CONF¥20and%20f i xVer si on%20i n%20("' 5. 3' ) </ ac: par anet er >
<ac: paranet er ac:nane="w dt h">600</ ac: par anet er >
<ac: par aneter ac: nane="server">JAC</ ac: par anet er >
<ac: par anet er
ac: nane="server| d">144880e9- a353- 312f - 9412- ed028e8166f a</ ac: par anet er >
<ac: paranet er ac: nane="border">true</ ac: par anet er >
</ ac: struct ur ed- nacr o>

JIRA Issues Macro

JIRA

is the issue tracking and project management system supplied by Atlassian. By adding the JIRA Issues

macro to a Confluence page, you can display one or more issues from a JIRA site. You can also choose to
create an issue in JIRA, at the time of adding the macro to the Confluence page.

Before you can use this macro, your Confluence and JIRA sites must be connected via Application Links. People
viewing the page will see the publicly accessible issues from the JIRA site. If your JIRA site has restricted
viewing (that is, people need permission to view issues) then they will need to authenticate before seeing the
restricted issues. See more about restricted JIRA issues below.

What you can do with the JIRA Issues macro

Using the JIRA Issues macro, you can:

Display a table of JIRA issues on your page, based on the results of a search using JIRA Query
Language (JQL).

Display a table of JIRA issues onto your page, using a JIRA URL.

Display a single issue from the JIRA site, or a subset of selected issues from your JIRA search results.
Display a count of issues from the JIRA site.

Create new issues in JIRA and display the issues on your page without leaving Confluence.

Adding and updating the JIRA Issues macro — an overview

Quick guide to using the macro on a Confluence page:
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1.
2.

In the Confluence editor, choose Insert > Other Macros.
Find and select the required macro.

Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of
suggested macros. Details are in Using Autocomplete.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open,
where you can edit the parameters of the macro.

Screenshot: Example of JIRA issues macro on a Confluence page

Key

summary T

CONF-30894  Useris not prompted before overwriting changes of another (¢
5

CONF-30866  TableOfContents Macros navigation is not working in (¢

Firefox 23.x / 24 x and Opera 12.16

CONF-30663 Left panel overlaps custom banner in Chrome (¢

CONF-30690 Dashboard popular stream won't render when it contains O]

content from an anonymous user

4 issues ¥ Refresh

Updated -~

Oct 22, 2013

Sep 24, 2013

Sep 23, 2013

Sep 19, 2013

P

Status

RESOLVED

RESOLVED

RESOLVED

RESOLVED

Resolution

Fixed

Fixed

Fixed

Fixed

Displaying issues via a JIRA Query Language (JQL) search

You can use the macro to display a table of JIRA issues on your page, based on the results of a search using Ji

RA Query Language (JQL).

JQL is a simple query language, similar to SQL, which works in JIRA. A basic JQL query consists of a field,

followed by an operator (such as = or >), followed by one or more values or functions.

Examples:

® The following query will find all issues in the 'TEST' project:

proj ect = "TEST"

® The following query will find all issues in the ‘documentation' component of the 'CONF' project:

proj ect = CONF and conponent = docunentation

For more information about JQL syntax, see the JIRA documentation: Advanced Searching.

To display a table of issues based on a JQL search:

ok wNE

7.

Insert the JIRA Issues macro onto your Confluence page, as described above.

Choose a JIRA server next to the Search button.
If prompted, log in to the JIRA server.

Enter the JQL query into the Search box.
Choose Search.

If you want to customise the display, choose Display options and adjust the columns and number of

issues that will appear in your table of issues.
Choose Insert.

Screenshot: Display options in the JIRA Issues macro browser.
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v Display options
Display as
Display the macro as a single issue.

Total issue count

Display total number ofissues as alink. E.g. 22 issues
@ Table
Customise your columns below,

Maximum issues | 20
Leave empty to get all issues.
Columns to display Key x || Summary x | | Issue Type % | Created x

Updaied % || Due Date x| Assignee x| Reporier
Priority % | | Status % | | Resolution x

Displaying issues via a JIRA URL

You can paste any of the following JIRA URLs into the JIRA Issues macro. Confluence will immediately convert
the URL to a JQL search.

* Any URL for a JIRA issue search or filter.
® A URL for a single issue.
® The URL of the XML view of a JIRA search.

Auto-convert: You can paste a JIRA URL directly into the Confluence editor (without calling up the macro
browser). Confluence will automatically convert the URL into a JIRA Issues macro.

Displaying a single JIRA issue, or selected JIRA issues
To display a single JIRA issue, choose one of the following methods:

® Paste the URL of the issue directly onto the Confluence page. (There is no need to use the macro
browser.) Confluence will auto-convert the link to a JIRA Issues macro.

® Or: Add the JIRA issues macro to the page as described above, and choose Recently Viewed to see the
JIRA issues you have visited recently. Select an issue and choose Insert.

® Or: Add the JIRA issues macro to the page as described above, and past the issue URL into the search
box in the macro browser.

® Or: Add the JIRA issues macro to the page, define your search criteria in the macro browser via JQL as
described above, then select the check box next to the issue in the search results, within the macro
browser.

You can display a single issue in a simple format with only its description and status, or in table form.

Display options
Display as ® Single issue

Display the macro as a single issue.

Display total number of issues as a link. E.g. 1 issues
Table

Customise your columns below

To display a subset of JIRA issues from your search results:

1. Add the JIRA issues macro to the page.
2. Define your search criteria in the macro browser via JQL, as described above.
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3. Select the check boxes next to the required issues in the search results, within the macro browser.

Screenshot: Selecting a subset of issues to display

Insert JIRA Issue
Search project = CONF Q
Create New Issue Search using any issue key, search URL, JIRA link, JQL or plain text
Recently Viewed O Key Summary -
[ (s) CONF-31418 Error getting content from PDF document
(7] CONF-31417 Page Properties Report Macro should offer filters on specifi. . |5
[ (® CONF-31415 Special Characters Entered into Link Macro Causes Link to ...
() CONF-31414 Add Attachments Macro (and Tools->Attachments) plugin po...
[ (=] CONF-31413 Code Block Macro creates hyperlinks from URLs when sett...
O] [¢) CONF-31411 Activity Stream gadget doesn't respect the Look and Feel s...
[Z) CONF-31410 Editor: Control of the Insert pull-down menu
[ (# CONF-31409 Use MoCookie directive in Multimedia Widgets for external c. ..
[ (#) CONF-31408 Merge Two Pages and Preserve the Incoming Links for Both
~ Display options
Select Macro Hint: type "Cirl+3hifi+J" in the editor fo quickly access this dialog Insert | Cancel

Displaying a count of issues

You can choose to display the number of issues returned by your search, rather than a table of issues. The JIRA
Issues macro will display a count of issues, linked to the search in JIRA.

Screenshot: The JIRA Issues macro displaying an issue count on a Confluence page
28227 issues

To display an issue count:

1. Add the JIRA issues macro to the page.

2. Define your search criteria in the macro browser via JQL, as described above.

3. Choose Display options, then choose Total issue count next to 'Display options' in the macro browser.
4. Choose Insert.

Creating a new JIRA issue in the editor

While editing a Confluence page, you can create an issue in JIRA and display it on your Confluence page,
without leaving the Confluence editor.

To insert an issue into JIRA:

1. Add the JIRA Issues macro to the page, as described above.
2. Choose Create New Issue.
3. Supply the information about your JIRA server, project, and issue, as prompted.
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4. Choose Insert.

Confluence will send a request to JIRA, to add the issue to the JIRA site. Confluence will also display the
resulting JIRA issue on the Confluence page.

Limitations

The JIRA Issues macro will notify you if it is unable to create an issue in the selected project. This may be
because the project has a required field, field configuration or other customisation that is not supported by the
JIRA Issues macro. In this situation you will need to create the issue directly in JIRA.

Configuring Application Links to display restricted JIRA issues
Before you can use this macro, your Confluence and JIRA sites must be connected via Application Links.

If the JIRA site allows anonymous viewing of issues, you must configure an application link, but there is no need
to configure any incoming or outgoing authentication between JIRA and Confluence. People viewing the
Confluence page will see the publicly accessible issues from the JIRA site.

If your JIRA site has restricted viewing, or if some JIRA projects or issues are restricted to viewing by certain
people, then people will need to log in before seeing the restricted issues.

In such a case, the outgoing authentication in the Confluence Application Links determines how the JIRA Issues
macro handles restricted issues:

® If the outgoing authentication is set to Trusted Applications, people can see restricted issues in JIRA if
their username is the same in JIRA and Confluence, and if they have permission in JIRA to see the issue.

® |f the outgoing authentication is set to OAuth, people may need to choose Login & Approve, to gain
access to the JIRA server and restricted issues.

® If the outgoing authentication is set to Basic Access, people can see the JIRA issues that are visible to
the user account configured in JIRA's outgoing authentication setting.

Rendering HTML from JIRA

Formatted fields from JIRA can be displayed in Confluence if you set up a Confluence-to-JIRA application link.
Otherwise, such formatted fields will be escaped within the output of the JIRA issues macro. This is to prevent
the possibility of malicious HTML being served by an untrusted JIRA server. The most likely field where you will
notice this is in the description field.

This example shows how a description column may be displayed in JIRA:

Description
This is
® the description
® of my issue

If there is no application link between JIRA and Confluence, the description will appear in the JIRA issues macro
like this:

Description
<p>This is<ul><li>the description</li><li>of my issue</li></ul></p>
Disabling the JIRA Issues macro

The functionality is provided by an add-on (plugin) called 'JIRA Macros'. To make the macro unavailable on your
site, you can disable the add-on. See Disabling and enabling add-ons.

Notes

HTTPS: The JIRA Issues macro can access a JIRA site running under SSL provided the Confluence server is
configured to accept the JIRA SSL certificate. See Connecting to LDAP or JIRA or Other Services via SSL.

Custom fields can be added as columns to the table simply by using the name of the field with no quotes. Earlier
versions of the macro required you to use the custom field id, e.g. cust onfi el d_10100.
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Code examples

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a

Confluence page.
Macro name: j i rai ssues

Macro body: None.

Note: A number of additional parameters that are not available via the macro browser are available in storage

format and wikimarkup.

Parameter name

anonynmous

baseur |

Required

No

No

Default

fal se

The value of the 'url'
parameter

Parameter description
and accepted values

If this parameter is set to
‘true’, JIRA will return
only the issues which
allow unrestricted
viewing. That is, the
issues which are visible
to anonymous viewers,
as determined by JIRA's
viewing restrictions. If
this parameter is omitted
or set to ‘false’, then the
results depend on how
your administrator has
configured the
communication between
JIRA and Confluence. By
default, Confluence will
show only the JIRA
issues which the user is
authorised to view.

Note: This parameter is
available only if you
insert the macro via wiki
markup or by editing the
storage format of the
page. The graphic user
interface (macro
browser) for the JIRA
Issues macro does not
offer this parameter.

If you specify a 'baseurl’,
then the link in the
header, pointing to your
JIRA site, will use this
base URL instead of the
value of the "url'
parameter. This is useful
when Confluence
connects to JIRA with a
different URL from the
one used by other users.
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col umms

count

cache

No

No

No

By default, the following
columns are shown:

type

key
summary
assignee
reporter
priority
status
resolution
created
updated
due

fal se

on

A list of JIRA column
names, separated by
semi-colons (;). You can
include any columns
recognised by your JIRA
site, including custom
columns. See the JIRA
documentation for a list
of names.

If this parameter is set to
'true’, the issue list will
show the number of
issues in JIRA. The
count will be linked to
your JIRA site.

The macro maintains a
cache of the issues
which result from the
JIRA query. If the 'cache’
parameter is set to 'off,
the relevant part of the
cache is cleared each
time the macro is
reloaded. (The value
‘false' also works and has
the same effect as 'off'.)

Note: This parameter is
available only if you
insert the macro via wiki
markup or by editing the
storage format of the
page. The graphic user
interface (macro
browser) for the JIRA
Issues macro does not
offer this parameter.
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hei ght No 480 (if render mode is The height in pixels of
dynamic) the table displaying the
JIRA issues.

Note that this height
specification is ignored in
the following situations:

® |f the 'renderMode'
parameter (see
below) is set to
'static'.

®* When the JIRA
issues are displayed
in a PDF or Word
document, in an
email message or in
an RSS feed.

Note: This parameter is
available only if you
insert the macro via wiki
markup or by editing the
storage format of the
page. The graphic user
interface (macro
browser) for the JIRA
Issues macro does not
offer this parameter.

r ender Mode No static If the value is 'dynamic’,
the JIRA Issues macro
offers an interactive
display which people can
manipulate as follows:

® Click the column
headers to sort the
output.

® Drag and drop the
columns into a
different order.

® Temporarily remove
a column from the
display.

®* View a page of
issues at a time, for
faster response
times.

A value of 'static’ will
disable the dynamic
display features.

Note: This parameter is
available only if you
insert the macro via wiki
markup or by editing the
storage format of the
page. The graphic user
interface (macro
browser) for the JIRA
Issues macro does not
offer this parameter.
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title

ur |

wi dt h

Storage format example

No

Yes

No

JIRA Issues

none

100%

You can customise the
title text at the top of the
JIRA issues table with
this parameter. For
instance, setting the title
to 'Bugs-to-fix' will
replace the default 'JIRA
Issues' text. This can
help provide more
context to the list of
issues displayed.

Note: This parameter is
available only if you
insert the macro via wiki
markup or by editing the
storage format of the
page. The graphic user
interface (macro
browser) for the JIRA
Issues macro does not
offer this parameter.

The URL of the XML
view of your selected
issues in JIRA Issue
Navigator.

Note: If the URL in the
‘url’ parameter does not
contain at erpMax argu
ment, then the value of t
enpMax will default to
500. If your JIRA server
is version 3.12 or earlier,
this means that the JIRA
Issues macro will return a
maximum of 500 issues.
If your JIRA server is
version 3.13 or later, a
value of 500 means that
the JIRA Issues macro
will return a maximum of
500 issues per page.

The width of the table
displaying the JIRA
issues. Can be indicated
either as a percentage
(%) or in pixels (px).

Note: This parameter is
available only if you
insert the macro via wiki
markup or by editing the
storage format of the
page. The graphic user
interface (macro
browser) for the JIRA
Issues macro does not
offer this parameter.
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Example using a URL that points to the XML view of a JIRA search:

<ac:structured-nmacro ac:nanme="jirai ssues">

<ac: par anet er ac: nanme="anonynous" >true</ ac: par anet er >

<ac: paranet er ac: name="col uims" >t ype; key; sunmar y</ ac: par anet er >

<ac: paraneter ac:name="url">

<ri:url

ri:value="http://jira.atlassian.com sr/jira.issuevi ews: searchrequest-xm /tenp/ Searc
hRequest . xm ?j gl Quer y=pr oj ect +¥%3D+CONF+AND+%28sumar y+% E+j i r ai ssues+COR+descri ption
+9@E+j i rai ssues+OR+comment +%&E+j i r ai ssues¥@29&anp; t enpMax=10"/ >

</ ac: par anet er >
</ ac: structured- macro>

Example using JQL — note that Confluence will insert the ser ver and ser ver | d parameters, based on settings
in Application Links:

<ac:structured-macro ac: name="jira">

<ac: par amet er
ac: name="col ums" >key, sunmary, t ype, cr eat ed, assi gnee, st at us</ ac: par anet er >

<ac: paraneter ac:nane="server">Atl assi an JI RA</ ac: par anet er >

<ac: par anet er
ac: name="server| d">144880e9- a1111- 333f - 9412- ed999a9999f a</ ac: par anet er >

<ac: paraneter ac:nanme="j gl Query">project = CONF AND conponent = documentati on

AND resol ution = unresol ved</ ac: par anet er >

</ ac: structured- macr o>

Wikimarkup example

{jiraissues:anonynous=true|url=http://jira.atlassian.conisr/jira.issueviews:searchr
equest - xm / t enp/ Sear chRequest . xm ?j gl Quer y=pr oj ect +¥%3D+CONF+AND+%28sunmar y+%’E+j i ra
i ssues+OR+descri pti on+%’E+j i r ai ssues+OR+conment +%E+j i r ai ssues%®9&t enpMax=10| col um
s=type; key; summary|titl e=My List of |ssues}

JUnit Report Macro

The JUnit Report macro displays a summary of JUnit test results from a directory accessible by the Confluence
server. JUnit is a unit testing framework which allows programmers to ensure that individual units of Java source
code are functioning correctly.

For security reasons JUnit test result files can only be imported from a specified location in the

Confluence server's file system. We recommend administrators create a folder in their Confluence home
directory, add the system property conf | uence. junit.report. directory and specify the location for
JUnit test result files to be imported from. JUnit Test result files cannot be imported from the server until this
system property is set.

The JUnit Report macro appears as shown in the screenshot below.

Screenshot: The JUnit Report macro in Confluence

Test Time Messages
MoneyTest 100% _ 00:03.391 Tests:Failures:Exceptions:
1 0 0
[» testAdd 00:03.0
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Note:When generating reports from the JUnit Report macro, set the Apache Ant formatter to 'XML".

Using the JUnit Report macro
To add the JUnit Report macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of
suggested macros. Details are in Using Autocomplete.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open,
where you can edit the parameters of the macro.

Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the
parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro
browser, it will be listed below in brackets (exanpl e).

Parameter Required Default Description

URL of the test result Must include either the d  None URL of a particular test
XML file irectoryortheurl pa result XML file. Is

(url) rameter overridden by the Direct

ory (URL) of your test
result files parameter if
you use both.

Example, from a
Confluence instance: ht
tp: //your Confl uenc
el nst ance. coni down
| oad/ att achnment s/ <
page id>/file.xm

For Confluence
installations without
anonymous user access,
you can specify logon
credentials as part of this
parameter in the form of
URL parameters:

® 0s_username —
The username of a
Confluence user with
permission to access
to the JUnit test
results.

® 0s_password —
The password of the
Confluence user
specified in the os_u
Ser name parameter.
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Directory (URL) of your  Mustinclude eitherthe d  None URL of a directory
test result files irectory ortheurl pa containing your test
(directory) rameter result files. This must be

a directory name and not
the XML file itself.
Overrides the URL of the
test result XML file para
meter if you use both.

Example,file:///C./
TEMP/

Example, for a network
drive: http://*host*/

*pat h*
Report Detail No all Detalil for the report. Can
(reportdetail) be all, fixture, summary
or failuresonly.
Debug No None Shows the content of
(debug) failures, as well as the

error messages.

Code examples

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a
Confluence page.

Macro name: j uni treport

Macro body: None.

Storage format example

<ac:structured-nmacro ac: name="junitreport">
<ac: paraneter ac:nanme="reportdetail">sunmary</ac: paranet er >
<ac: paraneter ac:nanme="directory">
<ri:url ri:value="http://confluence.com downl oad/ attachnents/123/"/>
</ ac: par anet er >
<ac: par anet er ac: name="debug">true</ac: par anet er >
<ac: paraneter ac:name="url">
<ri:url ri:value="http://confluence.com downl oad/ attachnents/123/file.xm"/>
</ ac: par anet er >
</ ac: structured- macr o>

Wiki markup examples

Loading JUnit reports from a local drive:

{junitreport:directory=file:///C | TENMP/}

Loading JUnit reports from a network drive:

{junitreport:url=http://*host*/*path*}

Loading JUnit reports from a Confluence site:
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{junitreport:url=http://yourConfluencel nstance. conl downl oad/ att achnent s/ <page
id>/file.xm}

Loading JUnit reports from a Confluence site that requires authentication:

If your Confluence site is not accessible by anonymous users, specify login credentials with the os_user nane a
nd os_passwor d URL parameters (as part of the macro's ur | parameter). In this case, we are specifying a
username of '‘admin' and a password of 'secret'.

{junitreport:url=http://yourConfluencel nstance. conf downl oad/ att achnent s/ <page
id>/file.xm ?0s_user nane=adm n&os_passwor d=secr et }

Labels List Macro

The Labels List macro displays a list of all labels within the current space. Each label in the list links to a page
that displays all pages in the current space that contain that label.

Using the Labels List macro
To add the Labels List macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of
suggested macros. Details are in Using Autocomplete.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open,
where you can edit the parameters of the macro.

Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the
parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro
browser, it will be listed below in brackets (exanpl e).

Parameter name Required Default Parameter description
and accepted values

Restrict to this Space No Current space The key of the space

Key whose labels you want to

(spaceKey) display.

Excluded label(s) No Blank The labels that you do

(excl udedLabel s) not want to appear in the
list.

Code examples

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a
Confluence page.

Macro name: | i st abel s

Macro body: None.

Storage format example
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<ac:structured-nmacro ac: nane="1listl abel s">
<ac: paramet er ac: nane="spaceKey" >
<ri:space ri:space-key="DOC"'/ >
</ ac: par anet er >
<ac: par anet er ac: nane="excl udedLabel s">not -t hi s-1 abel </ ac: par anet er >
</ ac: structured- macr o>

Wiki markup example

{l'i stl abel s: spaceKey=DOC}

Livesearch Macro

The Livesearch macro allows you to add a search box to a Confluence page. When users enter a search term
into the search box, Confluence will dynamically display matching results as they type.

Using the Livesearch macro
To add the Livesearch macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of
suggested macros. Details are in Using Autocomplete.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open,
where you can edit the parameters of the macro.

Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the
parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro
browser, it will be listed below in brackets (exanpl e).

Parameter Default Description

Restrict to this Space Key all spaces Specify a space key to limit the

(spaceKey) search to the given space.
Case-sensitive.

Restrict to label(s) Specify labels to limit the search to

(1 abel s) content with that label. If

unspecified will search all content
regardless of label.

Size medium Choose a medium or large search
(size) field size.

Placeholder text Specify the placeholder text to
(pl acehol der) appear in the search field, for

example 'Search this space’
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Type all Specify the content types to be

(type) included in the search - choose
from pages, blogs, comments,
space descriptions, or all content

types.
Additional space name Display the space name, a page
(addi tional) excerpt or nothing under the

search result.

Code examples

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a
Confluence page.

Macro name: | i vesear ch
Macro body: None.

Storage format example

<ac: structured-nmacro ac: nanme="|ivesearch">
<ac: paranet er ac:nane="addi ti onal ">page excerpt</ac: paraneter>
<ac: par anet er ac: nane="pl acehol der">Search thi s space</ ac: par anet er >
<ac: par anet er ac: nanme="| abel s">nyLabel </ ac: par anet er >
<ac: paraneter ac: nane="spaceKey">
<ri:space ri:space-key="SS"/>
</ ac: par anet er >
<ac: paraneter ac:nanme="type">page</ac: paranet er >
<ac: paraneter ac:nanme="size">| arge</ ac: par anet er >
</ ac: structured- macr o>

Wikimarkup example

{l'i vesear ch: spaceKey=DOC]| si ze=l ar ge| pl acehol der=Search thi s space}

Loremipsum Macro

The Loremipsum macro displays paragraphs of pseudo-Latin text (more information). You can use this macro to
generate more-or-less meaningless text for demonstration purposes in pages showing a draft layout or
arrangement of page elements. The text is deliberately non-meaningful so that it does not influence the viewer's
perception of the page arrangement or design.

A basic example of the Loremipsum text:

Lorem ipsum dolor sit amet, consectetuer adipiscing elit. Aliguam fermentum vestibulum est. Cras
rhoncus. Pellentesque habitant morbi tristique senectus et netus et malesuada fames ac turpis
egestas. Sed quis tortor. Donec non ipsum. Mauris condimentum, odio nec porta tristique, ante
neque malesuada massa, in dignissim eros velit at tellus. Donec et risus in ligula eleifend
consectetuer. Donec volutpat eleifend augue. Integer gravida sodales leo. Nunc vehicula neque ac
erat. Vivamus non nisl. Fusce ac magna. Suspendisse euismod libero eget mauris.

Using the Loremipsum macro
To add the Loremipsum macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of
suggested macros. Details are in Using Autocomplete.

Created in 2014 by Atlassian. Licensed under a Creative Commons Attribution 2.5 Australia License.


http://creativecommons.org/licenses/by/2.5/au/
http://en.wikipedia.org/wiki/Lorem_ipsum

Confluence 5.5 Documentation 190

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open,
where you can edit the parameters of the macro.

Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the
parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro
browser, it will be listed below in brackets (exanpl e).

Parameter Default Description

Number of Paragraphs 3 Determines the amount of
pseudo-Latin (space-filler) text to
display. The macro will display a
maximum number of 30
paragraphs.

Parameter is unnamed in storage
format and wikimarkup.
Code examples

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a
Confluence page.

Macro name: | or ermi psum
Macro body: None.
Storage format example
<ac:structured-macro ac: name="| orem psuni >

<ac: par anmet er ac: nane="">2</ac: par anet er >
</ ac: structured-nacro>

Wikimarkup example

{l orem psum 2}

Multimedia Macro

Displays videos, animations and more, sourced from a file attached to a Confluence page and displayed on your
page. See Embedding Multimedia Content for more information.

Code examples

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a
Confluence page.

Macro name: nul ti nedi a

Macro body: None.

Parameter name Required Default Parameter description
and accepted values

page No Current page Name of the page to
which the multimedia file
is attached.
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space No
name Yes
wi dt h No
hei ght No
aut ostart No

Storage format example

<ac:structured-nmacro ac: name="nul ti nedi a">

Current space

None

If not specified, the
browser will determine
the width based on the
file type.

If not specified, the
browser will determine
the height based on the
file type.

fal se

<ac: paramet er ac:nane="w dt h">500</ ac: par anet er >

<ac: par aneter ac:name="nane">

<ri:attachnment ri:filenanme="N njas. MOV'/>

</ ac: par anet er >
</ ac: structured-nmacro>

Wikimarkup example

Space key of the page
that has the multimedia
file attached.

File name of the
multimedia file, which is
attached to a Confluence
page.

Width of the movie
window to be displayed
on the page. By default,
this value is specified in
pixels. You can also
choose to specify a
percentage of the
window's width, or any
other value accepted by
HTML.

Height of the movie
window to be displayed
on the page. By default,
this value is specified in
pixels. You can also
choose to specify a
percentage of the
window's height, or any
other value accepted by
HTML.

If the parameter is set to
t r ue then the video or
audio file will start
playing as soon as the
page is loaded. If this
option is setto f al se th
en the file will not play
until the user clicks the
icon or image on the

page.

{mul ti medi a: space=DOC| page=My nacr os| hame=ni nj as. swf | aut ost art =t rue}

Navigation Map Macro

The Navigation Map macro displays a navigable map of the pages tagged with a given label.
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Using the Navigation Map Macro
To add the Navigation Map macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of
suggested macros. Details are in Using Autocomplete.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open,
where you can edit the parameters of the macro.

Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the
parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro
browser, it will be listed below in brackets (exanpl e).

Parameter Default Description

Label none Specify the label associated with
the pages you want to show in the
navigation map.

This parameter is unnamed in
storage format and wikimarkup.

Map Title none Specify a title for the navigation

(title) map.

Number of Cells Per Row 5 Specify the number of cells in a
row

(wrapAfter)

Cell Width (Pixels) 90 px Specify the cell width

(cel Il Wdt h)

Cell Height (Pixels) 60 px Specify the cell height

(cel | Hei ght)

Navigation Map Theme Confluence Define a theme for the navmap.

(there)

If you want to create your own
navmap 'look and feel' (for
example, one with rounded
corners), you need to add a
customised navmap macro theme
file to the VEB- | NF/ cl asses/te
nmpl at es/ macr os directory. The
file name convention to use is hav
map- nyt hene. vm Use the name
of your choice for the nyt hene pa
rt of the file name, which is also
the value you use for this
parameter. Hence, if your theme
was called navmap- r oundededg
es. vm use the value of r ounded
edges for this parameter.

Code examples

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a
Confluence page.

Macro name: navmap
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Macro body: None.

Storage format example

<ac: structured-macro ac: nane="navmap" >
<ac: paramet er ac: nane="w apAfter">4</ac: par anet er >
<ac: paraneter ac:nanme="title">My map nane</ ac: par aneter>
<ac: paraneter ac:nanme="cel | Hei ght ">50px</ ac: par anet er >
<ac: paranet er ac: nanme="t hene" >navmap- nyt hene. vnx/ ac: par anet er >
<ac: paraneter ac: nanme="cel | Wdt h">80px</ac: par anet er >
<ac: par anet er ac: nanme="">nyl abel </ ac: par anet er >
</ ac: structured- macr o>

Wiki markup example

{navmap: nyl abel | wapAfter=4|titl e=My map
nane| cel | Hei ght =50px| t heme=navmap- nyt henme. vni cel | W dt h=80px}

Network Macro

The Network macro displays a list of Network activity on a Confluence page or blog post. You can specify the
user whose network activity you wish to show. These interactions include the users that the specified user is
following or users who are following the specified user. The Network macro shows each listed user by their
profile picture. It also provides a choice of two themes and the ability to limit the number of users in the list.

Screenshot: Network macro

Following

Rach Admin is following 3 users
L]
]|z

Using the Network macro

To add the Network macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of
suggested macros. Details are in Using Autocomplete.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open,
where you can edit the parameters of the macro.

Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the
parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro
browser, it will be listed below in brackets (exanpl e).

Parameter Default Description
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Username

Mode

Theme

Maximum Results

(max)

Disabling the Network macro

Current user's username

following

full

No limit imposed up to a maximum
of 30

194

The username of the Confluence
user whose network interactions
you wish to show. If no username
is specified, then current user's
(that is, your) network interactions
are shown.

Determines which users are listed,
with respect to the specified user:

® following — those who the
user is following.

* followers — those who are
following the user.

This parameter is unnamed in
storage format and wikimarkup.

Determines how the user's
network is displayed:

¢ full —shows a large
version of user's profile
pictures and, if the followi
ng mode is set, provides
an entry field function to
follow more users.

® tiny — shows only the small
version of user's profile
pictures.

Restricts the number of users
displayed. If the number of users
exceeds the specified maximum,
then a Show All link is provided.
This link leads to the specified
user's Network view, showing the
complete list of network
interactions.

The Network macro is provided by the 'network’ module in the 'Profile Macros' plugin. To remove the macro from
your site, you can disable the module in the plugin. See Disabling and enabling add-ons.

Code examples

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a

Confluence page.
Macro name: net wor k

Macro body: None.

Storage format example
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<ac: structured-macro ac: nanme="net wor k">
<ac: paramet er ac: nane="user nane">
<ri:user ri:userkey="12345678912345678912345"/ >
</ ac: par anet er >
<ac: par aneter ac: nane="nmax">10</ ac: par anet er >
<ac: paranet er ac: nane="t hene">ful |l </ ac: par anet er >
<ac: paranet er ac: name="">fol | ower s</ ac: par anet er >
</ ac: structured- nacr o>

Wiki markup example

{network: fol | ower s| user nanme=adm n| nax=10| t hene=ful | }

Noformat Macro

The Noformat macro displays a block of text in monospace font with no other formatting.

Using the Noformat Macro

To add the Noformat macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of
suggested macros. Details are in Using Autocomplete.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open,
where you can edit the parameters of the macro.

Enter the content that is to be unformatted into the body of the macro placeholder.

Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the
parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro
browser, it will be listed below in brackets (exanpl e).

Parameter Default Description
No Panel False Removes the panel around the
(nopanel) content.

Code examples

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a
Confluence page.

Macro name: nof or nat

Macro body: Accepts plain text.

Storage format example
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<ac: structured-nmacro ac: nane="nof or mat " >

<ac: paranet er ac: nane="nopanel ">true</ ac: par anet er >

<ac: pl ai n-t ext - body><! [ CDATA[ ht t p: / / www. exanpl e. con] ] ></ ac: pl ai n-t ext - body>
</ ac: structured- macr o>

Wiki markup example

{nof or mat : nopanel =true} http://ww. exanpl e. com{ nof or mat }

Note Macro

The Note macro displays a block of text in a yellow highlighted box. This is useful for emphasising important
information.

Example:

1 My note
This is the content of my note.

Using the Note Macro
To add the Note macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of
suggested macros. Details are in Using Autocomplete.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open,
where you can edit the parameters of the macro.

Add the text of the note to the body of the macro placeholder.

Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the
parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro
browser, it will be listed below in brackets (exanpl e).

Parameter Default Description
Optional Title none If specified, the title is displayed in
(title) bold next to the icon.
Show Exclamation Mark Icon true ® true — displays the warning
(icon) icon
® false —theicon is not
displayed

Code examples

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a
Confluence page.

Macro name: not e

Macro body: Accepts rich text.
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Storage format example

<ac:structured-nmacro ac: nane="note">

<ac: paraneter ac:nanme="icon">fal se</ac: par anet er >
<ac: paraneter ac:name="title">M title</ac:paraneter>
<ac:rich-text-body>

<p>This is the content

</ac:rich-text-body>
</ ac: struct ured-nmacro>

Wiki markup example

{note:icon=false|title=My title}
This is the content of ny note.

{not e}

Office Excel Macro

of ny note.</p>

The Office Excel macro displays the content of an Excel spreadsheet on a wiki page. First attach the
spreadsheet to a Confluence page, then use the macro to display the content. When viewing the page, people
will see the content of the spreadsheet, without needing to have Office installed.

For details, see the View File Macro.

Code examples

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a

Confluence page.
Macro name: vi ewxl s

Macro body: None.

Parameter name

nane

page

Required

Yes

No

Default

(None.)

The page containing the
macro

Parameter description
and accepted values

The file name of the
Excel spreadsheet to be
displayed. The document
must be attached to a
page on your Confluence
site.

The name of a
Confluence page to
which the Excel
spreadsheet is attached.
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col

row

grid

sheet

No Last column with content
No Last row with content

No true

No The most-recently

viewed worksheet

Storage format example

<ac:structured-nmacro ac: nane="vi ewxl s">

<ac: paraneter ac:nanme="col ">E</ ac: par anet er >
<ac: paraneter ac:nanme="nanme">
<ri:attachnent ri:filenane="Spreadsheet. x|l s"/>
</ ac: par anet er >
<ac: paraneter ac: nanme="sheet">Sheet 1</ ac: par anet er >
<ac: paramet er ac: nane="row'>5</ac: par anet er >

</ ac: structured-nmcro>

Wiki markup example

The number of the last
column you want
displayed, starting from
'0" as the first column.

Hint for reducing the
size of the
spreadsheet: Use the ¢
ol and r ow parameters
to reduce the size of the
spreadsheet displayed
on the wiki page. This is
especially useful to
prevent the display from
showing empty cells.
This will also help to
prevent 'out of memory'
errors.

The number of the last
row you want displayed,
starting from '0' as the
first row.

Determines whether the
macro will show borders
around the cells in the
spreadsheet.

Accepted values:

® true— Shows
borders.

® fal se —Does not
show borders.

The name of the
worksheet that you want
displayed.

{vi ewxl s: col =5| page=Docs| nane=My docunent . xl s| gri d=f al se| sheet =mysheet | r ow=5}

Office PowerPoint Macro

Created in 2014 by Atlassian. Licensed under a Creative Commons Attribution 2.5 Australia License.

198


http://creativecommons.org/licenses/by/2.5/au/

Confluence 5.5 Documentation

The Office PowerPoint macro displays the content of a PowerPoint presentation on a wiki page. First attach the

presentation to a Confluence page, then use the macro to display the content. When viewing the page, people
will see the content of the presentation, without needing to have Office installed.

For details, see the View File Macro.

Code examples

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a

Confluence page.
Macro name: vi ewppt

Macro body: None.

Parameter name

name

page

hei ght

wi dt h

slide

Storage format example

Required

Yes

No

No

No

No

Default

(None.)

The page containing the
macro

All slides, starting with
the first, as a slide show

Parameter description
and accepted values

The file name of the
PowerPoint presentation
to be displayed. The
document must be
attached to a page on
your Confluence site.

The name of a
Confluence page to
which the PowerPoint
presentation is attached.

The height of the macro
display, specified in
pixels (for example: 10p
X, or just 10) or as a
percentage (for example:
209 of the window's
height.

The width of the macro
display, specified in
pixels (for example: 10p
X, or just 10) or as a
percentage (for example:
20%) of the window's
height.

The number of the slide
that you want displayed
on the Confluence page,
where the first slide is
numbered zero. Instead
of a slide show, the page
will display just the single
slide, represented as a
JPEG image.
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<ac: structured-nmacro ac: nanme="vi ewppt ">
<ac: par anet er ac: nanme="hei ght">250</ ac: par anet er >
<ac: paraneter ac:name="wi dt h">250</ ac: par anet er >
<ac: par aneter ac:nanme="nane">
<ri:attachnent ri:filenane="101_sanpl epresentati on. pptx"/>
</ ac: par anet er >
</ ac: structured- nacr o>

Wiki markup example

{vi ewppt : hei ght =20% page=Docs| wi dt h=20% name=My docunent . ppt| sl i de=4}

Office Word Macro

The Office Word macro displays the content of a Word document on a wiki page. First attach the document to a
Confluence page, then use the macro to display the content. When viewing the page, people will see the content
of the document, without needing to have Office installed.

For details, see the View File Macro.

Code examples

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a
Confluence page.

Macro name: vi ewdoc

Macro body: None.

Parameter name Required Default Parameter description
and accepted values

nane Yes (None.) The file name of the
Word document to be
displayed. The document
must be attached to a
page on your Confluence

site.
page No The page containing the  The name of a
macro Confluence page to
which the Word

document is attached.
Storage format example

<ac: structured-macro ac: name="vi ewdoc" >
<ac: par aneter ac:nanme="nane">
<ri:attachnent ri:filenane="Chocol ate. doc"/>
</ ac: par anet er >
</ ac: structured-macr o>

Wiki markup example
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{vi ewdoc: page=Docs| name=My docunent . doc}

Page Index Macro

The Page Index macro creates a hyperlinked alphabetical index of all page titles within the current space.

The top section of the index contains a cell for each letter of the alphabet, with cells for numbers and symbols.
Each cell indicates how many pages are in the corresponding list.

The lower section contains lists of page titles followed by the first few sentences of content on that page.

Each letter, number or symbol in the top section is hyperlinked to the corresponding cell in the lower section.
Each page title in the lower section is hyperlinked to the page in the space.

Screenshot: Page Index macro (partial view)

Space Index
0-9 .1 A B..1 c...1 D0 E..O
0 G...1 .0 ... 1 J..0 K...0
L...O M_..0 M...0 o1 PO Q.0
0 5.8 T...1 u._..o0 V... 0 W_..0
x...0 ¥ .. 0 Z...0 l@#s ... 0
0-9 A
[S) 25 reasons people like Confluence (#] Angry Nerds Home
Integration with JIRA Great product Its a Welcome to Angry Merds, a sample Confluence space. We
wiki User experience design think you're gonna like it herel
B H
[S) Blog ideas (3 Confluence hints and tips
Do users needto be told left side /right What hints and tips do you share with other Confluence
side of screen Macros and what you can users?
do with them
D E
F G
[E) Games as a communication medium
Canwe use games as a communication medium?

Using the Page Index macro
To add the Page Index macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of
suggested macros. Details are in Using Autocomplete.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open,
where you can edit the parameters of the macro.

This macro accepts no parameters.
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Code examples

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a

Confluence page.

Macro name: i ndex

Macro body: None.

Parameters: None.

Storage format example

<ac:structured-nmacro ac: nanme="i ndex"/>

Wiki markup example

{i ndex}

Page Properties Macro

The Page Properties and Page Properties Report macro work together to
enable you to show summary information from one page on a another
page. You can see examples of these two macros in action in the Decisions
Blueprint and Product Requirements blueprints.

This macro was previously known as the Metadata Details macro.

Adding the Page Properties macro to a page

The Page Properties macro uses key value pairs. The body of the macro
must be set up correctly for your information to appear in the Page
Properties Report.

To add the Page Properties macro to a page:

1.
2.

3.

In the editor, choose Insert > Other Macros > Page Properties.

In the macro body create a two column table and remove the header
row.

In the left column list your 'keys' - these will be the column headings
in your report table.

In the right column list the value for each key - these will populate the
rows in your report table.

Add a label to your page - you will need to specify this label in the
page properties report macro.

Save your page.

On this page:
® Adding the

Page
Properties
macro to a
page
Using
multiple
Page
Properties
macros on
one page
Parameter
S

Code
examples

Related pages:

®* Page

Properties
Report
Macro
Decisions
Blueprint
Product
Requireme
nts
Blueprint

I Don't forget to add a label to your page, or your page will not appear in the Page Properties Report
macro.

Next you need to add the Page Properties Report macro to another page.

Screenshot: Page Properties macro in the editor. Deadline, Current Status and Team will be column
headings in the report.
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B Page properties

Deadline 1 June
Current Status Mot Started

Team Purple Monkeys

Screenshot: The example above as it appears in the Page Properties Report

Sample space / Project ABC # Edit © Watch [2 Share &F Tools

Status Report

Created by Ewan User 36 minutes ago

Title Current Status Deadline Team
Project ABC In Progress 15 November Green Parrots
Project DEF Not Started 1 June Purple Monkeys

Using multiple Page Properties macros on one page

You can add multiple Page Properties macros on a single page, and choose whether to include all or only
specific macros in the report. You might use multiple macros because you want the information in the macro
to display in context with the rest of the page, or because you want to be able to report on individual Page
Properties macros separately.

The Page Properties macro includes an optional ID parameter that can be used to identify specific Page
Properties macros.

To show the contents of all Page Properties macros in the report:

® Add a label to the page containing the Page Properties macros.
® Specify this label in the Page Properties Report macro.

To show the contents of selected Page Properties macros in the report:

® Add a label to the page containing the Page Properties macros.
® Specify an ID in the Page Properties macro that you want to report on.
® Specify both the label and ID in the Page Properties Report macro.

Note: The Page Properties Report macro can only accept one page label, and one ID.

Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the
parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro
browser, it will be listed below in brackets (exanpl e).

Parameter Default Description
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Page Properties ID (None) Optional ID used to identify a
particular Page Properties macro
on a page. Specify this ID in the
Page Properties Report to
include summary information
from macros with this ID only.

Hidden False Determines whether the data in
the Page Properties macro will be
displayed on the current page.
This setting does not affect the
display of the detail in the Page
Properties Report macro.

Code examples

The following examples are provided for advanced users who want to inspect or edit the underlying markup
for a Confluence page.

Macro name: detai |l s
Macro body: Accepts rich text.
Storage format example

The following example contains two pieces of data - Owner and Date.

<ac: structured-nmacro ac: nane="detail s">
<ac:rich-text-body>
<t abl e>
<t body>
<tr>
<t d>Owner </ t d>
<t d>Rach Admi n</td>
</tr>
<tr>
<t d>Dat e</t d>
<td>1 May</td>
</[tr>
</t body>
</t abl e>
</ ac:rich-text-body>
</ ac: st ruct ured- macr o>

Notes

You cannot use text formatting or macros in the left column as the data in this column is used to
populate the column headings in your Page Properties Report macro.

If your table has a header row, this row will be ignored by the Page Properties Report macro. You
should remove the header row.

It is not possible to reference the metadata using the metadata key from within the page, or anywhere
else on a Confluence page.

Page Properties Report Macro

The Page Properties and Page Properties Report macro work together to
enable you to show summary information from one page on a another
page. You can see examples of these two macros in action on the Decision
and Product Requirements blueprints.

This macro was previously known as the Details Summary macro.

Adding the Page Properties Report macro to a page
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To add the Page Properties Report macro to a page: On this page:
1. Inthe editor, choose Insert > Other Macros > Page Properties ® Adding the
Report. Page
2. Enter the Label you want to report on - this is the label added to Properties
pages containing the Page Properties macro. Report
3. Restrict the report by ID, space or specify column headings or sort macro to a
order - see the Parameters table below for more details. page
4. Choose Insert. ® Reporting
on specific
Page
Properties
macros
® Parameter
S
®* Code
examples

Related pages:

® Page
Properties
Macro

® Decisions
Blueprint

® Product
Requireme
nts
Blueprint

Note: If your report is empty, check:

® You have specified the label correctly and the label appears on pages containing the Page Properties
macros.
® The Page Properties macros on each page are configured correctly.

Screenshot: Page Properties Report

Sample space / Project ABC # Edt © Watch [ Share &% Tools ~

Status Report

Created by Ewan User 36 minutes ago

Title Current Status Deadline Team
Project ABC In Progress 15 November Green Parrots
Project DEF Not Started 1 June Purple Monkeys

Reporting on specific Page Properties macros

You can add multiple Page Properties macros on a page, and choose whether to include all or only specific
macros in the report. The Page Properties macro includes an optional ID parameter that can be used to
identify specific Page Properties macros.

To show the contents of:

® All Page Properties macros in the report - specify just the label for the page.
® Selected Page Properties macros in the report - specify both the label for the page and the ID of the
particular Page Properties macro.
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Note: The Page Properties Report macro can only accept one page label, and one ID.

Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the
parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro
browser, it will be listed below in brackets (exanpl e).

Parameter

Label

Page Properties ID

Restrict to spaces

Title column heading

Columns to show

Number of items to display

Sort by

Default

(None)

(None)

(None)

Title

(None)

30

Last modified date

Description

Identifies the label to be used in
the Page Properties Report. The
report will show data from all
pages in the current space
containing a Page Properties
macro with the same label.

If not specified, the report will
show data from all Page
Properties macros on a page,
where there are multiple macros.
Specify an ID to include only data
from Page Properties macros
with the same ID.

If not specified, the report will
only show data from the current
space. You can specify a comma
separated list of space keys, or
use @all to show data from all
spaces.

The heading to display on the
first column in the report table.
This column contains links to
pages displayed by the report.
The default column heading is
Title'".

If not specified, the report will
show all columns. You can
specify a comma separated list of
columns to include.

If your column heading includes
commas, use double quotes
around the column name. If your
column heading includes quotes,
use double quotes. For example,
A column, "My ""new™"" column,
yes", Third column

Number of items to display in the
table before displaying pagination
options for additional items.

Sort the table by a specific
column heading. Enter the
column name, exactly as it
appears in the corresponding
Page Properties macro.

Select the Reverse Sort check
box to sort the table in reverse
order.
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Show Comments Count No Displays the number of
comments for each page in the
table.

Show Likes Count No Displays the number of likes for

each page in the table.

Code examples

The following examples are provided for advanced users who want to inspect or edit the underlying markup
for a Confluence page.

Macro name: det ai | ssunmrary

Macro body: None.

Storage format example

<ac: structured-nmacro ac: nane="det ai | ssummary" >
<ac: paraneter ac:nane="id">status-dev</ac: paranet er >
<ac: paranet er ac: name="sort By">Cr eat ed</ ac: par anet er >
<ac: paraneter ac:nanme="| abel ">st at us</ ac: par anet er >
</ ac: structured-macro>

Page Tree Macro

The Page Tree macro displays a dynamic, hierarchical list of pages starting from a specified parent (root) page.
It can act as a table of contents or a list of related topics. When viewing the page tree, your reader can click a
link to view the relevant page. The page's current position is highlighted in the page tree.

Note: The Page Tree macro is used in the Confluence Documentation theme, to create a navigation panel
showing a table of contents for your space. Read the instructions on Configuring the Documentation Theme.

Using the Page Tree Macro
To add the Page Tree macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of
suggested macros. Details are in Using Autocomplete.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open,
where you can edit the parameters of the macro.

Click Refresh in the Macro Browser to see the effect of changes to the macro parameters.

Macro Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the
parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro
browser, it will be listed below in brackets (exanpl e).

Parameter Default Description
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Root Page
(root)

Sort Pages By
(sort)

Include Excerpts in Page Tree
(excerpt)

The home page of the space

position

false

208

Specify the parent page for the
page tree. The tree will include all
children of the given page, plus
their children and grand-children
etc. The tree will not include the
root page itself.

Specify the page title or a special
value as follows:

® Your page title — to specify a
page name for the parent or
root of the tree. The tree will
include all children and
grand-children of the specified
root. The tree will not include
the specified root page itself.

* ‘@home' — will include all
pages under the home page of
the space (default).

* ‘@self'— will include all pages
under the current page.

* '@parent’' — will include all
pages under the parent of the
current page, including the
current page.

® '‘@none' — will include all
pages in the space, including
orphaned pages and the home
page.

Specify the order to display the
pages in the tree. This sort order is
for display purposes only. It does
not permanently re-arrange the
page order. The value may be one
of the following:

® bitwise — sort alphabetically,
for example: titlel, title10,
title2.

® creation — sort by date of
creation.

®* modified — sort by order of
date last modified.

® natural — sort in 'natural’
alphabetical order, for
example: titlel, title2, title10.

® position — sort by the default
Confluence sorting rules. If
your pages have been ordered
manually, this sort will respect
the defined order. Otherwise
the pages will be displayed in
the 'natural’ alphabetical order,
such as: titlel, title2, title10.

Select if you want the page tree to
show excerpts from each page.
The excerpts must be defined on
each page by the Excerpt macro.
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Reverse Order false
(reverse)

Include Search Box above Page false
Tree
(sear chBox)

Show Expand/Collapse Links false
(expandCol | apseAl |)

Start Depth 1
(startDepth)

Code examples

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a

Confluence page.
Macro name: pagetr ee

Macro body: None.

Storage format example

<ac: structured-nmacro ac: nane="pagetree">

<ac: paraneter ac:name="reverse">fal se</ ac: paranet er >
<ac: paraneter ac:name="sort">natural </ ac: par anet er >
<ac: paraneter ac:nane="root">

<ac: link>

<ri:page ri:content-title="Page Nane"/>

</ac:link>
</ ac: par anet er >
<ac: paranet er ac:nane="start Depth">3</ac: par anet er >
<ac: paramet er ac: nane="excerpt">true</ac: paraneter>

<ac: par amnet er ac: nane="sear chBox">true</ac: par anet er >

Select to show the pages in
reverse (descending) natural
order. Must be used in
combination with the Sort Pages
By parameter.

Select if you want to include a
search box above the page tree.
The search box allows your
readers to search within the page
tree for the specified value.

Select if you want to display the
‘expand all' and 'collapse all' links
at the top of your page tree. Your
readers can click these links to
open or close all branches of the
tree at once.

Available values in wikimarkup
and storage format:

® true — Show the 'expand all
and 'collapse all' options.

* fal se — Do not show the
options.

Enter any number greater than 0
to set how many levels of children
the tree should show when it
opens for the first time.

<ac: par anet er ac: name="expandCol | apseAl | ">t rue</ ac: par anet er >

</ ac: structured-nmacro>

Wiki markup example
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{ pagetr ee: r oot =Page
Nare| sort =nat ur al | excer pt =true| rever se=f al se| st art Dept h=3| expandCol | apseAl | =t rue| se
ar chBox=t rue}

Sample Page Tree

This page is a sample, used to demonstrate the Pagetree macro.
For more information, take a look at the main page on the Page Tree Macro.

What you need to type What you will get

{pagetree:root=@parent|expandCollapseAll=false}

Another Sample Page Tree
We're using this page to demonstrate the Pagetree macro.

For more information, take a look at the main page on the Page Tree Macro.

What you need to type What you will get

{pagetree:root=@parent|expandCollapseAll=true} Expand all Collapse all

Sample Page Tree 2

This is another sample page, used to demonstrate the Pagetree macro.
For more information, take a look at the main page on the Page Tree Macro.

What you need to type What you will get

{pagetree:root=@parent|expandCollapseAll=true} Expand all Collapse all

Page Tree Search Macro

Using the Page Tree Search macro, you can add a search box to your Confluence page. When a viewer enters
a search term, Confluence will search a hierarchy of pages starting from a specified parent (root) page and
return the search results.

You can also add a search box as part of a dynamic page tree, which looks like a table of contents. See the Pag
e Tree macro .

Using the Page Tree Search macro

To add the Page Tree Search macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of
suggested macros. Details are in Using Autocomplete.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open,
where you can edit the parameters of the macro.

Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the
parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro
browser, it will be listed below in brackets (exanpl e).
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Parameter Default Description
Name of Root Page none The name of the root page whose
(root) hierarchy of pages will be

searched by this macro. If this not
specified, the root page is the
current page.

Note: Unlike the Page Tree
macro, the Page Tree Search
macro does not accept the special
values that start with an @ sign,
such as @home or @self.

Code examples

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a
Confluence page.

Macro name: paget r eesear ch

Macro body: None.

Storage format example

<ac:structured-nmacro ac: name="pagetreesearch">
<ac: paraneter ac:name="root">M/ page nane</ac: paraneter >
</ ac: structured-macr o>

Wikimarkup example

{paget reesearch: root =My page nane}

Panel Macro
The Panel macro displays a block of text within a customisable panel, like a text box.
Handy hint: You can use panels within columns, in table cells and in the sections defined by page layouts.

Here is an example of a Panel macro:

My Title

Using the Panel macro

To add the Panel macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of
suggested macros. Details are in Using Autocomplete.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open,
where you can edit the parameters of the macro.

Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the
parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro
browser, it will be listed below in brackets (exanpl e).
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Parameter

Panel Title
(title)

Border Style
(border Styl e)

Border Colour
(bor der Col or)

Border Pixel Width (Value Only)
(bor der W dt h)

Background Colour
(bgCol or)

Title Background Colour
(titleBGCol or)

Title Text Colour
(titleColor)

Code examples

Default

none

solid

212

Description

The title of the panel. If specified,
this title will be displayed in its own
title row.

The style of the panel's border.
Accepted values are sol i d, dash
ed and other valid CSS border
styles.

The colour of the panel's border.
Colours can be specified as HTML
colour names or hexadecimal
codes.

The width of the panel's border (in
pixels).

The background colour of the
panel. Colours can be specified as
HTML colour names or
hexadecimal codes.

The background colour of the title
row of the panel. Colours can be

specified as HTML colour names
or hexadecimal codes.

The colour of the text in the title
row of the panel. Colours can be
specified as HTML colour names
or hexadecimal codes.

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a

Confluence page.
Macro name: panel

Macro body: Accepts rich text.

Storage format example

<ac: structured-macro ac: nanme="panel ">
<ac: par anet er ac: nanme="bgCol or">#72bc72</ ac: par anet er >

<ac: parameter ac:nane="titl eBGCol or">#00a400</ ac: par anet er >

<ac: paraneter ac:name="title">My title</ac:paraneter>

<ac: par anet er ac: nanme="bor der Styl e">dashed</ ac: par anet er >

<ac: par anmet er ac: nane="bor der Col or " >bl ue</ ac: par anet er >
<ac: parameter ac:nane="titl eCol or">white</ac: paraneter>

<ac:rich-text-body>

<p>A formatted panel </ p>

</ac:rich-text-body>
</ ac: structured-macro>

Wiki markup example
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{panel :title=My

title| border Styl e=dashed| bor der Col or =bl ue| titl eBGCol or =#00a400| ti t| eCol or =whi t e| bgC

ol or =#72bc72}
A formatted panel

{panel }

PDF Macro

The PDF macro displays the content of a PDF document on a page. First attach the document to a Confluence

page, then use the macro to display the document.

For details, see the View File Macro.

Code examples

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a

Confluence page.
Macro name: vi ewpdf

Macro body: None.

Parameter name Required
name Yes
page No

Storage format example

<ac: structured-nmacro ac: nanme="vi ewpdf ">
<ac: par anet er ac: nanme="nanme">

<ri:attachment

</ ac: par anet er >

</ ac: structured- macr o>

Wiki markup example

{vi ewpdf : page=Docs| nane=My docunent . pdf}

Popular Labels Macro

Default

(None.)

The page containing the
macro

ri:filename="M/_docunent. pdf"/>

Parameter description
and accepted values

The file name of the PDF
document to be
displayed. The document
must be attached to a
page on your Confluence
site.

The name of a
Confluence page to
which the PDF document
is attached.

The Popular Labels macro displays the most popular labels used throughout your Confluence site or within a
space. A popular label is a label that has been added to many pages.
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Using the Popular Labels Macro
To add the Popular Labels macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of
suggested macros. Details are in Using Autocomplete.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open,
where you can edit the parameters of the macro.

Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the
parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro
browser, it will be listed below in brackets (exanpl e).

Parameter Default Description

Number of Labels to Display 100 Specifies the total number of

(count) labels to display in the heatmap.

Restrict Labels to this Space none Restricts the list of popular labels

Key to the specified space.

(spaceKey)

Style of Labels list ® |ist — displays the popular

(style) labels as a bulleted list,
ordered by popularity (highest
first).

® heatmap — displays the
popular labels using different
font sizes for each label
depending on the label's
popularity, ordered by label
names.

Code examples

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a
Confluence page.

Macro name: popul ar -1 abel s

Macro body: None.

Storage format example

<ac: structured-nmacro ac: name="popul ar - | abel s" >
<ac: paramet er ac: nane="count">20</ac: par anet er >
<ac: paranmeter ac:nanme="spaceKey">
<ri:space ri:space-key="ds"/>
</ ac: par anet er >
</ ac: structured- nacr o>

Wikimarkup example

{popul ar - abel s: styl e=heat map| count =20| spaceKey=ds}

Profile Picture Macro
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The Profile Picture macro displays a user's profile picture on a page.

® When viewing the page, mouse-over the picture to see the Hover Profile for the user.
® When editing the page, click on the picture and choose View User Profile to see the profile for the user.

-

-

B
-}

Edit ‘iew User Profile Remove

The Profile Picture macro is useful for such tasks as creating Team Pages that show all members of a project
team.

Using the Profile Picture Macro
To add the Profile Picture macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of
suggested macros. Details are in Using Autocomplete.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open,
where you can edit the parameters of the macro.

Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the
parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro
browser, it will be listed below in brackets (exanpl e).

Parameter Default Description
User none The username, or real name, of a
Confluence user.
Code examples

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a
Confluence page.

Macro name: profil e-picture

Macro body: None.

Storage format example

<ac:structured-macro ac: name="profil e-picture">
<ac: paraneter ac:name="User">
<ri:user ri:userkey="12345678912345678912345"/ >
</ ac: par anet er >
</ ac: structured- macr o>

Wiki markup

Wiki markup is not available for this macro. You cannot add this macro via wiki markup.
Recently Updated Dashboard Macro

The Recently Updated Dashboard macro displays a list of the most recently changed content within Confluence.
It is similar to the Recently Updated macro but is intended for use on the Confluence dashboard.
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Using the Recently Updated Dashboard macro
To add the Recently Updated Dashboard macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of
suggested macros. Details are in Using Autocomplete.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open,
where you can edit the parameters of the macro.

Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the
parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro
browser, it will be listed below in brackets (exanpl e).

Parameter Default Description
Space(s) The space which contains the Filter content by space. The macro
(spaces) page on which the macro is added  will display only the pages etc

which belong to the space(s) you
specify here. You can specify one
or more space keys, separated by
commas. *' means all spaces.

Include these Content Types all types Filter content by type. You can
Only specify one or more types,
(types) separated by commas. Available

types are: page, bl ogpost or ne
ws, spacedesc, attachnent, co
nment , mai |, useri nf o.

Label(s) none Filter content by label. The macro

(1 abel s) will display only the pages etc
which are tagged with the label(s)
you specify here. You can specify
one or more labels, separated by
commas.
Note: If there are no pages
matching any of the specified
labels, then Confluence will ignore
the labels and will list all recently
updated pages, as well as
showing a message, "These labels
don't exist and were ignored: xxx ".
This unexpected behaviour is
noted in issue

[*] CONF-13860 - recently-updated-dash
board macro doesn't return an empty
result when no pages match the specified
label(s) oreN

User(s) all users Filter by username of the user who

(users) updated the content. The macro
will only display content created
and updated by the user(s) you
specify here. You can specify one
or more usernames separated by
commas.
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Width of Table 100% Specify the width of the macro

(wi dt h) display, as a percentage of the
window width.

Show User Profile Pictures false Select whether profile pictures of

(showProfil ePic) the users who updated the content

are displayed.

Code examples

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a
Confluence page.

Macro name: r ecent | y- updat ed- dashboar d
Macro body: None.

Storage format example

<ac:structured-macro ac: nane="recent| y-updat ed- dashboar d">
<ac: paraneter ac:nanme="spaces">
<ri:space ri:space-key="ss"/>
</ ac: par anet er >
<ac: paraneter ac:nane="users">
<ri:user ri:userkey="12345678912345678912345"/ >

</ ac: par anet er >

<ac: paraneter ac:name="w dt h">50%/ ac: par anet er >

<ac: paraneter ac:nanme="| abel s">choc</ ac: par anet er >

<ac: paranet er ac: nane="types">page</ ac: par anet er >
</ ac: structured- nacr o>

Wiki markup example

{recent!| y-updat ed- dashboar d: spaces=ds| user s=adm n| wi dt h=50% showPr of i | ePi c=true| | ab
el s=choc| t ypes=page}

Recently Updated Macro

The Recently Updated macro displays a list of the most recently changed content within Confluence.

Using the Recently Updated Macro
To add the Recently Updated macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of
suggested macros. Details are in Using Autocomplete.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open,
where you can edit the parameters of the macro.

Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the
parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro
browser, it will be listed below in brackets (exanpl e).
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Parameter

Author(s) by username
(aut hor)

Default

None specified. That is, display all
content

Description

Filter the results by author. The
macro will display only the pages
etc which were last modified by
the author(s) you specify here.

You can specify one or more
authors, separated by a comma or
a space.

For example: j sm t h, j br own

To include content from one user,
but exclude from another user: j s
nmth,!jbrown
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Space(s)
(spaces)

@el f

That is, the space which contains
the page on which the macro is
used

219

This parameter allows you to filter
content by space. The macro will
display only the pages etc which
belong to the space(s) you specify
here.

You can specify one or more
space keys, separated by a
comma or a space.

® To exclude contentin a
specific space, put a minus
sign (-) immediately in front of
that space key. For example: If
you specify a space key of - BA
DSPACE you will get only
content which is not in the
BADSPACE.

® To indicate that the results mu
st come from a specific space,
put a plus sign (+) immediately
in front of that space key. For
example: If you specify a
space key of +GOCDSPACE you
will get only content in
GOODSPACE. (Note that this
is not particularly useful,
because each content item
belongs to one space only. If
you put a plus sign next to one
space key and list other space
keys too, the other space keys
will be ignored.)

Special values:

® @el f — The current space.

® @ersonal — All personal sp
aces.

* @l obal — All site spaces.

® @avorite— The spaces
you have marked as favourite.

® @avourite —The same as
@ avori t e above.

® @l | — All spaces in your
Confluence site.

¢ * _The same as @l | above

When specifying a personal

space, remember to use the tilde
(=) sign in front of the username,
such as ~j bl oggs or ~j bl oggs@
exanpl e. com

Created in 2014 by Atlassian. Licensed under a Creative Commons Attribution 2.5 Australia License.


http://creativecommons.org/licenses/by/2.5/au/

Confluence 5.5 Documentation

Label(s)
(1 abel s)

Width of Table
(wi dt h)

None specified i.e. display all
content

100%

Filter the results by label. The
macro will display only the pages
etc which are tagged with the
label(s) you specify here.

You can specify one or more label
values, separated by a comma or
a space.

® To exclude content which
matches a given label, put a
minus sign (-) immediately in
front of that label value. For
example: If you specify a label
value of - badpage you will get
only content which is not
labelled with 'badpage’.

® To indicate that the results mu
st match a given label value,
put a plus sign (+) immediately
in front of that label value. For
example: If you specify a label
value of +super page, +good
page you will get only content
which has at least two labels,
being 'superpage' and
‘goodpage’.

The labels parameter only applies
to the page and bl og content

types.
Specify the width of the macro

display, as a percentage of the
window width.
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Include these Content Types All types This parameter allows you to filter
Only content by content type. The
(types) macro will display only the content

of the type you specify here.

You can specify one or more
types, separated by a comma or a
space.

To exclude content of a given
content type, put a minus sign (-)
immediately in front of that content
type. For example: If you specify a
content type of - bl ogpost you
will get pages and all other content
except for blog posts.

Available values:

® page — Pages.

® bl ogpost or news — Blog
posts, also known as news
items.

¢ commrent — Comments on
pages and blog posts.

® attachnment — Attachments.

® st atus — Status updates ma
de by other users.

Maximum Number of Results 15 Specify the maximum number of

(max) results to be displayed. If this
parameter is omitted, then a
maximum of 15 results are
displayed. The theoretical
maximum value that this
parameter can accept is 2 to the
power of 31, minus 1 (or
2147483647), though this has
been limited to 200 in the code, for
performance reasons. More details
are here.
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theme
(t hene)

Show User Profile Pictures
(showPr of i | ePi c)

Hide Title
('hi deHeadi ng)

Notes

conci se

fal se

False

222

Choose the appearance of this
macro:

® conci se — the default list,
showing the names of pages
which were updated or
commented on, the users who
made the page modifications
and time when the
modifications occurred.

® soci al — lists recent
modifications in reverse
chronological order, but groups
them by user into short time
segments. A 'sub’ list appears
within each user's time
segment, showing the names
of pages which they updated
or commented on and time
when these modifications
occurred.

® sidebar — lists recent
updates in reverse
chronological order, showing
the names of pages which
were updated or commented
on and time when the page
modifications occurred. This
theme does not show
authorship.

Specify showPr of i | ePi c=t rue
to display the profile pictures of the
users who updated the content.

Determines whether the macro
hides or displays the text 'Recently
Updated' as a title above the list of
content. Only available in
wikimarkup and storage format.

Accepted values:

® true —Title is hidden.
* fal se — Title is shown.

® The Recently Updated Dashboard macro is similar to this macro, but is intended for display on the

Confluence dashboard.

® |f you would like to change the wording displayed by the Recently Updated macro, please refer to the

document on modifying the Confluence interface text.

Code examples

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a

Confluence page.

Macro name: recent | y- updat ed

Macro body: None.

Storage format example
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<ac: structured-nmacro ac: nanme="recent!|y-updated">
<ac: par aneter ac: nane="spaces">
<ri:space ri:space-key="ss"/>
</ ac: par anet er >
<ac: par aneter ac: nane="aut hor">
<ri:user ri:userkey="12345678912345678912345"/ >
</ ac: par anet er >
<ac: paraneter ac:nane="users"/>
<ac: par aneter ac: nane="nmax">10</ ac: par anet er >
<ac: paramet er ac:nane="w dt h">50%/ ac: par anet er >
<ac: paranet er ac: nanme="t hene" >si debar </ ac: par anet er >
<ac: paranet er ac: nanme="| abel s">choc</ ac: par anet er >
<ac: paraneter ac:nane="types">page</ ac: par aneter>
</ ac: struct ured- nacr o>

Wikimarkup example

{recent|y-updat ed: spaces=ds| aut hor =admi n| max=10| hi deHeadi ng=t r ue| wi dt h=50% t hene=si
debar | showProfil ePi c=true| | abel s=choc| t ypes=page}

Recently Used Labels Macro

The Recently Used Labels macro displays a list of the labels that have been most recently added to a page, blog
post or attachment. You can define the number of labels to be displayed and the scope (the current space, your
personal space or site spaces, also known as 'global’ spaces).

Using the Recently Used Labels macro
To add the Recently Used Labels macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of
suggested macros. Details are in Using Autocomplete.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open,
where you can edit the parameters of the macro.

Parameters of this macro

Parameters are options that you can set to control the content or format of the macro output. Where the
parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro
browser, it will be listed below in brackets (exanpl e).

Parameter Default Description
Number of Labels to Display 10 Specifies the total number of
(count) labels to display in the list.
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Scope for Retrieving Labels global Specifies the scope of labels to be
(scope) displayed in the list. Valid values
include:

® global — covers all site
spaces (non-personal) in the
Confluence installation.

® space — the current space.
personal — your own
personal space.

List Style list ® |ist — displays the list of labels
(style) horizontally.
® table —includes additional
information such as the page
to which the label was added
and the user who added it.

Table Title none Adds a title to the top of the list in

(title) table style. Titles are only visible
when the List Style parameter
has been set to table.

Code examples

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a
Confluence page.

Macro name: recent | y-used- 1| abel s

Macro body: None.

Storage format example

<ac:structured-macro ac: name="recentl|y-used-| abel s">
<ac: paraneter ac:nane="title">M/ title</ac:paraneter>
<ac: par aneter ac: nane="scope" >space</ ac: par anet er >
<ac: paraneter ac: nanme="styl e">t abl e</ ac: par anet er >
<ac: paramet er ac: nane="count">20</ac: par anet er >
</ ac: structured- macro>

Wiki markup example

{recently-used-|abels:title=My title|scope=space| styl e=tabl e| count =20}

Related Labels Macro

The Related Labels macro lists all labels from every page which has one or more labels in common with the
current page.

Using the Related Labels Macro

To add the Related Labels macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of
suggested macros. Details are in Using Autocomplete.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open,
where you can edit the parameters of the macro.
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Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the
parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro
browser, it will be listed below in brackets (exanpl e).

Parameter Default Description

Restrict to these Labels none Specify the labels for which you

(1 abel s) want to view related labels. For
example, docunent ati on, ny: s
tuff.

Code examples

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a
Confluence page.

Macro name: related-labels

Macro body: None.

Storage format example

<ac:structured-macro ac: name="rel at ed-| abel s">
<ac: paraneter ac: nanme="| abel s">choc, cake</ ac: par anet er >
</ ac: structured-nmacro>

Wiki markup example

{rel at ed- | abel s: | abel s=choc, cake}

RSS Feed Macro

The RSS Feed macro embeds an RSS feed on a page. It can display the contents of external feeds, or of
internal feeds generated by Confluence. To display blog posts or to list recently updated pages in a space, use
the Feed Builder to create an internal feed, then render it using this macro.

(D CAUTION: Including unknown HTML inside a webpage is dangerous.
HTML inside an RSS feed can contain active scripting components. This means that it would be
possible for a malicious attacker to present a user of your site with script that their web browser would
believe came from you. Such code could be used, for example, to steal a user's authentication cookie
and give the attacker their Confluence login password.

The RSS Feed macro may be disabled by your Confluence administrator. Also, your Confluence administrator
can define a whitelist of trusted URLs. You will see an error message on the Confluence page, if the included
URL is not in the whitelist.

Using the RSS Feed macro
To add the RSS Feed macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of
suggested macros. Details are in Using Autocomplete.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open,
where you can edit the parameters of the macro.
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Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the
parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro
browser, it will be listed below in brackets (exanpl e).

Parameter Default Description

RSS Feed URL none The URL of the RSS feed link you
(url) want to show.

Maximum Number of Entries 15 Limit the number of entries

(‘max) displayed.

Show Item Titles Only false Show only the titles of the news
(showTi tl esOnl y) items, not the content.

Show Name/Title of RSS Feed true Hide the feeds title bar.
(titleBar)

How up to date is the feed?
By default, the RSS Feed macro caches the feed results for 60 minutes before fetching the data again.

If you wish to change the default caching, use the Cache macro to define how often the RSS Feed macro
fetches the feed updates. You will need to install the Cache plugin onto your Confluence site.

What happens to a page containing a disallowed URL?

Your Confluence Administrator can set up a whitelist of allowed URLSs. If this is the case, you may see an error
on the pages which contain the RSS Feed macro.

A user can add the RSS Feed macro or the HTML-include macro to a Confluence page. The macro code
includes a URL from which the content is drawn. When the page is displayed, Confluence will check the URL
against the whitelist. If the URL is not allowed, Confluence will display an error message on the page.

The error message says that Confluence "could not access the content at the URL because it is not from an
allowed source" and displays the offending URL. If the person viewing the page is a Confluence Administrator,
they will also see a link to the Administration page where they can configure the URL whitelist.

Here is an example of the error message, including the link shown only to Confluence Administrators:

Could not access the content at the URL because it is not from an allowed source.
http://ffeathers wordpress.com

Confiqure whitelist =

Here is an example of the error message, but without the link.

Could not access the content at the URL because it is not from an allowed source.
http:{fffeathers wordpress.com

You may contact your site administrator and request that this URL be added to the list of allowed sources.

Authentication
Privatefeeds from external sites

RSS feeds which require authentication cannot be accessed using the RSS Feed macro.

Accessing internal HTTPS feeds
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This applies only to Confluence instances which have enabled HTTPS for all content. If your site is fully HTTPS,
the RSS Feed macro cannot access internal feeds. To enable the RSS Feed macro to access internal feeds
without affecting your HTTPS setup, enable local-only HTTP access:

1. Shut down Confluence.

2. Consult the SSL guide to enable HTTP access to Confluence. You'll want to ensure that you have an
HTTP connector and an SSL connector, both commented in. This means that Confluence will be
accessible via both HTTP and HTTPS. However, you should not have a redirect port, nor rules in web.xml
to redirect all traffic.

3. Instead of using web.xml to redirect traffic, insert a firewall rule to redirect all HTTP requests not from the
Confluence server to the equivalent HTTPS URL. This ensures that users will only be able to access
Confluence via HTTPS, as intended. If you have still left HTTP access for attachments enabled (to avoid
the IE download bug) you must selectively enable those URLS as well.

4. Modify your Confluence RSS Feed macro feed link to use the HTTP URL, and restart Confluence.

Enabling and disabling the RSS Feed macro
The RSS Feed macro is a module of the Confluence HTML Macros plugin.
To enable or disable the RSS Feed macro:

1. Enable the Confluence HTML Macros plugin by following the instructions in Enabling HTML macros.
2. In the plugin module list of the HTML macros, find the RSS (rss-xhtml) module and hover your cursor
over it to enable or disable it.

Code examples
Macro name: rss

Macro body: None.

Storage format example

<ac: structured-macro ac: nanme="rss">
<ac: paraneter ac:name="nmax">10</ac: par anet er >
<ac: paramnet er ac: nanme="showTit| esOnly">true</ac: paranet er>
<ac: paraneter ac:nane="url">
<ri:url ri:value="http://myblog.comfeed"/>
</ ac: par anet er >
<ac: paraneter ac:nane="titleBar">fal se</ac: paraneter>
</ ac: structured- nacr o>

Wikimarkup example

{rss: max=10| showTi t | esOnl y=true| url =http:// nybl og. conl feed|titl| eBar=fal se}

Search Results Macro

The Search Results macro searches your Confluence site based on search terms specified in the macro
parameters, and displays the results on the wiki page.

Using the Search Results macro
To add the Search Results macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of
suggested macros. Details are in Using Autocomplete.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open,
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where you can edit the parameters of the macro.

Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the
parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro
browser, it will be listed below in brackets (exanpl e).

Parameter Default Description

Search Terms none The search terms which this

(query) macro will use to generate its
results.

You can refine your search query
by using operators such as 'AND'
and 'OR'. For example: my_query
1 AND ny_query2

For more information, take a look
at the documentation on the Confl
uence search syntax.

Maximum Number of Results 10 Set a limit to the number of search
(maxLimt) results displayed.
Restrict to this Space Key all Start typing the space name to find

the space, or specify the key of the
space you want to search in. Note
that the key is case sensitive.

Content Type all Specify the content type. The

(type) content types are: page, commen
t, blogpost, attachment, userinf
0 (the content of user profiles only)
and spacedesc (the content of
space descriptions only).
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Last Modified all Specify a period of time in weeks,

(1 ast Modi fi ed) days, hours and/or minutes, to see
the content modified within that
time frame.

These are the values you can use:

®* w=weeks
®* d =days

® h =hours

® m= minutes

For example:

® 2h 35m
¢ 3d 30m

Notes:

® If no time category is specified,
Confluence assumes minutes.

® |f you specify more than one
time period (for example,
weeks and days), you must
separate the periods with a
space. You can put them in
any order.

®* The time categories are not
case sensitive. For example, '4
d' is the same as '4D.

Restrict to this Username all Specify the username of a
(contributor) Confluence user, to show only
content created or updated by that
user.
Notes

Permissions: When a user views the page containing the Search Results macro, the search results will show
only pages and other content types for which the user has 'View' permission.

Code examples

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a
Confluence page.

Macro name: sear ch

Macro body: None.

Storage format example
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<ac: structured-nmacro ac: nane="search">
<ac: paramneter ac:nane="|ast Modi fi ed">3w</ ac: par anet er >
<ac: paranet er ac: name="query">choc</ ac: par anet er >
<ac: paraneter ac:name="contributor">
<ri:user ri:userkey="1235678912345678912345678912345"/>
</ ac: par anet er >
<ac: paramnet er ac: nanme="maxLi m t">10</ac: par anet er >
<ac: paraneter ac:nanme="type">page</ac: paranet er >
<ac: par anet er ac: nane="spacekey">
<ri:space ri:space-key="ss"/>
</ ac: par anet er >
</ ac: structured- macr o>

Wiki markup example

{search: | ast Modi fi ed=3w| quer y=choc| cont ri but or =adm n| maxLi m t =10| t ype=page| spacekey
=ds}

Section Macro

Used with the Column macro to define columns on a page. See Working with page layouts and columns and
sections.

Code examples

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a
Confluence page.

Macro name: secti on

Macro body: Rich text, consisting of one or more Column macros.

Parameter name Required Default Parameter description
and accepted values

bor der No False If the value is t r ue, the
columns in this section
will have a dashed
border.

Storage format example

The following example shows a section and column macro together.
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<ac:structured-nmacro ac: nane="section">
<ac: paramet er ac: nane="border">true</ ac: paranet er >
<ac:rich-text-body>
<ac: structured-macro ac: nanme="col um" >
<ac: paranet er ac: nanme="wi dt h">100px</ ac: par anet er >
<ac:rich-text-body>
<p>This is the content of <strong>colum 1</strong>.</p>
</ac:rich-text-body>
</ ac: structured- macr o>
<ac: structured-macro ac: nane="col um" >
<ac:rich-text-body>
<p>This is the content of <strong>col umm 2</strong>.</p>
</ac:rich-text-body>
</ ac: structured- macr o>
</ac:rich-text-body>
</ ac: structured- nacr o>

Wiki markup example

{secti on: border=true}

{col um: wi dt h=100px}

This is the content of *columm 1*.
{col um}

{col um}

This is the content of *columm 2*.
{col um}

{section}

Space Attachments Macro

Displays a list of attachments belonging to the current space. See Displaying a List of Attachments for more
information on using this and other attachment macros.

Code examples

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a
Confluence page.

Macro name: space- attachnments

Macro body: None.

Parameter name Required Default Parameter description
and accepted values
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showFi | ter No true Determines whether or
not the filter panel is
shown. If you select this
option, people viewing
the page will be able to
filter the list of
attachments by file type
(extension) and by label.

Accepted values:

® true— Macro
displays the filter
panel.

® fal se — Macro does
not display the filter
panel.

space No Current space. Determines the
Confluence space
containing the
attachments that the
macro will display.

Storage format example

<ac:structured-nmacro ac: nane="space-attachnents">
<ac: paraneter ac:nane="showFi |l ter">fal se</ac: paranet er >
<ac: paramet er ac: nane="space">
<ri:space ri:space-key="ds"/>
</ ac: par anet er >
</ ac: structured- macr o>

Wiki markup example

{space-attachnments: showFi | t er =f al se| space=ds}

Space Details Macro

The Space Details macro displays the details of a Confluence space, including the space name, description, and
more.

Using the Space Details macro
To add the Space Details macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of
suggested macros. Details are in Using Autocomplete.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open,
where you can edit the parameters of the macro.

Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the
parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro
browser, it will be listed below in brackets (exanpl e).
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Parameter Default Description
Width of Table 100% The width of the space details
(w dt h) table, specified as a percentage

(%) of the page width.

Code examples

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a
Confluence page.

Macro name: space-detail s

Macro body: None.

Storage format example

<ac:structured-nmacro ac: nane="space-detail s">
<ac: paramet er ac:nane="w dt h">50%/ ac: par anet er >
</ ac: structured- nacr o>

Wiki markup example

{space-detail s: wi dt h=50%

Space Jump Macro

This page describes the Space Jump macro, which is provided with the Documentation theme. You can use
space jumping to link from a page in one space to a page with the same name in another space, without
knowing the name of the page when you create the link.

1 Advance warning of plans to merge Documentation theme with the default theme
This is an advance notice that we plan to merge the functionality of the Confluence Documentation
theme with the Confluence default theme. We do not yet have a specific date for this plan, and we are
interested in your feedback. The new default theme, introduced with Confluence 5.0, includes a sidebar
with contextual navigation. Our plan is to include features from the Documentation theme in the default
theme, and then remove the Documentation theme from Confluence.

If you are interested in this change and would like to give us feedback, please add a comment on this
blog post: Advance warning of plans to merge Documentation theme with the default theme. We are
especially interested to know which features of the Documentation theme you use and value the most.

The Space Jump macro inserts a link onto the page. When the reader clicks the link, they will jump to a page
that has the same name in another space. You specify the space when you insert the Space Jump macro.

Example: We use the Space Jump macro to put a standard message at the top of our archive spaces, telling
people that they're reading an old version of the documentation and letting them jump quickly to the same page
in the latest documentation. See the words 'this page in the current documentation' in the screenshot below.

Screenshot: One way of using the Space Jump macro

This documentation relates to an earlier version of Confluence.
Viiew this page in the current documentation or visit the current documentation home.

% Configuring the Documentation Theme
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Using the Space Jump macro
To add the Space Jump macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of
suggested macros. Details are in Using Autocomplete.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open,
where you can edit the parameters of the macro.

Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the
parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro
browser, it will be listed below in brackets (exanpl e).

Parameter Default Description

Space None The space key that contains a
page with the same page title that
you want the link to jump to.
Space keys are case-sensitive.

Alias None The text to display as the
hyperlinked text. If you do not
supply an alias, Confluence will
display the page name.

Notes
What happens if there is no page with the same name in the target space?

For the space jump to work, the target space must contain a page with the same name as the page that renders
the Space Jump macro. If the target space does not contain such a page, you will see a broken link. Confluence
handles this in its usual manner: the link is coloured red. If you click the link, Confluence offers to create the
page for you.

Can | use the Space Jump macro in any space?

Yes. You can use the Space Jump macro in any space, even if that space is not currently using the
Documentation theme. Provided that the Documentation theme plugin and its components are installed and
enabled on your Confluence site, the Space Jump macro is available in any space.

Code examples

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a
Confluence page.

Macro name: spacej unp

Macro body: None.

Storage format example

<ac: structured-nmacro ac: name="spacej unp" >
<ac: paraneter ac:nanme="alias">M/ Space</ac: paraneter>
<ac: paraneter ac: nane="space">
<ri:space ri:space-key="SS"/>
</ ac: par anet er >
</ ac: structured- nacr o>

Created in 2014 by Atlassian. Licensed under a Creative Commons Attribution 2.5 Australia License.


http://creativecommons.org/licenses/by/2.5/au/

Confluence 5.5 Documentation 235

Wiki markup example

{spacej unp: al i as=ny | i nk| space=ds}

Spaces List Macro

The Spaces List macro displays a list of spaces, similar to the list of spaces seen on the dashboard.

Using the Spaces List macro

To add the Spaces List macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of
suggested macros. Details are in Using Autocomplete.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open,
where you can edit the parameters of the macro.

Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the
parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro
browser, it will be listed below in brackets (exanpl e).

Parameter Required? Default Description

Scope of spaces no all The view from which
spaces are listed.
Available options are:

® all — All spaces in the
Confluence
installation.

® category — Spaces
grouped according to
space categories.

* favourite — Spaces
which you have
added to your
favourites list.

®* new — New spaces
which have been
created within the last
7 days.

This parameter is
unnamed in wikimarkup
and storage format.

Width of List no 100% The width of the spaces

(wi dt h) list, specified as a
percentage (%) of the
window width.

Notes

There is a bug in this macro that prevents people from selecting a space category. For details, please refer to
this issue: [#] CONF-26597 - Changing category in Space List macro generates wrong URL = RESOLVED
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Code examples

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a
Confluence page.

Macro name: spaces

Macro body: None.

Storage format example

<ac: structured-macro ac: nanme="spaces">
<ac: paranet er ac:nane="w dt h">80%/ ac: par anet er >
<ac: paraneter ac:name="">favourite</ac: paraneter>
</ ac: structured- nmacr o>

Wiki markup example

{spaces: favourite|w dt h=80%

Status Macro

The Status macro displays a coloured lozenge (a rounded box) that is useful for reporting project status. You
can choose the colour of the lozenge and the text that appears inside the lozenge. The macro also displays its
current status in the editor, and you can change the status directly in the editor.

ALL GOOD!

Screenshot: Click on the Status macro lozenge to change the status.

ALL GOOD

Edit ALL GOOD [ ] B P remove

Using the Status macro
To add the Status macro to a page using the Macro Browser:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of
suggested macros. Details are in Using Autocomplete.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open,
where you can edit the parameters of the macro.
Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the
parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro

browser, it will be listed below in brackets (exanpl e).

Parameter Default Description
Colour Grey The colour of the lozenge. The
(col our) following colours are available: Gr

ey, Red, Yellow, Green and Blue.
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Title The colour that you select. The text that will appear inside the

(title) lozenge. If you do not specify any
text, the title will be the colour of
the lozenge, that is 'Grey’, 'Red’,
'Yellow', 'Green' or 'Blue’.

Use outline style False The style of the lozenge and its
(subtle) border. The default style lozenge
is a solid background colour with
white text. The outline style
lozenge is white with a coloured
border and coloured text as shown
here
ALL GOOD!

Code examples

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a
Confluence page.

Macro name: st at us

Macro body: None.

Storage format example

<ac:structured-nmacro ac: name="stat us">
<ac: par anet er ac: name="col our">G een</ ac: par anet er >
<ac: paraneter ac:nane="title">On track</ac: paraneter>
<ac: parameter ac:nane="subtl e">true</ac: paraneter>
</ ac: structured- nacr o>

Wiki markup example

{status:colour=Geen|title=On track]|subtle=true}

Table of Contents Macro

The Table of Contents macro scans the headings on the current Confluence page to create a table of contents
based on those headings. This helps readers find their way around lengthy pages, by summarising the content
structure and providing links to headings.

Using the Table of Contents macro
Hint: For quick access from the editor toolbar, choose Insert > Table of Contents.
To add the Table of Contents macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of
suggested macros. Details are in Using Autocomplete.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open,
where you can edit the parameters of the macro.

Macro parameters

Parameters are options that you can set to control the content or format of the macro output. Where the
parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro
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browser, it will be listed below in brackets (exanpl e).

Parameter Default
Output Type list
(type)

Display Section Numbering clear
(outline)

List Style disc
(style)

Heading Indent
(i ndent)

238

Description

® |ist — produces a typical
list-type table of contents.

® flat — produces a horizontal
menu-type series of links.

Select the check box to apply
outline numbering to your
headings, for example: 1.1, 1.2,
1.3.

Select the style of bullet point for
each list item. You can use any
valid CSS style. For example:

® none — no list style is
displayed

® circle— theliststyleis a
circle

® di sc — the list style is a filled
circle. This is the typical bullet
list, and is used for this

example list.

® squar e —the list style is a
square

® deci mal —thelistis

numbered (1, 2, 3, 4, 5)

® | ower - al pha —the listis
lower-case, alphabetised (a, b,
c, d, e)

® | ower - r oman — the list style
is lower roman numerals (i, ii,
iii, iv, v, vi)

® upper-roman — the list style
is upper roman numerals (1, 11,
I, 1v, V, VI)

Sets the indent for a list according
to CSS quantities. Entering 10px
will successively indent heading
groups by 10px. For example,
level 1 headings will be indented
10px and level 2 headings will be
indented an additional 10px.
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Separator
(separator)

Minimum Heading Level
(minLevel)

Maximum Heading Level
(maxLevel)

Include Headings
(i ncl ude)

Exclude Headings
(excl ude)

Printable
(printable)

CSS Class Name
(cl ass)

brackets

checked

This parameter applies to flat lists
only. You can enter any of the
following values:

® brackets — Eachitemis
enclosed by square brackets: [
]

® braces — Eachitemis
enclosed by braces: {}.

® parens — Each item is
enclosed by parentheses: ().

® pi pe — Eachitemis
separated by a pipe:

® anything — Each item is
separated by the value you
enter. You can enter any text
as a separator, for example "**
*'_If using a custom separator,
be aware that text displays
exactly as entered, with no
additional white space to
further separate the
characters.

Select the highest heading level to
start your TOC list. For example,
entering 2 will include levels 2, and
lower, headings, but will not
include level 1 headings.

Select the lowest heading level to
include. For example, entering 2
will include levels 1 and 2, but will
not include level 3 headings and
below.

Filter headings to include
according to specific criteria. You
can use wildcard characters. See
Sun's Regex documentation for
examples of constructing regular
expression strings.

Filter headings to enclude
according to specific criteria. You
can use wildcard characters. See
Sun's Regex documentation for
examples of constructing regular
expression strings.

By default, the TOC is set to print.
If you clear the check box, the
TOC will not be visible when you
print the page.

If you have custom TOC styles in
your CSS style sheet, use this
parameter to output the TOC
inside <di v> tags with the
specified class attribute.
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Examples

The examples below are based on this table of contents:

« Places
« Favourite Places
« Lnknown Places
« Foods
« Favourite Foods
o« Unknown Foods
* Things
« Favourite Foods
« Lnknown Foods

Filtered Table of Contents

This example filters the headings to include those that contain 'Favourite', but excludes headings which end with
"Things'. The list is styled with Roman numerals.

Parameter Value

List Style upper -roman
Include Headings Favourite.*
Exclude Headings . *Thi ngs

The resulting table of contents is:

I. Favourite Places
Il. Favourite Foods

Flat List

This example filters all headings to render a flat list of 'Unknowns' enclosed in square brackets (the default list
style).

Parameter Value
Output Type flat
Maximum Heading Level 2

Include Headings Unknown. *

The resulting table of contents is:

[ Unknown Places ] [ Unknown Foods ] [ Unknown Foods ]

Notes

®* When you use a Table of Contents macro in a template, you will see an error when you preview the
template itself. But the Table of Contents macro works on the pages that people create from the
template — the table of contents shows up after they have saved the page. (This is probably because the
template is not defined as a page, and the Table of Contents macro works for pages only.)
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® Due to an outstanding issue in the Table of Contents macro (CONF-10619), the macro browser's Refresh
function does not render any parameter modifications. Currently, the rendering of parameter value
modifications to the Table of Contents macro occurs only after the page is saved.

® Using HTML heading markup with the Table of Contents macro
The Table of Contents macro cannot handle HTML heading markup on its own. Hence, if you use the HT
ML and HTML Include macros to render HTML heading markup in a Confluence page, the Table of
Contents macro will not create a contents list out of these headings. (For more information about this
issue, please refer to TOC-93.)
However, if you insert an HTML anchor into each HTML heading on your page (based on the following
syntax), the Table of Contents macro will incorporate these headings into your contents list.

<h2><a nane="pagenane- headi ngnhane" ></ a>Headi ng Nanme</ h2>

The syntax for the anchor name is the page name and heading name separated by a hyphen. Remove all
spaces and convert all text to lower case. Convert all punctuation marks to their URL-encoded equivalent.

Code examples

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a
Confluence page.

Macro name: t oc

Macro body: None.

Storage format example

This example shows a list-type table of contents.

<ac: structured-macro ac: name="toc">
<ac: paraneter ac:name="printabl e">true</ac: paranet er >
<ac: paraneter ac:nanme="styl e">square</ ac: par anet er >
<ac: paraneter ac:name="nmaxLevel ">2</ac: par anet er >
<ac: paranet er ac:nanme="i ndent " >5px</ ac: par anet er >
<ac: paramnet er ac: nane="m nLevel ">2</ ac: par anet er >
<ac: paranet er ac: nanme="cl ass" >bi gpi nk</ ac: par anet er >
<ac: paraneter ac:nanme="exclude">[1//2]</ac: paraneter>
<ac: paraneter ac:nanme="type">list</ac: paraneter>
<ac: paraneter ac:name="outline">true</ac: paraneter>
<ac: paranet er ac: nanme="incl ude">. *</ ac: par anet er >

</ ac: structured- nmacr o>

This example shows a flat table of contents.

<ac:structured-nmacro ac: name="toc">
<ac: paranet er ac: nane="maxLevel ">2</ ac: par anet er >
<ac: paranet er ac: nanme="m nLevel ">2</ ac: par anet er >
<ac: paraneter ac:name="cl ass">bi gpi nk</ ac: par anet er >
<ac: paranet er ac: nanme="excl ude">[1//2] </ ac: par anet er >
<ac: paraneter ac:name="type">fl at </ ac: paranet er >
<ac: paraneter ac:name="outline">true</ac: paraneter>
<ac: paraneter ac: nanme="separ ator">pi pe</ ac: par anet er >
<ac: paranet er ac: nane="incl ude">. *</ ac: par anet er >

</ ac: structured- nacr o>

Wiki markup example
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This example shows a list-type table of contents.

{toc: printabl e=true|styl e=squar e| maxLevel =2| i ndent =5px| m nLevel =2| cl ass=bi gpi nk| exc
lude=[ 1//2] | type=list]|outline=true|include=.*}

This example shows a flat table of contents.

{toc: printabl e=true| maxLevel =2| m nLevel =2| cl ass=bi gpi nk| excl ude=[1//2]|type=fl at| ou
tline=true| separ at or =pi pe| i ncl ude=. *}

Table of Content Zone Macro

You can use the Table of Content Zone macro to mark out a section (zone) within the page from which to create
a table of contents. You can style the headings as a flat list, and place the list of links at the top and bottom of
the section or page, to provide navigation bars similar to web navigation.

Using the Table of Content Zone macro

To add the Table of Content Zone macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of
suggested macros. Details are in Using Autocomplete.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open,
where you can edit the parameters of the macro.

Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the
parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro
browser, it will be listed below in brackets (exanpl e).

Parameter Default Description
location both Specifies where in the zone the
(1l ocation) output list is displayed: top, botto

m, or both, which encloses the
page zone content.

Output Type list Specifies the layout for the table of
(type) contents:

® list — produces a vertical list,
typical of a TOC.

® flat — produces a horizontal
menu-type series of links, for
example: [Heading 1] [Heading
2] [Heading 3].

Display Section Numbering false Select to apply outline numbering
(outline) to your headings, for example: 1.1,
1.2,1.3.
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List Style none Specifies the style of bullet point
(style) for each list item. You can use
any valid CSS style. For example:

® none — no list style is
displayed

® circle-- theliststyleis a
circle

® di sc — the list style is a filled
circle. This is the typical bullet
list, and is the one we're using
for this example list

® squar e —the list style is a
square

® deci mal —thelistis
numbered (1, 2, 3, 4, 5)

® | ower - al pha —the listis
lower-case, alphabetised (a, b,
c, d, e

® | ower - r oman — the list style
is lower roman numerals (i, ii,
iii, iv, v, vi)

® upper-roman — the list style
is upper roman numerals (I, Il

I, v, V, VI
Heading Indent Sets the indent for a list output
(indent) type, according to CSS quantities.

Entering "10px" will successively
indent list heading levels by 10px.
For example, hl headings will be
indented 10px and h2 headings
will be indented an additional

10px.
Separator brackets Only applies to the flat output type
(separator) . Specifies the display style of the

links. You can enter any of the
following values:

® brackets — Each itemis
enclosed by square brackets: [
].

® braces — Eachitem is
enclosed by braces: { }.

® parens — Each item is
enclosed by parentheses: ().

® pi pe — Each item is
separated by a pipe:

® anything — Each is separated
by the value you enter. You
can enter any text as a
separator, for example "***', I
using a custom separator, be
aware that text displays exactly
as entered, with no additional
white space to further separate
the characters.
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Minimum Heading Level 1
(m nLevel)
Max Heading Level 7
(maxLevel)

Include Headings
(i nclude)

Exclude Headings
(excl ude)

Printable true
(printable)

CSS Class Name
(cl ass)

Examples

The examples are based on a page with the following headings:

» Places
+ Favourite Places
» Unknown Places
+ Foods
» Favourite Foods
s Lnknown Foods
* Things
« Favourite Foods
» Unknown Foods

Filtered Table of Contents

244

Select the largest heading level to
start your TOC list. For example,
2 will list h2, h3, and h4 headings,
but will not include h1 headings.

Select the smallest heading level
to include in the TOC. For
example, 2 will list h1 and h2, but
will not include h3 and below.

Filter the included headings
according to specific criteria. You
can use wildcard characters. See
Sun's Regex documentation for
examples of constructing regular
expression strings.

Exclude headings according to
specific criteria. You can use
wildcard characters. See Sun's
Regex documentation for
examples of constructing regular
expression strings.

By default, the TOC is set to print.
If you clear this parameter, the
TOC will not be visible when you
print the page.

If you have a custom TOC in your
CSS style sheet, you can use this
parameter to output the TOC with
the specified "class" attribute.

This example will filter all headings to include those that contain "Favourite", but will exclude any heading which
ends with the word "Things". The list is styled with upper-case Roman numerals.

Parameter Value

Output Type list

List Style upper - r oman
Include Headings Favourite.*
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Exclude Headings . *Thi ngs

Screenshot: Filtered TOC 'zone' headings

Favourite Places
Favourite Foods

Flat List

This example will filter all headings to render a flat list of "Unknowns" enclosed in square brackets.

Parameter Value
Output Type flat
Separator brackets
Max Heading Level 2

Include Headings Unknown. *

Screenshot: Filtered TOC 'zone' headings displayed as a flat list

[ Unknown Places ] [ Unknown Foods ] [ Unknown Foods ]

Notes

Due to an outstanding issue in the Table of Content Zone macro (CONF-10619), the Macro Browser's Ref
resh function does not render any parameter modifications. Currently, the rendering of parameter value
modifications to the Table of Content Zone macro occurs only after the page is saved.

Using HTML heading markup with the Table of Content Zone macro — The Table of Content Zone macro
cannot handle HTML heading markup on its own. Hence, if you used the HTML and HTML Include macro
s to render HTML heading markup in a Confluence page, the Table of Content Zone macro will not create
a contents list out of these headings. (For more information on about this issue, please refer to TOC-93.)

However, if you insert an HTML anchor into each HTML heading on your page (based on the following
syntax), the Table of Content Zone macro will incorporate these headings into your contents list.

<h2><a nane="pagenane- headi ngnane" ></ a>Headi ng Nane</ h2>

The syntax for the anchor name is the page name and heading name separated by a hyphen. Remove all
spaces and convert all text to lower case. Convert all punctuation marks to their URL-encoded equivalent.

Code examples

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a
Confluence page.

Macro

Macro

name: t oc- zone

body: Accepts rich text.

Storage format example
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<ac:structured-nmacro ac: nane="t oc-zone">

<ac:
<ac:
<ac:
<ac:
<ac:
<ac:
<ac:
<ac:

par anmet er
par anet er
par anet er
par anet er
par anmet er
par anmet er
par anet er

ac

ac:
ac:
ac:
ac:
ac:
ac:

> name="
name="
name="
nane="
name="
name="
name="

ri ch-text-body>
<p>Only headings within this block are included in the table of contents.</p>
</ac:rich-text-body>
</ ac: structured- nacr o>

Wiki markup example

printabl e">f al se</ ac: par anet er >
maxLevel " >2</ ac: par anet er >

m nLevel " >2</ ac: par anet er >

| ocati on" >t op</ ac: par anet er >
type">fl at </ ac: par anet er >
outline">true</ac: paraneter>
separ at or " >pi pe</ ac: par anet er >

{toc-zone: printabl e=fal se| maxLevel =2| mi nLevel =2| | ocat i on=t op| type=fl at| outl i ne=true

| separ at or =pi pe}

Only headings within this block are included in the table of contents.

{toc-z

Tip Macro

one}

Using the Tip macro, you can highlight a helpful tip on a Confluence page. The macro creates a green-coloured
box surrounding your text as shown below.

(%) Tip Macro Example
This text is displayed inside the tip macro.

Using the Tip macro

To add the Tip macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of
suggested macros. Details are in Using Autocomplete.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open,
where you can edit the parameters of the macro.

Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the
parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro
browser, it will be listed below in brackets (exanpl e).

Parameter

Optional Title

(title)

Show Tip Icon

(icon)

Default Description

none The title of the tip. If specified, it
will be displayed in bold next to the
icon.

true If cleared, the icon will not be
displayed.
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Code examples

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a
Confluence page.

Macro name: ti p

Macro body: Accepts rich text.

Storage Format example

<ac:structured-macro ac: name="tip">
<ac: paraneter ac:nanme="icon">fal se</ac: par anet er >
<ac: paraneter ac:nanme="title">M title</ac:paraneter>
<ac:rich-text-body>
<p>This is ny hint.</p>
</ ac:rich-text-body>
</ ac: structured- macr o>

Wiki markup example

{tip:icon=false|ltitle=My title}
This is ny hint.
{tip}

User List Macro

The User List macro displays a list of users registered in Confluence, based on their group membership.

Using the User List macro

To add the User List macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of
suggested macros. Details are in Using Autocomplete.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open,
where you can edit the parameters of the macro.
Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the
parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro

browser, it will be listed below in brackets (exanpl e).

Parameter Default Description
Group(s) none Specifies one or more groups
(groups) whose Confluence users you want

to list, using a comma-separated
list of group names. To see all
users registered in a Confluence
installation, specify an asterisk ("*")
for this parameter's value.
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Display Online/Offline Users All registered users List online or offline users. Leave
(online) blank to show all users,

irrespective of status.
Accepted values:

® Unspecified — The macro will
show all registered users.

® true — The macro will show
only online users.

® fal se —The macro will show

only offline users.

In order to make this feature
functional, a System Administrator
needs to enable the User Log In
Listener for your Confluence site.

Code examples

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a
Confluence page.

Macro name: userli ster

Macro body: None.

Storage format example

<ac:structured-nmacro ac: name="userlister">
<ac: par anet er ac: nanme="groups">confl uence-users</ ac: par anet er >
<ac: paraneter ac:name="online">fal se</ac: paranet er >
</ ac: structured- macr o>

Wiki markup example

{userlister:groups=confluence-users]|online=fal se}

User Profile Macro

The User Profile macro displays a short summary of a given Confluence user's profile. This is the same
summary that appears in a Hover Profile, which appears whenever you mouse over a user's name in the
Confluence interface.

Screenshot: Example of the User Profile macro

Leah Admin
sample@email. com.au

Updating Confluence documentation
Position:  Tech Writer
Department. Department of Awesome
Location: Aflassian, Sydney

Using the User Profile macro

To add the User Profile macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
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2. Find and select the required macro.

Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of
suggested macros. Details are in Using Autocomplete.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open,
where you can edit the parameters of the macro.

Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the
parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro
browser, it will be listed below in brackets (exanpl e).

Parameter Default Description

Username none The username of the Confluence

(user) user whose profile summary you
wish to show.

Code examples

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a
Confluence page.

Macro name: profil e
Macro body: None.
Storage format example
<ac:structured-macro ac: name="profile">
<ac: par aneter ac:nane="user">
<ri:user ri:userkey="12345678912345678912345678912345"/ >

</ ac: par anet er >
</ ac: structured-nmacro>

Wiki markup example

{profile:user=adm n}

User Status List Macro

The User Status List macro displays a history of a given Confluence user's status updates. This is the same
history that appears in the user's Status Updates view.

Screenshot: Example output of the User Status List macro

Time to look at networks

n

201

[

Clear - Delete - Feb 1

Updating my profile picture

Delete - Feb 15, 2013

Making Confluence sing...

Delete - Feb 15, 2013
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Using the User Status List macro
To add the User Status List macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of
suggested macros. Details are in Using Autocomplete.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open,
where you can edit the parameters of the macro.

Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the
parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro
browser, it will be listed below in brackets (exanpl e).

Parameter Default Description
Username none The username of the Confluence
(usernane) user whose history of status

updates you wish to show.

Notes

Hint: If you wish to list status updates made by more than one user, you can use the Recently Updated macro w
ith the following parameter values:

® Include these Content Types Only: st at us
® Author(s) by username: The user(s) whose status updates you want to include in the list. If you leave
this field blank, the status updates of all users will be included.

Code examples

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a
Confluence page.

Macro name: st at us-1|i st
Macro body: None.
Storage format example
<ac:structured-nmacro ac: name="status-list">
<ac: par anet er ac: nane="user nane" >
<ri:user ri:userkey="12345678912345678912345678912345"/ >

</ ac: par anet er >
</ ac: structured-nmacro>

Wiki markup example

{status-1ist:usernane=adm n}

View File Macro

The View File macros allow you to embed an Office or PDF document into your Confluence page. First attach
the document to a page and then use one of the View File macros to display the document's content.

When people view the page, they will see the content of the Office or PDF document. They do not need to have
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Office installed in order to see the content of an Office document. If they do have Office installed, people will be
able to open the document for editing in their Office application.

For a full list of Office Connector prerequisites and limitations, please refer to:

® Office Connector Prerequisites

® Office Connector Limitations and Known Issue

For an overview of all Office Connector features, please refer to Working with the Office Connector.

Displaying an Office or PDF Document in Confluence

To display an Office or PDF document in a page, use one of the following View File macros in the macro

browser:

Office Excel
Office PowerPoint
Office Word

PDF

To add one of the View File macros to a page:

1. In the Confluence editor, choose Insert > Other Macros.

2. Find and select the required macro.

Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of

suggested macros. Details are in Using Autocomplete.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open,

where you can edit the parameters of the macro.

Parameters for the Office and PDF macros

Parameters are options that you can set to control the content or format of the macro output. Where the
parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro

browser, it will be listed below in brackets (exanpl e).

Macro Parameter

All View File macros Page Name
File Name

Office Excel Show Grid?

Worksheet Name

Last Row

Default

The page which contains
the macro

none

true

Last worksheet viewed in
the spreadsheet

Last row with content

Description

Enter a page name, if
you wish to display a
document which is
attached to another
Confluence page.

The file name of the
Office or PDF document
to be displayed. The
document must be
attached to a page on
your Confluence site.

Select to show grid lines
around each cell of the
Excel spreadsheet. Clear
to hide these grid lines.

The name of the
worksheet that you want
displayed.

The number of the last
row you want displayed,
starting from '0' as the
first row.
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Last Column Last column with content  The number of the last
column you want
displayed, starting from
'0" as the first column.

Hint for reducing the
size of the
spreadsheet: Use the L
ast Column and Last
Row parameters to
reduce the size of the
spreadsheet displayed
on the wiki page. This is
especially useful to
prevent the display from
showing empty cells.
This will also help to
prevent '‘out of memory"
errors.

Office Height Specify the height of the
display, in pixels (default)
or as a percentage of the
window's height.

PowerPoint

Slide Number none Specify the number of
the slide that you want
displayed on the
Confluence page, where
the first slide is
numbered zero. Instead
of a slide show, the page
will display just the single
slide, represented as a
JPEG image. If not
specified, all slides
display as a slideshow.

Width Specify the width of the
display, in pixels (default)
or as a percentage of the
window's width.

Editing an Office document

You can launch your Office application and edit Office documents displaying in the view file macros directly from
your Confluence page.

®* Word and Excel - choose the Edit Document link above the content
® PowerPoint - choose the edit icon on the viewer.

You will find more information and other methods for editing attached Office documents in Editing an Office
Document from Confluence.

Troubleshooting
Problems? Please refer to our guide to the Office Connector limitations and known issues.
Code examples

Refer to the page for each macro to see storage format and wikimarkup examples.

® Office Excel Macro
® Office PowerPoint Macro
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® Office Word Macro
® PDF Macro

Warning Macro

The Warning macro is useful for highlighting a warning on a Confluence page. The macro creates a red-coloured
box surrounding your text as shown below.

(D Example of a Warning Macro
This text appears inside the Warning macro.

Using the Warning macro

To add the Warning macro to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of
suggested macros. Details are in Using Autocomplete.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open,
where you can edit the parameters of the macro.
Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the
parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro
browser, it will be listed below in brackets (exanpl e).

Parameter Default Description

Optional Title none The title of the warning note. If

(title) specified, will be displayed in bold
next to the icon.

Show Warning Icon true If "false”, the icon will not be

(icon) displayed.

Code examples

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a
Confluence page.

Macro name: war ni ng

Macro body: Accepts rich text.

Storage format example

<ac: structured-nmacro ac: name="war ni ng" >
<ac: paraneter ac:nanme="icon">fal se</ ac: par anet er >
<ac: paraneter ac:name="title">This is ny title</ac: paraneter>
<ac:rich-text-body>
<p>This is <enpinportant</enr information.</p>
</ac:rich-text-body>
</ ac: structured- nacr o>

Wiki markup example
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{warning:icon=false|title=This is ny title}
This is _inportant_ information.
{war ni ng}

Widget Connector Macro

The Widget macro, or Widget Connector, allows you to embed certain multimedia content from other web sites
into your Confluence page.

It supports the following content:

® Gadgets and other widgets: Google Gadgets, Widgetbox.
® Videos: YouTube, MySpace Video, Yahoo Video, Dailymotion, Episodic, Vimeo, Metacafe, blip.tv, Viddler

® Photos and images: Flickr, Skitch.com.

® Micro-blogging: Twitter, FriendFeed, BackType.

* Documents and presentations: SlideShare, SlideRocket, Scribd, presentations on Google Docs. Note: Th
e integration with Google Docs is currently broken. Please refer to & CONF-24927 for details of the issue

® (Calendars: Google Calendar.
® Forms and online databases: Wufoo HTML Form Builder and Wufoo Reports.
® Support and customer satisfaction: Get Satisfaction.

There are live examples of many of these on the widget examples page. If you wish to extend the functionality of
this plugin, please see Extending the Widget Connector.
On this page:

Using the Widget Connector
Parameters
Examples of macro sources
Troubleshooting
Code examples
® Storage format example
® Wiki markup example

Related pages:

® \Working with Macros
® Confluence User's Guide

Using the Widget Connector

To add the Widget Connector to a page:

1. In the Confluence editor, choose Insert > Other Macros.
2. Find and select the required macro.

Speeding up macro entry with autocomplete: Type { and the beginning of the macro name, to see a list of
suggested macros. Details are in Using Autocomplete.

To edit an existing macro: Click the macro placeholder and choose Edit. A macro dialog window will open,
where you can edit the parameters of the macro.

Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the
parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro
browser, it will be listed below in brackets (exanpl e).

Parameter Description
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Web Site's Widget URL This is the URL provided by the external web site for

(url) embedding content from that web site onto another
web page.

Pixel Height (Value Only) Specify the height of the display, in pixels.

(hei ght)

Pixel Width (Value Only) Specify the width of the display, in pixels.

(wi dt h)

Examples of macro sources

Google Gadgets

You need to find the URL for the Google Gadget you want to display.
Here is one way to find a gadget's URL:

1. Go to the Google Gadgets directory.

2. Find the gadget you want then click its name, such as 'Spider".

3. The gadget's summary page will open. Copy the URL from your browser's address bar. The URL looks
something like this one:

http://ww. googl e. com i g/ di rect ory?synd=open&ium=24&ur | =htt p: / / abowran. googl ep
ages. coni spi der . xm &out put =ht m

You can also use the URL of the ‘add gadget' page. The page is called 'Add "gadgetx" to your iGoogle page"

1. There are a couple of ways to get to the 'add gadget' page:
® Click a '+Google' button underneath the gadget when displayed on a page somewhere.
® Or click 'Add Stuff' on your iGoogle page.

2. Copy the URL from your browser's address bar. The URL would look something like this one:

http://ww. googl e. com i g/ adde?synd=opené&sour ce=ggyp&rodul eur | =abowran. googl epa
ges. coni spi der. xm

Widgetbox widgets
You will need to find the URL for the Widgetbox widget you want to display.
Here is one way to find a widget's URL:

1. Ensure you are logged in to Widgetbox and that you are viewing the Widgetbox Gallery.
2. Find the widget you want then click its name, such as 'cyber-pet'.

3. The widget's summary page will open. Within the Get Widget section, click the Atlassian Confluence icon

?  Unknown frtachment

required for the Widget Macro.

© if you cannot see this icon, click the more... link to reveal it.

In the Widgetbox Add to Confluence dialog box, click Copy.

Copy the URL from your browser's address bar. The URL looks something like this one:

ok

htt p: // wi dget box. conf conf | uence/ b8327e33- c8eb- 4a38- b842- f ba866f f dd28

YouTube
You will need to find the URL for the YouTube video that you want to display.
To find a YouTube video's URL:

1. Goto YouTube and search for the video you want.
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Click the title of the video, such as 'Wikis in Plain English'.

The video's summary page will open on YouTube. Choose Share.
Choose Options, located under the video's URL.

Choose Long link, then copy the long URL. It looks something like this:

aprwN

http://au.youtube.com wat ch?v=-dnLOOTdnLY

Note: You must use the long YouTube URL. The shortened URL (like this one: htt p: / / www. yout u. be
/ <vi deo_key>) does not work in the widget connector. If you are unable to view the video in some
browsers, use https: rather than http in your link.

MySpace Videos
You will need to find the URL for the MySpace video that you want to display.
To find a MySpace video's URL:

1. Go to MySpace Video and search for the video you want.

2. Click the title of the video, such as 'Glacier Creek Confluence Time Lapse'.

3. The video's summary page will open. Copy the URL from your browser's address bar. The URL looks
something like this one:

http://vids. myspace. conli ndex. cf n?fuseacti on=vi ds. i ndi vi dual &vi deoi d=3376248&s
ear chi d=20c789f 6- 1ae9- 459a- bf ec- 75ef cf c2847c

Yahoo Video
You will need to find the URL for the Yahoo video that you want to display.
To find a Yahoo video's URL:

1. Goto Yahoo Video and search for the video you want.

2. Click the title of the video, such as 'Wiki Technology Trend: Past, Now and Future'.

3. The video's summary page will open. Copy the URL from the address bar of your browser. The URL looks
something like this:

http://video. yahoo. com wat ch/ 423158/ 2424140

ﬂ If you are unable to obtain a uniqgue URL from your browser's address bar, click the envelope (Share)
icon on the lower section of the video screen and copy the contents of the Link field.

Dailymotion Video
You will need to find the URL for the Dailymotion video that you want to display.
To find a Dailymotion video's URL:

1. Go to Dailymotion and search for the video you want.

2. Click the title of the video, such as 'Wiki Technology Trend: Past, Now and Future'.

3. The video's summary page will open. Copy the URL from the address bar of your browser. The URL looks
something like this:

http://ww. dai | ynoti on. conf user/ spacevi dcast/vi deo/ x7zevj _spacevi dcast - 2009- pr
ono-vi deo_t ech

ﬂ If you are unable to obtain a uniqgue URL from your browser's address bar, click Menu at the lower
right section of the video screen, select URL & Embed Code and copy the contents of the Link field.
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Episodic
You will need an Episodic user account if you want to create and distribute videos via Episodic.
To embed an Episodic video onto a Confluence page:
1. Find the video and copy the URL from the address bar of your browser. The URL looks something like
this:

http://app. epi sodi c. coml shows/ 13/ epi sodes/ 493

2. Paste the URL into the Web Site's Widget URL box in the Macro Browser.
Vimeo
You will need to find the URL for the Vimeo video that you want to display.
To find a Vimeo video's URL:

1. Goto Vimeo and search for the video you want.

2. Click the title of the video, such as 'The Wiki Show - Allison the Russian High Kicker'.

3. The video's summary page will open. Copy the URL from the address bar of your browser. The URL looks
something like this one:

http://ww. vi meo. conf 909808

Metacafe
You will need to find the URL for the Metacafe video that you want to display.
To find a Metacafe video's URL:

1. Go to Metacafe and search for the video you want.

2. Click the title of the video, such as 'Wikis In Plain English (How To)'.

3. The video's summary page will open. Copy the URL from the address bar of your browser. The URL looks
something like this one:

http://ww. net acaf e. conf wat ch/ 679493/ w ki s_i n_pl ai n_engl i sh_how_t o/

blip.tv
This integration is currently broken. Please refer to CONF-27266 for details of the issue.
Viddler

This integration is currently broken. Please refer to CONF-27267 for details of the issue.

Flickr
You can embed a slide show of photos from Flickr by supplying a URL that specifies one of the following:

Photos with a specific tag.

Photos belonging to the photostream of a specific Flickr user.
A set of photos as defined by the Flickr user.

A user's photostream starting at a specific photo.

If you want to do something else, we suggest that you try any Flickr URL. It should work.

Below are some examples of the Widget macro code for embedding Flickr images.
Flickr Photos with a Specific Tag

This URL displays a slide show of Flickr photos that are tagged with the word 'Atlassian’ http://www.flickr.com/ph
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otos/tags/atlassian/
Flickr Photos from a Specific User

This URL displays a slide show of photos from the Flickr photostream of user 'Atlassian’: http://www.flickr.com/p
hotos/atlassian/
Flickr Photos from a Specific Set

This URL displays a slide show of Flickr photos from the set 'Melbourne Cup - November 2008' created by user
‘Atlassian’: http://www.flickr.com/photos/atlassian/sets/72157608657271078/
A Specific Flickr Photo

This URL displays a slide show of photos from the Flickr photostream of the user 'Atlassian’, starting with a
specific photo: http://www.flickr.com/photos/atlassian/3003538919/

Skitch.com
You will need to find the URL for the Skitch image that you want to display.
To embed a Skitch image onto a Confluence page:

1. Go to Skitch.com.
2. Find the image and copy the URL from the address bar of your browser. The URL looks something like
this:

http://skitch.conl atl assi an/ 411g/ exanpl e-i mage

Note: Skitch is now integrated with Evernote, as described in this blog post from The Next Web: Evernote is
bringing Skitch into its core service, Skitch.com will be archived. As a result, private images on Skitch.com are
no longer accessible and will not work in the Confluence widget connector. Existing public images on Skitch.com
will remain available.

Twitter

Note: Due to a recent change to the Twitter API, the process for displaying Tweets has changed. The following
instructions relate to v 2.1.6 of the Widget Connector plugin. Earlier versions of the Widget Connector no longer
display tweets correctly.

To embed a single tweet:

1. In Twitter, navigate to the tweet you wish to embed and choose Details to display just that tweet in your
browser.

2. Copy the page URL (the URL should be in the following format, https://twi tter.conf atl assi an/
st at us/ 346976521250037760).

3. In Confluence, paste the URL into the Widget Connector.

4. The single tweet will display, like the one below.

atlassian o Follow
@atlassian

Want to edit your @Confluence pages in fullscreen? Now
you can with the distraction-free editor — avail. now
ow.ly/m8dsY #e2conf

11:03 PM - 18 Jun 2013

5 RETWEETS 3 FAVORITES

To embed a dynamic list of tweets:

1. In Twitter, create a Widget (go to Settings > Widgets).
2. Configure the widget to display the tweets you wish to embed (for example, a user timeline, list of tweets
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or hashtag search).
3. Save the widget, then copy the page URL (the URL should be in the following format, https: //twitte

r.com settings/w dget s/ 354381809263472640/ edi t)

4. In Confluence, paste the URL into the Widget Connector.
5. The list of tweets will display, like the one below.
Tweaeats W Follow @confluence
Y Atlassian Confluence 2dul *
< G@confluence

Walking the requirements
documentation tightrope in an agile
world atlss.inf13hgGlh via @atlassian

Expand

Y Atlassian Confluence 27 Jun
<®W¥ (G@confluence

keep up-to-date with the new Watch
button in Confluence — available
today! ow ly/magm 11 #collaboration
#atlassian

Tweet to @confluence

FriendFeed

To display the latest messages from a FriendFeed user, add the user's FriendFeed link as the URL in the
Widget macro. For example:

BackType

To display the latest blog or website comments from a BackType user, add the user's BackType widget link as
the URL in the Widget macro. For example:

SlideShare
You will need to find the URL for the SlideShare presentation that you want to display.
To find a SlideShare presentation's URL:

1. Go to SlideShare and search for the presentation you want.

2. Click the title of the presentation, such as 'Using JIRA & Greenhopper for Agile Development'.

3. The presentation's summary page will open. Copy the URL from the address bar of your browser. The
URL looks something like this one:

http://ww. slideshare.net/jleyser/using-jira-greenhopper-for-agile-devel opnent
-presentation

SlideRocket
You will need to find the URL for the SlideRocket presentation that you want to display.
To find a SlideRocket presentation's URL.:

1. Log in to SlideRocket and go to your library of presentations.
2. Copy the 'web link' for the presentation you want to display. This will give you a URL that looks something
like this one:

http://app. sliderocket.conf app/ Ful | Pl ayer. aspx?i d=132f 9db7- b0Of b- 4f 51- b974- 3665
2774971b
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3. Paste the URL into the Widget macro code on your Confluence page.
Scribd
You will need to find the URL for the Scribd presentation that you want to display.
To find a Scribd presentation's URL:

1. Go to Scribd and search for the presentation you want.

2. Click the title of the presentation, such as 'My Sea Friends Coloring Book'.

3. The presentation's summary page will open. Copy the URL from the address bar of your browser. The
URL looks something like this one:

http://ww. scri bd. com doc/ 5683554/ My- Sea- Fri ends- Col ori ng- Book

4. Paste the URL into the Widget macro code on your Confluence page.
Google Docs Presentations
This integration is currently broken. Please refer to & CONF-24927 for details of the issue.
Google Calendar

You can embed a Google Calendar into your page and to do this, you will need to add the URL for the Google
Calendar that you want to display.

To find the URL for a Google Calendar:

1. Log in to Google Calendar.

2. In the calendar list on the left side of the page, ensure the appropriate calendar is selected, click the
down-arrow button next to the calendar name and then select the Calendar settings option.
(Alternatively, if available, click the Manage Calendars link at the bottom of the calendar list and then
click the name of the appropriate calendar.)

3. Inthe Calendar Address section, click the HTML button. A pop-up message with your calendar's public
URL appears.

4. Copy the URL from this pop-up message. The URL looks something like this:

http: //ww. googl e. con cal endar/ enbed?sr c=sonebody%l0exanpl e. com&ct z=Austral i a/
Sydney

5. Paste the URL into the Widget macro code on your Confluence page.
Wufoo HTML Form Builder
To display an HTML form built in the Wufoo HTML Form Builder, add the form's link as a URL to the Widget
Macro. For example:

http://exanpl es. wuf oo. conl f or ns/ cont act -form

Wufoo Reports

To display a Wufoo Report built using the Wufoo Report Manager, add the report's link as a URL to the Widget
Macro. For example:

http://exanpl es. wf 00. com reports/exanpl e-sati sfaction-survey-report/

Get Satisfaction social support application

To display a feedback form for a Get Satisfaction community, add the community or company link as a URL to
the Widget Macro. For example:
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http://getsatisfaction.confatlassian

Troubleshooting
If the URL given in the Widget Connector macro does not work, the macro displays an icon and the base URL.

For example, the following code:

http://exanmple.cominvalid

will result in an image like the one below:
L
®

Code examples

The following examples are provided for advanced users who want to inspect or edit the underlying markup for a
Confluence page.

Macro name: wi dget

Macro body: None.

Storage format example

<ac:structured-macro ac: name="w dget ">
<ac: paranet er ac: name="hei ght">480</ ac: par anet er >
<ac: paranet er ac: nane="w dt h">640</ ac: par anet er >
<ac: parameter ac:nane="url">
<ri:url ri:value="http://youtube.conlwatch?v=23pLByj_q5U"/>
</ ac: par anet er >
</ ac: structured- nacr o>

Wiki markup example

{wi dget : hei ght =400| wi dt h=400]| ur| =htt p: / / ww. googl e. coni i g/ di r ect or y?synd=open&nunr2
4&ur | =ht t p: / / www. gadzi . conf gadget s/ nonkey. xm &out put =ht m }

Widget Connector Examples

This page contains working examples of some services currently supported by the Widget Connector. This page
lets you preview what each widget will look like and see how to interact with it. For detailed usage, see Widget
Connector Macro.

Flickr
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http://ww.flickr.

http://ww.flickr.

http://ww.flickr.

http://ww.flickr.

conl phot os/ t ags/ atl assi an

conl phot os/ at | assi an/

coni phot os/ at | assi an/ sets/ 72157608657271078/

coni phot os/ at | assi an/ 3003538919/

On this page:

Flickr
Google Docs
YouTube
MySpace
Vimeo
BlipTV
Viddler
Skitch
Twitter
FriendFeed
SlideShare
SlideRocket
Scribd
Wufoo
Example of widget error
message

Related pages:

Widget Connector Macro
Working with Macros
Confluence User's Guide

Google Docs

This integration is currently broken. Please refer to & CONF-24927 for details of the issue.

YouTube

http://au. yout ube. com wat ch?v=-dnLOOTdnLY

Note: You must use the long YouTube URL, available under Share > Options. For detailed instructions, see the

user's guide to the widget macro.

MySpace
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http: // ww. myspace. coni vi deo/ t hefl ynn/ gl aci er - cr eek- confl uence-ti ne-1apse/ 3376248

Vimeo

f Get ADOBE A
FLASH® PLAYER

http://ww. vi neo. com 909808

BlipTV
This integration is currently broken. Please refer to CONF-27266 for details of the issue.
viddler

This integration is currently broken. Please refer to CONF-27267 for details of the issue.

Skitch

Skitch is now integrated with Evernote, as described in this blog post from The Next Web: Evernote is bringing
Skitch into its core service, Skitch.com will be archived. As a result, private images on Skitch.com are no longer
accessible and will not work in the Confluence widget connector. Existing public images on Skitch.com will
remain available.

Twitter

http://tw tter.conl ntcannonbr ookes

http://search.tw tter.conf search?q=At| assi anDr agons

FriendFeed

http://friendfeed. com nmynane

SlideShare

f Get ADOBE® 4
FLASH® PLAYER

http://ww. sl i deshare.net/jl eyser/using-jira-greenhopper-for-agile-devel opnent-pres
entation
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SlideRocket

http://app.sliderocket.conlfapp/ Ful | Pl ayer. aspx?i d=132f 9db7- bOf b- 4f 51- b974- 366527749
71b

Scribd

http://ww. scribd. com doc/ 28967704/ How di d- Shakespear e- change-t he- Engl i sh-| anguage|
hei ght =600px

Wufoo
http://exanpl es. wf oo. com forns/ contact-forn

Example of widget error message

This is an example of the error message you will see, if the Widget connector cannot find the URL or service
specified.

[ W
=
http://exanpl e.cominvalid

Task Report Macro

Use the Task Report macro to display a list of tasks on a page. Filter the On this page:
tasks by space, page, user, label, created date and more. ]

® Using
See Working with Tasks for more information on creating and assigning the Task
tasks. You can also use the Task Report blueprint, which will create a page Report
and add this macro for you. macro

® Parameter
Using the Task Report macro S

®* Code
To add the Content Report Table macro to a page: examples

1. Iq the Confluence edltor,. choose Insert > Other Macros. Related pages:
2. Find and select the required macro.

. . - ® Working
Speeding up macro entry with autocomplete: Type { and the beginning with Tasks

of the macro name, to see a list of suggested macros. Details are in Using
Autocomplete.

To edit an existing macro: Click the macro placeholder and choose Edit. A
macro dialog window will open, where you can edit the parameters of the
macro.

Task Report macro showing incomplete tasks, on pages with the label 'meeting-notes'.
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Meeting actions this month
Created and last modified by Rach Admin a minute ago
Description Due date Assignee Task appears on
Leah Admin| to schedule a follow up meeting Leah Admin ~ 2014-03-25 Meeting notes
Ewan User| to finish creating the new project space by |10 Mar 2014 10 Mar 2014  Ewan User 2014-03-25 Meeting notes
Josh User add designs to the project space's file list by |02 Apr 2014 02 Apr 2014 Josh User 2014-03-29 Meeting notes

Parameters

Parameters are options that you can set to control the content or format of the macro output. Where the
parameter name used in Confluence storage format or wikimarkup is different to the label used in the macro
browser, it will be listed below in brackets (exanpl e).

Parameter

Space(s) and Page(s)
(spaceAndPage)

Label(s)
(1 abel s)

Assigned to
(assi gnee)

Created by
(creator)

Created after
(creat eddat eFr on)

Task status
(st atus)

Number of tasks to
display
(pagesi ze)

Required Default
No None
No None
No None
No None
No None
No None
No 20

Description

Filter by the task
location. The macro will
only display tasks in the
pages or spaces
specified. You can enter
a combination of spaces
and pages.

Filter by Label. The
macro will only display
tasks on pages with this
label. You can enter
multiple labels,
separated by a comma.

Filter by Assignee. The
macro will only display
tasks assigned to the
users specified.

Filter by Creator. The
macro will only display
tasks created by the
users specified.

Filter by created date.
The macro will only
display tasks created on
or after the date
specified. Date must be
entered as dd- mm yyy

y.

Show complete,
incomplete or all tasks.

The number of tasks to
display on each page of
results in the table.
Choose from 10, 20 or
40.
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Display columns No description,duedate,assi  Columns to include in

(col ums) gnee,location the table. Available
columns include descrip
tion, duedate, assignee,
location, completedate
and labels.

Code examples

The following examples are provided for advanced users who want to inspect or edit the underlying markup
for a Confluence page.

Macro name: t asks-report-macro

Macro body: None.

Storage format example

Note: The spaceAndPage multi-picker parameter populates the spaces and pages parameters.

<ac:structured-macro ac: nane="t asks-report-macro">
<ac: paranet er ac: nane="spaces" >BSP</ ac: par anet er >
<ac: paranet er ac:nane="status">conpl et e</ac: par anet er >
<ac: paraneter ac:nane="assi gnees">
<ri:user ri:userkey="2c9682654373c47f014373caa68a0003"/ >
</ ac: par anet er >
<ac: par anet er
ac: nane="spaceAndPage" >space: BSP, page: 2555905</ ac: par anet er >
<ac: paranet er ac: name="pages" >2555905</ ac: par anet er >
<ac: paranet er ac: nanme="| abel s" >neet i ng- not es</ ac: par anet er >
<ac: paranet er ac: nane="pageSi ze">10</ ac: par anet er >
</ ac: structured- nacr o>

Wiki markup

Wiki markup is not available for this macro. You cannot add this macro via wiki markup.

Working with Drafts

A draft is a 'snapshot' of unsaved page content, which Confluence creates automatically at regular intervals
while you are editing a page or blog post. This can minimise the loss of work if your Confluence site experiences
a problem, since you can retrieve the page content from your last saved draft.

How do drafts work in Confluence?

At regular intervals, Confluence automatically saves a draft of the page you are editing. If a network failure or
system error prevents you from saving your page, you can retrieve its last saved draft and continue working on
the page from the last saved draft.

Drafts are created while you are adding and editing a page or blog post. Each new draft replaces the previously
saved draft. By default, Confluence saves a draft of your page once every thirty seconds. However, a Confluenc
e administrator can configure how often drafts are saved. In addition, whenever you edit a page and then move

to another screen, Confluence will automatically save a draft.

When you edit the page again, Confluence will let you know that a version of the page you are editing was not
saved and will give you the option to resume editing it.

Each time Confluence saves a draft, it displays a message and the time of the last save near the Save button on
the edit screen.
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On this page:

® How do drafts work in Confluence?
® Viewing drafts
® Viewing your unsaved changes

Related pages:

Resuming the Editing of a Draft

® Configuring the Time Interval at which Drafts are
Saved

® Concurrent Editing and Merging Changes

® Confluence User's Guide

Screenshot: Message displaying the time when the draft was last saved

What did you change? Motify watchers Freview m Cancel

Draft autosaved at 1:56 PM (view change)

More about drafts:

® A user only has access to the drafts of pages they have been working on and whose content has not yet
been saved.

® A user cannot create a draft explicitly.

® A user's drafts are listed in the 'Drafts' tab of their profile.

® Once a user has resumed editing a draft, or chosen to discard it, the draft is removed from their drafts tab.

Viewing drafts
Your drafts are listed on the Drafts tab of your user profile.
To see your drafts:

Choose your profile picture at top right of the screen, then choose Drafts.

Viewing your unsaved changes

While editing a page or blog post, you can view any 'unsaved' changes you have made since the last
automatically saved draft, by clicking view change (near the Save button).

Screenshot: Segment of the unpublished changes window

Unpublished Changes for 'Sample Page' Help

Two penguins find themselves together on an ice floe, drifting helplessly into warmer waters. The penguins are very fond of each
other. Suddenly cra-a-a-a-ck the ice flow splits in half, right between the penguins. As they drift apart, one penguin sadly waves a
flipper and calls out "Chocolate milk!"

What happens Do you know what happened next?

Image Removed

Close

Configuring the Time Interval at which Drafts are Saved
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By default, Confluence saves a draft of your page once every thirty seconds. Related pages:
Confluence administrators can configure how often drafts are saved. ,
® Working
As a Confluence administrator, you can set the time interval at which drafts with Drafts
are saved as follows: ® Resuming
the Editing
1. Choose the cog icon E: then choose General Configuration un of a Draft
der Confluence Administration.
2. Click Further Configuration in the left-hand panel.
3. Edit the setting for Draft Save Interval.
Concurrent Editing and Merging Changes
Sometimes, two or more people may edit a page at the same time. When Related pages:
this happens, Confluence will do its best to ensure that nobody's changes
are lost. * Page
History
How will | know if someone else is editing the same page as | am? and Page
: . T Compariso
If another user is editing the same page as you, Confluence will display a Y

message above your edit screen letting you know who the other user is and -

. Working
when the last edit was made. with Drafts
Screenshot: Notification of Simultaneous Page Editing
(@ This page is also being edited by Ewan User Your changes will be merged with theirs when you save. x

What happens if two of us are editing the same page and the other user saves before 1 do?

If someone else has saved the page before you, when you click 'Save', Confluence will check if there are any
conflicts between your changes and theirs. If there are no conflicting changes, Confluence will merge the
changes.

If there are conflicts, Confluence will display them for you and give you the option to:

® Continue editing - you can continue to edit the page, useful if you want to manually merge the
changes.

® Qverwrite - this will replace the other person's edits with yours.

® Cancel - this will discard your changes and exit the editor, keeping the other person's edits.

Example Scenario
For example, Alice and Bob both edit the same page at the same time.

If Alice clicks save before Bob, Bob is now effectively editing an out-of-date version of the page. When Bob
clicks save, Confluence will examine his changes to see if any overlap with Alice's. If the changes do not
overlap (i.e. Alice and Bob edited different parts of the page), Bob's changes will be merged with Alice's
automatically.

If Bob's changes overlap with Alice's, Confluence will display an error message to Bob showing where Alice
has changed the page, and giving Bob the options to overwrite Alice's changes with his own, to re-edit the
document to incorporate Alice's work, or to cancel his own changes entirely, maintaining Alice's changes.

Resuming the Editing of a Draft

If you have typed some content into a Confluence page or blog post, Confluence will save a draft of it, even if
you were not able to successfully save the page or blog post, or add a title to it.

There are two ways to resume editing an unsaved page or blog post:
A. Using your drafts view. To resume editing a draft from this view:

1. Choose your profile picture at top right of the screen, then choose Drafts.
2. Choose Resume Editing next to the appropriate draft to resume editing that draft.
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Note: If you had not yet entered a page title, the draft will be listed with the title 'Untitled".

B. If you had created a new page or blog post but did not save it, then when you next add a page or blog post in
that space, Confluence will ask you if you want to resume editing the page that was not saved. If you click resu
me editing, the draft and its unsaved content will be restored, allowing you to continue editing it.

Related pages:

® Working with Drafts

Screenshot: Resume Editing

(@ A version of this page you were editing at Feb 14, 2013 16:30 was saved as a draft. Do you want to view the change, resume editing or discard it?

What happens if | am editing the draft of a page that has since been updated?

When this happens, Confluence will display a message informing you that you are editing an outdated page. If
there are no conflicts between the two versions, Confluence will give you the option to Merge and Resume
editing.

If there are any conflicts, Confluence will give you the option to View the Conflict or to Discard your changes.
Recording Change Comments

A 'change comment' is a short description that summarises the changes made to a page during an editing
session. Change comments are a useful way of keeping track of the history of a page.

A change comment is not the same as a comment added to a page. Refer to Commenting on pages and blog
posts for information about that type of comment.

Note that once a change comment has been added and the page has been saved, it is not possible to update or
remove the change comment.
On this page:

® Entering a Change Comment
® Viewing a Change Comment
® Viewing a History of Change Comments

Related pages:

® Viewing Page Information
® Page History and Page Comparison Views
® Confluence User's Guide

Entering a Change Comment

You can enter change comments in the field located below the edit screen:

Screenshot: Entering change comments

What did you change? Notify watchers Preview m ~ILIE

Viewing a Change Comment

To see the most recent change to a page and any change comment that may have been entered, choose the
edited date on the byline. You can also go to Tools > Page History to see change comments for all versions.
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Pages / Sample Space Home

Page History

Versions Compared

24 Current
1 Rach Admin Ewan User
yesterday at 12:22 PM less than a minute ago

View Page History
Comment: adding a change comment

= View Page &% Tools -

Key
This line was added.
Formatting was changed.

Viewing a History of Change Comments

The change comments for a page are recorded under the 'Recent Changes' section of the page's 'Info’ view and

in the page's 'History' view.

Screenshot: History of change comments on Info view

Recent Changes

Since you last logged in:

Josh User, Sophie User made 2 changes. (view)
Since you last edited this page:

Josh User made 1 change. (view)

Time Editor
Feb 14, 2013 10:58 Josh User View Changes
Added penguin image
Feb 14, 2013 10:57 Sophie User View Changes
Fixed a typo
Feb 14, 2013 09:06 Rach Admin

View Page History

Creating Beautiful and Dynamic Pages

Confluence has a number of features that help you
build attractive pages to engage your readers and
give them the opportunity to interact with up-to-date
information. This page summarises those features
and provides links to detailed instructions.

Adding visual appeal

Pictures, photographs and
screenshots. Confluence pages
can display images from your
Confluence site and from other
websites. To put an image into
Confluence, you can upload it
and attach it to a page or blog
post, then display it on any page,
blog post or comment. Alternatively, display an
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image from a remote location via the web address
Displaying Images(URL). See .

Galleries. Use the Gallery Macro to display a set of
images. When viewing the page, people can click
any of the pictures to zoom in and view the images
as a slide show.

People. Add a Profile Picture Macro to show a
picture of a Confluence user, or a User Profile Macro
to show a summary of the person's profile as well as
their avatar.

Multimedia. You can display movies, animations
and videos, and embed audio files on your
Confluence page. For example, Confluence supports
Adobe Flash, MP3, MP4, and various other movie
formats. See Embedding Multimedia Content.

Social video and image sharing. The Widget
macro displays live content from social sites such as
YouTube and other video sharing sites, and Flickr fo
r shared photographs. See the guide to the .

Widget Connector Macro

Bringing numbers to life

On this page:
® Adding visual appeal
® Bringing numbers to life
® Displaying presentations and

documents
Pulling in content from your issue
tracker

® Telling a story in pictures
® Varying the structure of your

pages
Integrating your content with social
media

Showing activity streams

Related pages:

Working with Macros
Using the Editor
Confluence User's Guide

The Chart Macro offers a variety of graphs and charts that you can use to illustrate statistics and other

numerical data.

lllustration: A 3-dimensional bar chart produced by the Chart macro

45

410

E{i]
75
20
15
1a
5
. > > o

2009 2010 2011

B Fevenue M Expense

Displaying presentations and documents

Display your Office documents and other
presentations directly in Confluence.

® Attach your Office documents to a Confluence
page then display them on the page, using
the View File Macro. This works for Excel
spreadsheets, PowerPoint presentations and
Word documents.

® Display PDF files in Confluence too, also with
the View File Macro.

® Use the Widget Connector Macro to show
slide decks hosted on SlideShare and other

Illustration: A PowerPoint slide deck
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online presentation sites.

Pulling in content from your issue tracker

Many project teams and customers have useful
information on a JIRA issue tracker. Rather than
copying and pasting it onto your Confluence page,
you can display it directly from the source, thus
ensuring that the information shown in Confluence is
always up to date.

Link to a feature request in your issue tracker, or
display a list of fixed issues — useful for release
notes and project planning. See the JIRA Issues
Macro.

Telling a story in pictures

A number of Confluence add-ons provide
sophisticated tools for creating diagrams and
mockups.

For example:

Balsamiq Mockups for Confluence
Creately for Confluence

Gliffy Confluence Plugin

Graphviz Plugin for Confluence
Lucidchart for Confluence

Search the Atlassian Marketplace for more add-ons.

Before installing an add-on (also called a plugin) into
your Confluence site, please check the add-on's
information page to see whether it is supported by
Atlassian, by another vendor, or not at all. See our
guidelines on add-on support.

Varying the structure of your pages

You can build up a custom layout by using the page
layout tool to add sections and columns to your
page. See the detailed guidelines to Working with
Page Layouts and Columns and Sections.

Do you need to display tabular data, which your
readers can sort when viewing the page? See Worki
ng with Tables.

Use other macros to highlight and format sections of
your page:

Panel

Tip

Info

Note
Warning
Code block
Noformat

Integrating your content with social media

People share information on various social sites. You can make Confluence
a focal point where people collect their shared information and see what is

happening in the areas that matter to them.

272

lllustration: A Gliffy diagram

Pages Blogs

General Comments News
information Labels
Content
Labelz Labels
Attachments

Images, Office files,
movies, and more

lllustration: A Panel macro

Use a macro or add a smiley to
brighten your page. -

Illustration: A Twitter stream
via the Widget macro

Created in 2014 by Atlassian. Licensed under a Creative Commons Attribution 2.5 Australia License.


http://creativecommons.org/licenses/by/2.5/au/
https://marketplace.atlassian.com/plugins/com.balsamiq.confluence.plugins.mockups
https://marketplace.atlassian.com/plugins/com.cinergix.confluence.plugins.creately.CreatelyConfluence
https://marketplace.atlassian.com/plugins/com.gliffy.integration.confluence
https://marketplace.atlassian.com/plugins/com.atlassian.confluence.extra.graphviz
https://marketplace.atlassian.com/plugins/com.lucidchart.confluence.plugins.lucid-confluence
https://marketplace.atlassian.com/search/advanced?q=diagram+mockup&application=confluence&buildNumber=&category=Image%2C+Visualization+%26+Reporting&pluginSystemVersion=&supportType=&license=&cost=&createdAfter=&createdBefore=&minDownloadsCount=&minimumStars=&search=true
https://confluence.atlassian.com/display/Support/Atlassian+Supported+Plugins

Confluence 5.5 Documentation

Use the Widget Connector macro: (D Loading Twitter

Widget
® Show a live stream of tweets from a Twitter user, or tweets matching i
a Twitter search. Widget
* Display a video from YouTube or other online movie sites. 284381809263472

® Share photographs from Flickr.

® Display slide decks hosted on SlideShare and other online
presentation sites.

® See what else the Widget Connector macro can do.

Showing activity streams

Make your Confluence pages dynamic and interactive with:

® An activity stream showing updates and comments on Confluence
and other linked applications. See Working with Confluence Gadgets.

®* An RSS feed from within Confluence or an external site. See Subscri
bing to RSS Feeds within Confluence.

® A list of recent blog posts from within Confluence. See Blog Posts
Macro.

Working with Templates

When you add a new page, you do not have to write the content from scratch. Instead, you can base your new
page on a template. A template is a Confluence page with predefined content. Some templates are provided by
blueprints or add-ons, others are defined by Confluence users.

Some examples of where templates are useful:

* A software development project may have a template for use cases.
® A systems administration space may have a template for defining what information is kept about each
server.

Global templates and space templates

In Confluence, there are two places to store your page templates:
®* Space templates: These page templates are available in a specific space only. People who have space
administrator permission can define templates via the space administration screen.

* Global templates: These page templates are available in every space on the site. People who have Conf

luence Administrator permission can define the global templates via the Confluence Administration
Console.

System administrators can also download predefined templates.
On this page:

® Global templates and space
templates

® Creating a template

® Using a template

® Templates provided by
blueprints

® Promoting templates in the
Create dialog

® System templates

Related pages:

Adding a Template
Administering Site Templates
Importing Templates
Creating a Page using a
Template

® Confluence User's Guide

Creating a template
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You can write your template using the Confluence editor. You can also add special variables to the page, if you
want to include fields that the author will complete when adding the page. See Adding a Template for more
information.

Using a template

Page templates are used only when adding a page. It is not possible to apply a template to an already-existing
page. Once a page has been added using a template, the template is no longer linked to the page. All further
editing is performed as if the template was never used. Some plugins provide enhanced template functionality.
You can search the Atlassian Marketplace for template add-ons.

See Creating a Page using a Template for more information.

Templates provided by blueprints

A blueprint is a page template with added functionality to help you create, manage and organise content in
Confluence.

Confluence ships with some predefined blueprints.
You can also download additional blueprints from the Atlassian Marketplace. You can customise the blueprint
templates to suit your individual needs, disable particular blueprints or even develop your own blueprints.

See Working with Blueprints.

Promoting templates in the Create dialog

Space administrators can choose to promote specific templates and blueprints in the Create dialog. Promoting
items can help ensure consistency in a space by encouraging users to create particular types of content over
blank pages.

The promoted templates or blueprints will appear at the top, with all other content types, including Blank Page
and Blog Post collapsed under them. To view the other types of content available choose the Show more link.

Create Filter Help
Select space Company Knowledge Base - Parent: Company Knowledge Base
1= How-To Article % Troubleshooting Article
2= | Provide step-by-step guidance for completing a Provide solutions for commonly encountered
task. problems.
Show more

To promote a template or blueprint:

1. Goto Space Tools > Content Tools.
If your space is using the Documentation theme choose Browse > Space Admin > Templates.
2. Choose Promote next to the templates or blueprints you want to appear in the Create dialog.

Remember: by promoting a blueprint or template you will be hiding all other items, including blank page and blog
post, under the Show more link.

System templates

Confluence also provides 'system templates' containing content like the site welcome message and default
space content. See Administering Site Templates.

Adding a Template
A template is a predefined page that can be used as a framework when creating new pages. Templates are
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useful for setting a common style or format for a page.

In Confluence, there are two places to store your page templates:
® Space templates: These page templates are available in a specific space only. People who have space
administrator permission can define templates via the space administration screen.

* Global templates: These page templates are available in every space on the site. People who have Conf

luence Administrator permission can define the global templates via the Confluence Administration
Console.

Adding a space template
Space templates are available in one space only.
To add a template for a space:

1. Go to the space and choose Space tools > Content Tools on the sidebar.
2. Choose Templates > Add New Space Template.

If your space uses the Documentation theme:

1. Choose Browse > Space Admin at the top of the screen.
Note: The 'Space Admin' option appears only if you are a space administrator for the space or you are a
super user (a member of the conf | uence- adni ni st rat or s group).

2. Choose Templates from the space administration options.

3. Choose Add New Space Template.

The 'Create Template' screen will appear. Add content as described below.
On this page:
® Adding a space template
® Adding a global template
® Using the template editor
® The resulting form when the template
contains variables
Adding content to your template
® Labels
®* |mages and other attachments
® Variables used as form fields
® [nstructional text
® Adding a description to your template
® Converting an existing page to a template
®* Notes

Related pages:

Creating a Page using a Template
Working with Templates

Working with Confluence Labels
Working with Macros

Using the Editor

Confluence User's Guide

Adding a global template
Global templates are available in all spaces in your Confluence site.

To add a global template:

1. Choose the cog icon E: then choose General Configuration under Confluence Administration.
2. Choose Global Templates and Blueprints in the left-hand panel.
3. Choose Add New Global Template.

The 'Create Template' screen will appear. Add content as described below.

Using the template editor
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This illustration shows the template editor with an image, some text, styling, and variables.

[l
1|
]

= Punk ETabe v | DTemplate v | +1

Instructional Text

Insert a variable New Variable

Date

il H B B3~ =

Use the editor to format text,

add images, tables and macros )
Location
MeetingName

Time

ﬁ Set the variable type

Meeting Minutes Template <@ Enter the template title
Paragraph - B I | U A - 3 -
A ||| 2|8 gy
Minutes for
Date (3 Date]
Time
Location
Attendees Text  Multiline Text | List
Apologies
Minutes
« Add the first item here. .
> <@ Add labels

The resulting form when the template contains variables

This screenshot shows the form displayed when someone creates a page based on the template containing the
above variables. (See Creating a Page using a Template.)
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Page Template Wizard

Step 2: Fill in template variables

The information you supply will become part of the content in your new page.

_____________________________________________________________________________________________

Minutes for

Status Meeting (MeetingMame)

| Date 15/02/2013  (Date)

| Time 9:00 AM| (Time)

| Location Meeting Room 1 ~ (Location)
| Attendees

. Apologies

. Minutes

| e« Add the first item here...

<= Back Mext ==

Adding content to your template

Add a name for your template.

Enter text into the body of the template, and use the editor toolbar to apply styles, layout and formatting. You can
add links and macros. In general, you can use the Confluence editor in the same way as on a page. In addition,
you can add variables which will produce a form for data collection when someone adds a page based on the
template.

Below are some points of special interest in templates.

Labels

Choose Labels to add one or more labels to the template. These labels will be included in all pages created
using this template.

Images and other attachments

You cannot attach an image or other file to a template. Instead, attach the file to another page, and insert it into
the body of the template.

For example:

® You can attach an image to a page and then choose Insert > Image to embed the image into the
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template.
® You can attach a PDF file to a page and then choose Insert > Other Macros > PDF to embed the PDF
file into the template.

Variables used as form fields

You can add variables to your template, to act as form fields. When someone creates a page based on the
template, Confluence will display a text entry box for each field. The user can enter data into each field, and the
data is inserted onto the new page.

Every variable must have a unique name. If you add the same variable more than once in the same template,
Confluence will make sure that they have the same value when the user saves the page. This is useful if you
need the same information in more than one place in the page.

To insert a variable into a template:

1. Place your cursor on the template where you want the variable to appear.

2. Choose Template > New Variable from the editor toolbar. Alternatively, you can choose the name of an
existing variable if you want the same variable to appear more than once in the template.

3. Enter the variable name.

4. Press Enter. By default this will create a single-line text input field.

5. To change the variable type, click the variable placeholder. The variable's property panel will appear.
Choose one of the variable types: Text, Multi-line Text, or List. See below for a description of each type.

Speeding up variable entry with autocomplete: Type $ and the variable name, then press Enter, to add a
new variable or to select an existing variable from a list of suggestions. The suggestions are drawn from
variables already defined in this template.

These are the types of variable available:

Variable type Description
Text Creates a single-line text input field.

Screenshot: A template variable called $pur pose an
d its property panel

This tutorial helps you to | -

Text Multi-line Text  List

Multi-line text Creates a text box that allows more than one line of
text.

By default, the text area is 5 rows depth and 100
characters wide. You can change the size by typing
over the digits in the variable property panel.

Screenshot: A multi-line variable and its property

panel
Text Multi-line Text  List 3 ¥ 100
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List

Instructional text

279

Creates a dropdown list.

You must specify the values that will appear in the
dropdown list. The values:

®* Must be separated by commas.

® Can include letters, numbers, special characters,
and spaces.

® Cannot include commas (except as the list
separation character).

Screenshot: A list variable and its property panel

Text  Multi-line Text  List Choc Berries,ChocJIRA Fudge Supreme

Instructional text allows you to add placeholder content to a template. This text is only visible in the editor and

disappears when the author of the page begins typing.

To insert instructional text into a template:

1. Place your cursor on the template where you want the instructional text to appear.
2. Choose Template > Instructional Text on the editor toolbar.
3. Begin typing - the instructional text appears in italics with a shaded background to distinguish it from

normal paragraph text.

You can also change the placeholder type from 'text' to other types, including some that trigger an action such

as a user mention or creating a JIRA issue.

The following instructional text types are available:

Instructional text type

Text

User Mention

Description

Creates a line of text that is only visible in the editor.
Instructional text disappears when the user begins

typing.

1A M

Why are you doing this? How does this relate to th

[
T
(7]
1]
=]
T
L]
(=]
41)
[
s

Text  User Mention = JIRA Macro Remove

Creates a line of text that is only visible in the editor.
When clicked it triggers the @mentions dialog.

1 them an action ftem and notify them.

Text User Mention JIRA Macro Remove
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JIRA Issue Creates a single link of text that is only visible in the
editor. When clicked it triggers the JIRA Issues macro
dialog. Users can then search for or create a new
issue.

Text User Mention JIRA Macro Remove

Adding a description to your template

The template description displays in the 'Create’ dialog and is useful for explaining the purpose of a template to
users.

To add a description to a template:

® Go to the space or global templates page (as described above).
® Choose the Edit icon in the 'Description’ column.
® Enter your description and save.

. o Create New Template

User Created Templates Edit description p
Name Description Last Updated By Updated Operations
Blue Sky FAQ Template Useful FAQ template with formatting. # Rach Admin Mar 21, 2013  Edit - Delete

Converting an existing page to a template

If you would like to convert an existing page to a template, you can copy the content from the page and paste it
into the template editor. There is no automated way of doing this.

Please note the section above about images and other attachments in templates.

Notes

® You cannot insert variables via the 'Insert wiki markup' option in the editor toolbar.
Page templates are used only when adding a page. It is not possible to apply a template to an
already-existing page. Once a page has been added using a template, the template is no longer linked to
the page. All further editing is performed as if the template was never used. Some plugins provide
enhanced template functionality. You can search the Atlassian Marketplace for template add-ons.

®* When you use a Table of Contents macro in a template, you will see an error when you preview the
template itself. But the Table of Contents macro works on the pages that people create from the
template — the table of contents shows up after they have saved the page. (This is probably because the
template is not defined as a page, and the Table of Contents macro works for pages only.)

® The editor for templates is available only in Confluence 4.3 and later. Please refer to the earlier
documentation for a description of the wiki markup editor templates.

® Confluence also provides 'system templates' containing content like the site welcome message and
default space content. See Administering Site Templates.

Creating a Page using a Template

You can create a page based on a global template (available to all spaces) or a space template (available only
to that space). Before reading this page, make sure that someone has already created a template on your
Confluence site.

Information copied from the template to the page

When you create a page based on a template, Confluence will copy the following content and information from
the template to the new page:

® |abels
® Text and styles
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® Layouts and formatting

®* Macros

®* Embedded images and other files. Note that you cannot attach an image or other file to a template. But if
the template displays an image or file from another page, the new page will display that image or file too.

Form fields displayed by the template

If the template author included variables in the template, Confluence will display a form prompting you to supply
values for the variables when you add the page.

On this page:

Information copied from the template to the page
Form fields displayed by the template

Using a template to create a page

Notes

Related pages:

Adding a Template

Using the Editor

Working with Confluence Labels
Confluence User's Guide

Using a template to create a page

To create a page based on a template:

1. Choose Create on the header

2. Select a space and the template you want to use and choose Next

3. If the template contains variables, you will now see a form. Type the relevant information into the form
fields, and choose Next.

4. Now you will see